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System Requirements

e Reform 12 Enterprise or Reform 12 PDC
* MOST Plugin

e Alchemy Plugin

e MOST Alchemy Plugin

e For Evaluation and Demonstration: Windows XP, Windows 2003 Server, Windows
Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are Supported)

e For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit
Operating Systems are Supported)

All required Reform software downloads can be found at >> www.fabsoft.com
Downloads section.

Hardware Requirements

Please reference both the Alchemy Plugin Documentation and MOST Documentation
regarding Hardware Requirements.

Other Requirements

e Before starting this manual, MOST and Alchemy for Reform should be working
properly.

Installation

To install MOST-Alchemy to your existing Reform 12 installation, you will need to download
and run the MOST-Alchemy installation executable.

Step through the prompts and accept the User License Agreement. Allow the installation to
complete.

The default installation directory for Reform 12 and its plugins is C:\ProgramFiles\Reform...\.
If you have changed the path during the Reform installation routine, or if you are using a 64 bit
operating system, please refer to the appropriate path instead of the default one referenced
throughout this documentation.
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After the installation, the MOST Manager should be restarted (may be running as a

Service) as it requires newly added files to be loaded upon startup. To open the MOST
Manager, go to Start>Programs>Reform...>MOST>Manager. Press the red Stop button
and then the green Start button to do so.

i ]
Ele  Edit Tools Window  Help
L IE =
Log | Stats
= Connections Date Time Status ~
k5250300187 9/24/2009  44354PM  Login complste
L3EERA00347 9/24./2009 44354 PM  Sending file to client: Logout.brp
Manager 9/24/2009 44354 P Sending file to client: Logout.bmp
9/24./2009 44354 PM  Sending file to client: Logout.brp
9/24/2009 44354 PM Activating cached user data
9/24/2009 44354 P Authentication successful
9/24/2009 44354 P Authenticating uzer: tuborial
9/24/2009 44353PM  Login started
9/24/2009  441:53PM  Logowt
9/24,/2009 4:40:24 P Login complete
[ - 9/24/2009 4:40:24 PM Sending file to client: Logout. bmp
Comnection Infomation 9/24/2009 4:40:24 PM Sending file to client: Logout. bmp
9/24/2009 4:40:23 PM Sending file to client: Logout. bmp
Serial  L3B65900347 9/24./2009 4A4A0:23PM  Sending user data
IP- 192 168,087 9/24./2009 44023 P Authentication successful
. T 9/24./2009 4:40:22 P Authenticating user: tutarial
Aliaz  [Mone] 9/24/2009 4:40:22 P Login started
Lodin: 9/24/2009 43946 P Authentication failed b
ogir:  [Mone) < 3
Started

The Reform Spooler Service must also be restarted. This is to allow the Spooler to
recognize the newly installed forms. Open up the Spooler by going to Start>Programs>
Reform...>Spooler. Click the Refresh button or the red stop button and then the blue
start button.

(@ Reform12 Spooler. Monitor - Unicode - Unregistered Version

File Action Log Help

00 afs

Forms Process Results
| Form Mame Description SEC....
Start Service Account: Metwork Senice
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Importing MOST Screen

Please refer to the MOST manual for more information regarding MOST terminology,
MOST Setup and Connection Test.

To import Most screens Go to Start > Programs > Reform...> MOST-Alchemy > Install

MOST Screens

[ Ricoh_Reform_PDC_v12 OST-Alchemy 4 n Install
I Startup
... -

This will install Alchery screens in o the MOST designer|

If not already open, MOST Designer will appear. You will be prompted if you want to
Import Alchemy into MOST. Click Yes. If asked if you want to overwrite files, click Yes.

Import [%|

‘?1/ Import Alchemy inko MOST?

You can leave MOST Designer open as it will be used in the following section.

MOST Manager Service

If running the MOST Manager as a service, the service logon account must have the
correct permissions to access the Alchemy server. To check which account the service
is running as, go to Control Panel>Administrative Tools>Services.

File Action View Help

& [FlEd= HEl»mnn

., Services {Local)

£} services (Local)

MOST 2.4 Manager Mame = | Descripkion | Status | Skartup Type | Log Cn As | ;I

‘EhMicrosoft Fibre Channel Platform R,  Registerst... Manual Local Service
Skop the service ‘EhMicrosoft 1SCSI Initiatar Service Manages ... IManual Local System
Restart the service 0 _ —
Description: T
FabSoft's MOST Manager 5 Met, Tep Port sharing Service Provides a... Disabled Local Service LI
% Extended 4 Standard /

Network Service/Local System may or may not have enough permission depending on
your environment. To change the service logon account, right click on MOST 2.4
Manager and go to Properties. Select the Log On tab.

form®12 Alchemy For MOST
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"General LogOn | Hecnver_l,ll Dependenciesl

Log on az:

" Local System account
[T &llow service to interact with deskiop

&+ Thiz account: I Browse. . |

Password: |

Confirm password: |

Help me configure user account log on options.

Cancel | Epply |

Here you can enter the account and password for an account that has access to the
Alchemy server. It is recommended to use a domain account with administrative
privileges on both the MOST server and the Alchemy server. Once completed, click the
OK button. The service will need to be restarted for the new changes to take effect.
This can be done by right clicking on the service and selecting Restart or simply by
stopping and starting the service.

Setting Global Variables

We need to setup the communication beween MOST and Alchemy. To do so, we have
to configure certain parameters in MOST’s Global variables screen. If the MOST
Designer is not already open, go to Start>Programs> Reform... >SMOST>Designer.

On the MOST Designer’s menu, go to Data>Global Variables

@ MOST Designer Q@E|
File  Edit View m Tools  Window  Help
R R == N Users and Groups. ..
Collections. ..
» Advanced Search ‘ Global Yariables. .
Static Data...
D et et Display Properties...
¥ Log Out Prozimity Card Data... Save TaFile

» Preview H

» Process
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These are the Global Variables required to access your Alchemy server. For more
information about the global variables, please see the Reform Alchemy documentation.
Select each variable one by one, enter its value in the provided box and then click the
update button.

N

Variable Name =AlchemyCacheExpire Value= 20

Variable Name=AlchemyDomain Value =<Your Domain>
Variable Name=Alchemy Server Value=
http://SERVERNAME/AuWebService/AuWebService.asmx
Variable Name = AlchemyTimeout Value= 20

Global Yariables

Encrypt | Wariable

| Walue |

O
O
O
!

AlchemyCacheE zpire 20

Alchemyl omain CompanyD omain

AlchemyS erver hittp: ASERVE RMAME fiw/ebService/buin'eb.. .
AlchemyT imeout 20

Click File>Save or use the small save icon e to save all the global variables.

Assigning the Alchemy Collection to Users

1. Open your MOST Designer if not already opened (Start>Programs> Reform...
>MOST>Designer).
2. On the MOST Designer tool bar, click on Data > Users and Groups

& MOST Designer,

File  Edit  Wiew

- = &

- Buttor Objects

b Advanced Search

b Edit Data

¥ Log Out

Data I Tools  Window  Help

Users and Groups. ..

Collections...

Global variables. ..

Skatic Data...

Display Propetties. ..
Y alue

Proximity Card Data. .. et ame

3. Select the user you want to assign the Alchemy collection to. The user that you

are assigni

ng the Alchemy collection to must be able to authenticate to the

Alchemy server. To add a new user, use the Add button. For the tutorial, we will
be using the user demo.

form®12 Alchemy For MOST
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— Uszers/Groups — Settings
= Users Login Timeout: IU 3: Scan Mode: IAuto Feeder 'l
- Groups Color: | Monochrame - Sides: | One Sided -
i Domain Users Compression: I WH - l File Type: I TIFF - l

Drenszity: IDefauIt 'l Scan Type: IMixed 'l
R esolution: IBDD dpi 'l Size: IAuto 'l

i Collections

Available Collections: Selected Collections:

Save ToFile
Email
Admin

=5

Add Femove | e | - |

4. Select Alchemy from the Available Collections and click the
Alchemy collection for the selected user.

to add the

5. File>Save or use the small save icon |4 to save your changes.

MOST Alchemy Tutorial

The emulator shows you exactly what you would see on an MFP and it functions in the
same manner. This same process could be tested with the same exact steps, but by
installing MOST on the MFP by following the instructions in the MOST manual. (Please
refer to the MOST manual on how to setup MOST on a MFP.)

1. Login to MOST at an MFP or use MOST Desktop (Start > Program > Reform...>
MOST>Misc>MOST Desktop).

Username: demo (The Username that was just added)
Password: demo (The Password for the username added)

form®12 Alchemy For MOST
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File

fapsSoer

www.fabsoft.com

lzername: | demo

Pagzword:

‘ Log In ‘

Remember Me

B2009 FabSoft

w22, 00825, 622

2. The emulator will now connect to the MOST server and login. It may take several
seconds to log in, since MOST must connect to the Alchemy server to retrieve the

account settings.

B MostT
File

Database/Folder:

"

Scan to Captaris Alchemy

O]

Document Informat ion:

a Log Out

sScan

3. Use the Database/Folder drop down menu to see a list of available folders. Click

anywhere on the combo box to pull up this list.

eform.12
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M rost 1= B3
File

Database/Folder:

Scan to Captaris Alchemy

Al chemy

Folder 1/Test1
Folder 2/Test2
Folder 3/Test3
Folder 4/Testd/Testd-1
Folder 5/Test5/Test5-1
Folder 6/Test6/Test6-1

3 Log out Scan

4. After selecting a destination Database/Folder, the list box will be populated with
The document’s properties. These are the properties set on the Alchemy database.
To enter information for the fields, simply click the shaded area next to the field

name.
File

..... | Scan to Captaris Alchemy
I | Database/Folder:
Al chemy
[ Folder 1/Test1 Ed
Document [nformat ion:
Document Title —
Document Mummber I
Document Owner
Diocument Type
PressiClick to fill in field.
B Loy out Scan

5. The above procedure can be repeated for each desired field.

,fOI'sz Alchemy For MOST
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File
Scan to Captaris Alchemy
Databaze/Folder:
Al chemy
[ Folder 1/Test1 |~
Document  [nformat ion:
Document Title Test Document 1
Docurnent Murmber 123456788
Document Cwner UserMame
Document Type Sales Order
B Log out Scan

6. After you have finished populating the properties for the document, click the
green Scan button to send your document to the Alchemy server.

® mosT M= B

File

Database/Folder:
[ Folder 1/Test1 Ed

Document  Informat ion:

Scan to Captaris Alchemy

Al chemy

Document. Title
Document Mumhber
Document Owner

Diocument Type

Test Document 1

123456789

UserMame

Sales Order

a Log Out ‘ Scan

7. You have completed the Alchemy tutorial. You can check that the document has
successfully uploaded to the Alchemy server. If you do not see the document,
please make sure you are able to upload documents using the Reform 12 Alchemy
plugin by referencing the Reform Alchemy Documentation.

,fOI'sz Alchemy For MOST
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Maintenance

There are certain directories that need to be monitored for growth along with the Alchemy
plugin for Reform 12. As a system processes more and more jobs, the size of these
directories can grow very quickly. Overall system performance can be affected by the large
amounts of space that the files may take up. Obsolete files should be deleted according to
your needs and file retention specifications. It is recommended to monitor the following
directories for growth:

Directories:
C:\Program Files\Reform...\Backups
C:\Program Files\Reform...\Spooler\ImageQueue

Troubleshooting

1. If you are having problems connecting to your Alchemy server using the Reform or
MOST, it is important that the server allows connections from your computer and
service accounts for Reform Spooler and MOST Manager. The MOST Manager service
account is responsible for viewing Alchemy directories on the MOST screen. The
Reform Spooler service account is responsible for uploading the document when
the Scan button is clicked. Both these services should have access to the Alchemy
server.

Open up a Internet Explorer page. Type in http://ALCHEMYSERVERNAME/AuWebService/
AuWebService.asmx in the address bar

Make sure you are have access to this page. If you are prompted with a login, please
login with the correct credentials.

When you connect successfully, you should see the following:

UE A @ uwebservice Web Service 2 - B - o - reege - (G Took

AuWebService

The following operations are supported. For a formal definition, please revie:

« EngineStatus
« IdentifyCaller

s ProcessRequest

This web service is using http://tempuri.org/ as its default namespace.

the XML Web service is made publi

ient applications to distinguish it from other s
der development, but published XML Web se

Your XML Web service should be identified by a namespace that you control. For example, you can use your company's [nternet domain name
part of the namespace. Although many XML Web service namespaces look like URLs, they need not peint to actual resources on the Web. (XML
Web service nam

can be changed using the WebSen 2mespace property. TH
the XML Web service methods. Belo de example that sets the

using ASP.NET, the default namesi
ribute applied to the class that conta

[WebService (Namespace="http: //microsoft. com/webservices/") ]
public class MyWebService {

// implementation
3

Wisual Basic

<WebService (Namespace:="http://microsoft.com/uebservices/")> Public Class MyWebService
' implementation
End Class

form®12 Alchemy For MOST
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Try running through the MOST Alchemy tutorial again after successfully connecting.

2. It is also important to note that the user in MOST that has access to the Alchemy
collection must also be able to authenticate to the Alchemy server.

3. If running MOST as a service, please see. MOST Manager Service

Other company or product names mentioned herein may be trademarks or registered
trademarks of their respective companies
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