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System Requirements
® Reform 12 Enterprise or Reform 12 PDC
® MOST Plugin
® MOST BubbleSheet Plugin
® Email Plugin
® For Evaluation and Demonstration: Windows XP, Windows 2003 Server,

Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are
Supported)

® For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit
Operating Systems are Supported)

All required Reform software downloads can be found at www.fabsoft.com >>
Downloads section.

Hardware Requirements

Please refer to the MOST Documentation regarding Hardware Requirements.

Other Requirements

® MOST must be configured before installing.

Installation
To install MOST-BubbleSheet to your existing Reform 12 installation, you will need to
download and run the bubblesheet.exe installation executable.

bubblesheet

Step through the prompts, and the installation will begin. After you have completed the
installation of MOST-BubbleSheet, the Reform Spooler Service must be restarted.
Open up the Spooler by going to Start>Programs>Reform..>Spooler. Click the Refresh
button or the red stop button and then the blue start button.
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Reform12 Spooler Monitor - Unicode - Unregistered Version

File Action Log Help

00 2R

Forms Process Results

Forrm MNare Drescription SEC

Start Service Account: Metwork Service

The default installation directory for Reform 12 and its plugins is C:\Program
Files\Reform...\. If you have changed the path during the Reform installation routine,
or if you are using a 64 bit operating system, please refer to the appropriate path
instead of the default one referenced throughout this documentation.

Importing Most Screen
Please refer to the MOST manual for more information regarding Most terminology,
Most Setup and Connection Test.

To import the MOST screens that you will be using with BubbleSheet go to
Start>Programs>Reform...>Bubble_Sheet>Install Bubble Sheet for MOST

{.j Manager ¥ Microseft Update [ Bubble_Sheet P Install Bubble Sheet For MOST
-Jﬂ Accessaries 4 -Jﬂ MOST 4 ser Manual

{j} MOCST Deskiop d‘j Startup » E Diesigner
£ Internet Explorer ff| Install windows Printer

0L . = t Expl Install tind Prink
Erver Car —

% Manager ﬂ LogMeIn | Spooler
[ Outlack Express Liser Manual Printable POF
.. Remote Assiskance @ Iser Manual Searchable

llﬂ Microsoft SOL Server 2005k ‘ideo Training Center
ﬁ Ricoh_Reform_PDC_wlZ 3 2, ‘WorkFlowv Designer

all Programs

If not already open, the MOST Designer will appear and you will be prompted to import
the screens. Click Yes.
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Import |

‘?rj Impork Bubble_Sheet into MOST?

Leave the MOST Designer open as we will be using it next.

Assigning Collection to Users

1. If MOST Designer is not already open, Go to
Start>Programs>Reform...>MOST>Designer
2. On the MOST Designer tool bar click on Data>Users and Groups
3. Under Users, click on demo (the user demo is used for the tutorial, but you can
add this collection to any user). Select BubbleSheet from the Available Collection
and click the d to add the BubbleSheet collection. Go to File> Click on Save
or click the | icon in the toolbar.
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File Edit Yiew Data Tools ‘window  Help
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- Button 0
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b Log Out
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¥ Save ToGlobal

» Smart Search
-«

- CheckBox Objects

¥ CheckBox

» Enable/Disable Add Remove Y . |

T abs and Collec

5 Users and Groups® (% |Glnhal Variables (%
T_LDAP_Sav

T_Save ToFile
i Users/Groups ~ Settings IT_Savel oFile_Statuz
M= eee Login Timecut: IU 3: Scan Mode: IAuto Feeder hd G .
Email

le_Sheet_EditT ester

- Domain U sers Compressian: | MMF - File Type: ITIFF 57 le_Shest_RemoveT ester

T_Email

Density: IDefault 'l Scan Type: IMmed i T_Email2

Calar: IMonDchrome vl Sides: IDHE Sided - le_Sheet_fddT ester J

T_LDAP_Email
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Admin

Object Properties

Emai Users and Groups
Scan To Folder
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Configuring Email
Go to Start>Programs>Reform>MOST>Designer and go to Data>Global Variables...

& mosT Designer

File  Edit iew | Data | Tools ‘Window  Help

hE L'i" Gi IUsers and Groups, ..
- Button Objects Colleckions. ..
b Advanced Search | Global Wariables. ..
Static Data. ..
- et Bl Display Properties. ..
b Log Out Proccimity Card Data...
LH

Make sure to fill in the email variables with correct information. You might need to fill
out all the fields if your email setup requires them.

lobal Yariables™ X |
— Global ¥ ariables

E ncrvpt | " ariable | W alle |
O CommunicationT ype Local
O EmailSersert ame 'ourE mail3 ervert ame
O EmailServerT ype SMTP
O EmailT o5 elf True
O E mailllzertd ame
E mailllzerPazsword
O Exchangedlias

MOST BubbleSheet Tutorial

At this point, you should have a basic understanding of the functionality of MOST. In this
tutorial, we’re going to be using the MOST Desktop to simulate an MFP running MOST
and connecting to a MOST server. This tutorial assumes MOST connectivity has already
been configured and established. (The MFP required for testing the Print Status
functionality of this tutorial. Please refer to the MOST manual on how to setup MOST on
the MFP or any other MOST related issues.)

The emulator shows you exactly what you would see on an MFP, and it functions in the
same way. This same process could be tested with the same exact steps, but by
installing MOST on the MFP by following the instructions in the MOST manual.
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1. Login to MOST at an MFP or use MOST Desktop (Start > Program >
Reform...>MOST>Misc>MOST Desktop) using the username and password for
which you gave the BubbleSheet collection to. In the tutorial, we configured the

user demo, password demo. Click Log In.

M mosT
File

B2009 FabSoft

= B3

form

Reform Your Business Platform

Uzername: | demo

Password: | #sk

Loz In

Remenber Me

w2, 3.91112.628

2. The emulator will now connect to the MOST server and login. Once it logs in, you
will see a series of collections and tabs. For this tutorial, we will be using the
BubbleSheet collection and tabs which you have made available to the user.
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M MosT M= E3
File

Bubb | eShest

Print Bubble Sheets
s Rezults Humber of Students
Add Tester
Search Class Mame

Del Tester

Search Class Description
Add Class
Edit Class Search Class Location

Scan #0nly Classes with students will be displaved.
Test Mame:
a Log Out Print Test Sheets

3. From your BubbleSheet collection you will see the Print Test screen which allows
you to print documents. The first thing we want to do is go to the Add Class tab.
On the left, click on Add Class tab and fill out fields with the following
information:
Instructor Name: Luna Cruz
Class Name: 2" Grade
Class Description: 2" Grade
Class Location: Room 202

Click on Save to add the Class.
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¥ MOST
File

Print Test

Bubb | eSheet

Add Tester

Del Tester

&dd Class

Edit Class

Scan

Inst ructor Mame:

Class Mame:

Class Description:

Class Location:

= O %

a Log Out

Reset

= save

After clicking Save, we want to add a tester to the class we created. Type the name of
the tester and click on the class you want to add them to. Add the following tester:

Test Taker Name: John Doe

Click on Save to add the Tester.

M mosT
File

Print Test

Add Tester

Del Tester

&dd Class

Edit Class

Scan

Bubb | efhest

Test Taker hame:

Class:

John Doe

Clazs Mame

Znd Grade

Clasz Description

2nd Grade

a Log Out

Reset

i Save
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After clicking Save, we want to add another tester to the same class. Add the following
tester:

Test Taker Name: Jane Doe

Click on Save to add the tester.

& mosT M= B
File

Bubb | eshest

Print Test
Add Tester Test Taker Mame: [Jane Doe
Class Name Class Description
Del Tester ~ - ~ -
Class: 2rnd Grade 2nd Grade
&dd Class
Edit Class
Sean

a Log Out Reset ﬁ Save

4. On the left, click on the Print Test tab. Click on the Search Class Name and leave
the field empty to return all the classes. You should only see 1 entry in the list
because the 2 test takers we added are in the same class, which is 2" Grade.
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M mosT o=l

File

Bubb| eSheet

Brint Toct Print Bubble Sheets

e —— Results Number of Students

Add Tester
Search Class Name

Del Tester

Search Class Description
Add Class
Edit Class Search Class Location

Scan #0nly Clazses with students will be displaved.
Test Name:
a Log Out Frint Test Sheets

We want to add another class. On the left, click on Add Class tab and fill out fields with
the following information:

Instructor Name: Luna Cruz

Class Name: 3™ Grade

Class Description: 3" Grade

Class Location: Room 303

Click on Save to add the Class.
™ mMosT M=

File

Print Test

Inst ructor Name: ‘Luna Cruz ‘
hdd Tester
Del Tester Class Name: ‘3rd Grade ‘
bdd Class Class Description: ‘3rd Grade ‘
Bdit Class Class Locat ion: ‘Room 303 ‘

Scan
a Log Out Reset Fi Save
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After clicking Save, we want to add a tester to the 3" Grade class. Add the following
tester:

Test Taker Name: Jenna Doe

Click on Save to add the tester.

& rmost s E3
File
Bubb | eSheet
Print Test
hdd Tester Test Taker Mame: |Jenna Doe
Clazs Name Class Description
Del Tester
Class: 2rd Grade ?nd Grade
add Class 3rd Grade 3rd Grade
Edit Class
Scan
a Log Out Reset = Save

5. On the left, click on the Edit Class tab. Click on the Class button and leave the
field empty to return all the classes.
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M Mmost MiE E3
File
Bubbleshest
Enter the Class Mame, Description
Search Classes: Class .
Print Test or Location as the =earch word.
Inst ructor Clasg Name Clazs Description Class Location
bdd Tester
Lura Cruz 2nd Grade 2nd Grade Room 202
Luna Cruz 3rd Grade 3rd Grade Room 303
[el Tester
bdd Class
Edit Clas=s
Sean
Inst ructor: Class Mame:
Class Desc: | ‘ Class Loc: ‘ |
a Log Out Reset Save

6. Select Luna Cruz, 3" Grade from the list to edit her information and click on Save
when finished. Click on the Class button to refresh the list and you should see
the new information.

Instructor Name: Luna Cross
Class Name: 4™ Grade

Class Description: 4™ Grade
Class Location: Room 204

form12 BubbleSheet



BubbleSheet For MOST 14

M mosT [_ (O] <]
File
Bubb | e8hest
Enter the Class Mame, Description
Search Classes: Class .
Print Test or Location as the search word.
Instructor Clags Name Class Description Class Location
bdd Tester
Lura Cruz 2nd Grade 2nd Grade Foom 202
Lura Cross 4th Grade 4th Grade Room 204 |
Del Tester
Add Claszs
Edit Clas=
Scan
Inst ructor: Class Mame:
Class Desc: ‘ ‘ Class Loc: | ‘
a Log Out Reset Save

7. Go back to Print Test tab and click on Search Class Name and leave the field
empty to return all the classes. You will see the 2 entries. Select 2" Grade from
the list.

M mosT [_ O] x]

Bubblesheet

File

Print Test

idd Tester
Search Class Mame

Del Tester

Print Bubble Sheets

4th Grade

Search Class Description

hdd Class
Edit Class Search Clazs Locat ion
Scan #0nly Classes with students will be displaved.
Test Name:
a Log Out Print Test Sheets
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8. A MFP is required to print the Test Sheets. Type in the Test Name and click on
the Print Test Sheets button. The number of test sheets printed will depend on
the number of students within the class plus a copy for the instructor.

Mrost [_ [
File

Bubb | eSheet

""" Print Bubble Sheets

Print Test

................................................... Results Number Uf Students
4dd Tester nd Grade 2
Search Class Mame nd Grad

4th Grade 1

Del Tester

Search Class Description
idd Class
Edit Class Search Class Location
Scan #0nly Classes with studentz will be displayed.

Test hame: 2nd Grade Test

a Log Out Frint Test Sheets

9. Now go to the Del Tester tab, click on the Test Taker button to refresh the list.
Select Jane Doe to be deleted. Click on Remove button to delete Jane Doe from

the list.
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& most [_|)

Bubb | eSheet

File

Mame Class Mame Search Studerts:
Print Test Jane Doe 2nd Grade
i T Jenra Doe 4th Grade Test Taker
ester
John Doe 2nd Grade
Del Tester
Leave the search
blank to list
bdd Class all students.
Edit Class
Scan
a Log Out Remove

Wait a few seconds and click on Test Taker to refresh the list. You should be
able to see that Jane Doe has been removed from the list.

|
M| mosT [_ [}
File

Bubbleshest

Mame Class Mame Search Students:
Print Test Jenra Doe 4th Grade
John Doe 2nd Grade Test Taker

4dd Tester

Del Tester
Leave the search
blank to |ist

&dd Class all students.

Edit Class

Scan
a Log Out Remove
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10. Go to the Scan tab when the tests are completed and click on the Scan button.

M most = |
File

Bubb | efheet

- Scan completed tests with Tag Doc barcodes
Add Tester
Del Tester Faze Orientation: ‘ buto ‘ A |
Add Class
Edit Class
Scan

a Log Out Scan

11. Click on the Logout button to end the tutorial.

& Mmost =] o]
File

Bubb | efheet

- Scan completed tests with Tag Doc barcodes
bdd Tester
Del Tester Paze Orientation: ‘ buto | - ‘
4dd Class
Edit Clazs
Scan

a Log Out Scan
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Maintenance

There are certain directories and SQL tables that need to be monitored for growth along
with the Ricoh BubbleSheet plugin for Reform 12. As a system processes more and
more jobs, the size of these directories and SQL tables can grow very quickly. Overall
system performance can be affected by the large amounts of space that the files may
take up. Also, there exists a 4GB database limit if using the Microsoft SQL Server
Express 2005 supplied with this installation. Obsolete files/database entries should be
deleted according to your needs and file retention specifications. It is recommended to
monitor the following directories and SQL tables for growth:

Directories:

C:\Program Files\Reform...\Backups

C:\Program Files\Reform...\Spooler\ImageQueue

SQL Tables:
Reform_BubbleSheet_Groups
Reform_BubbleSheet_Students

Other company or product names mentioned herein may be trademarks or registered
trademarks of their respective companies
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