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About the DocumentMall Plugin 
The DocumentMall plug-in acts as a bridge between Reform and DocumentMall.  It 
allows you to archive processed forms to a DocumentMall account for later retrieval.  
The plug-in is very flexible, as it allows you to set up the DocumentMall account with 
static and/or dynamic values, which allows you to better organize your documents. 
 
Reform 12 maximizes the integration with Ricoh's DocumentMall by enabling automatic 
delivery of document information from any operating system, application or device. 
Whether a document is being printed from the host, scanned in using an MFP or copier, 
or generated by a user from an application, Reform will capture the process, extract the 
text and intelligently archive it to DocumentMall. With Reform’s alternative input 
options, more of your valuable information can be effortlessly accessed and easily 
shared company-wide through DocumentMall. Reform can control directory locations as 
well as custom index information to simplify document retrieval. Full text searches can 
be performed to quickly find specific information stored in PDF, TIFF, or any other files. 
Fast and easy access to important information is an extremely vital resource, and 
Reform’s integration capabilities to DocumentMall let you obtain the most 
comprehensive document information archive to improve the workflow of your 
business operations. 
 

System Requirements 
 Reform 12 Enterprise or Reform 12 PDC 

 DocumentMall Plugin 

 DocumentMall Upload Agent Monitor – This will be automatically installed with 
the DocumentMall Plugin during the installation. 

 For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 
Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 
Supported) 

 For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 
Operating Systems are Supported) 

 Microsoft .NET Framework 2.0 (this will be automatically installed if the installer 
does not find it on the system) 

 

All required Reform software downloads can be found at www.fabsoft.com >> 
Downloads section. 

 

Hardware Requirements 
 Production System Recommendation (These suggestions are only estimations. 

High load environments may require multiple servers, or additional hardware.) 

http://www.fabsoft.com/
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1. Pentium 4 Processor 
2. 4 GB RAM 
3. HDD Space 100 GB (Redundancy recommended) 
4. Battery Backup (UPS) 
5. Dedicated server, no other software products except for virus and 

security programs. 

 Minimum System Requirements for demonstration purposes only 
1. Pentium 4 Processor 
2. 2 GB RAM 
3. HDD Space 30 GB 

 
Hardware specifications depend greatly on the workload and throughput that is 
required.  Higher end processors and greater amounts of memory will increase the 
amount of information and data that Reform can process thus improving overall system 
throughput.  For load balancing or failover, multiple servers can also be used. (Note: A 
license for Reform and each plug-in is required for each server running the software.) 
Before obtaining the server that you plan on utilizing for Reform, please check the plug-
ins’ user manuals for System Requirements as well as they may require additional 
hardware.  For production systems, we also recommend redundant hard drives utilizing 
the mirroring features of RAID (Redundant Array of Independent Disks) to minimize data 
loss and expedite system recovery in the event of a hardware failure.  Battery backups 
are also suggested to maintain system uptime and reliability in case of power failures.     
 
 

Installation 
To install the DocumentMall Plugin components, download and run the installer. 
 

 
 

Step through the prompts and accept the User License Agreement. The installation will 
begin.  The DocumentMall Upload Agent Service is automatically installed and started 
when you install the DocumentMall Plugin. The Microsoft .NET Framework will be 
automatically downloaded and installed if it is not already present on the system. Allow 
the installation to complete and then read on to the next section to learn how to set up 
DocumentMall integration. 
 
The default installation directory for Reform 12 and its plugins is C:\Program 
Files\Reform…\.  If you have changed the path during the Reform installation routine, 
or if you are using a 64 bit operating system, please refer to the appropriate path 
instead of the default one referenced throughout this documentation.  
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Plugin Registration and Licensing 
When evaluating Reform 12, the plugins will also be in an evaluation mode for that 
period of time.  Once Reform has been purchased and licensed, the required plugins 
must also be licensed in order to continue functioning correctly.    
Please see the “Reform 12 Licensing and Registration” section of the Reform 12 User 
Manual for more information on how to license Reform 12 Plug-ins.  After the license is 
entered, the Reform Spooler will need to be restarted to refresh the licenses. More 
information regarding the Reform Spooler Service can be found in the Reform 12 User 
Manual. 
 
 

Sending Your First Document to DocumentMall 
Implementing DocumentMall integration into your workflow consists of installing the 
plug-in, entering your DocumentMall account information into the Upload Agent 
settings, and setting up your form. Since we have already covered the installation 
process, the first thing we need to do is add an account to the DocumentMall Upload 
Agent. 

1. DocumentMall might run right after you install it.  If so, you should see the  icon 
in the system tray (next to the clock).  Double click on this icon to bring up the 
DocumentMall Upload Agent. 

2. If it is not running, you can start it by going to:  
Start>Programs>Reform…>DocumentMall>Upload Agent 

3.  Open the options window by going to Edit>Options. It will prompt you for a 
password. The password is: 

dmuaconfig 
4. Click on the Accounts item in the left list. 

5. Click the  button on the right to add a new account. We are going to add the 
FabSoft Tutorial account that has been set up for demonstration purposes.  

6. Enter the following information: 
Account Name: FABSOFT 
User Name: tutorial 
Password: tutorial 
Account Type: Production 

Select the option Include this account when creating synch.xml files. 
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Make sure that you check the option ‘Include this account when creating synch.xml 

files’! 
7. Click Save to save your options.  
8. In the main window of the Upload Agent, go to: 

File>Generate Synch.xml Files 
 

 
 

9. Click OK at the prompt. Wait for the process to finish. After it completes, you can 
close the DocumentMall Upload Agent. 
 

 
 

10. Now we need to configure Reform. Open the Reform Designer by going to 
Start>Programs>Reform…>Designer. 

11. For the example, we will be creating a new form with an existing template. In the 
Reform Designer, go to File>New>New. Select the DocumentMall.FTM and click OK. 
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12. When it asks if you would like to open a text file for designing, select No. 

 
13. Next, go to File>Save to save your form. Name it DocumentMall.FOM. 

14. You can now close the Reform Designer since we have our form which we will be 

using alongside the Workflow Designer to route the document. 

*Now that we have our form, we can begin to create the desired DocumentMall 

workflow using the Workflow Designer.  First, the Workflow Designer must be started.   

15. To open it, go to Start>Programs>Reform…> Workflow Designer. 

16. Once open, we must go to File > New… 

 

17. Select “Document Automation” and click Ok. 
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18. You will now notice that your Inputs, Processes and Outputs have been populated by 

the various plugins you have installed (DocumentMall being one of the Outputs) 
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19. We can now start adding the necessary components to the workflow.  First, drag 

and drop a Form and File object onto the workflow by clicking and holding your 

mouse on Form and File and then moving your mouse over to the workflow and 

releasing the mouse button.  

 
*You will be prompted with the following dialog: 

 
20. Enter a description for the object you just added.  This is done by typing in the 

provided box.  Type “DocumentMall Demo” and click Finish. This will take you back 

to your workflow. 

21. Now we are ready to configure the “DocumentMall Demo” form and input file.  To 
do so, right click on the newly added object and select “Configuration…” or simply 
double-click on it. 
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22. You are now presented with the Input Setup window.  First, we want to select the 
TextFile or data stream that our form will be using.  To do so, you can simply begin 
typing in the box, or you can browse to find it.  We want to select the 
DocumentMall.out file from \Reform…\Backups\.  Click the small folder icon to 
bring up a window which will let us choose that file.  Select the file and click Open.   

 
23. After choosing the text file, you are taken back to the Input Setup page so that you 

can select a form.  Click the small folder icon to bring up a window which will let us 
choose the desired DocumentMall.FOM form file.  Select the file and click Open.  
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24. Now that you have both your Input Text File and Reform Form selected, the setup 
of Form and File is complete.  You can quickly double check that the correct files 
are selected and then click Finish.  

 
 

25. You will also be prompted to add a page-break field to the forms.  At this point, we 
want to select No. 

 

26. To finish the DocumentMall workflow, we want to add a DocumentMall Output.  
We use the same drag and drop procedure as with the Form and File (see step 19).  
Take your mouse and drag the “DocumentMall” object from under Output onto 
the workflow somewhere below your Input.  Once you release your mouse, you 
will be prompted to describe “DocumentMall”.  Type “DM Upload” in the box and 
then click Finish. 
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27. Once you click Finish, you are taken back to your workflow.  Your DocumentMall 
will have a Red Caption because it is not yet configured. To configure 
DocumentMall, you must first connect the Form and File object titled 
“DocumentMall Demo”.  To do so, first select the “Add Connector” button from 
the menu bar.  Next, drag your mouse from the small “x” underneath 
“DocumentMall Demo” to the small “x” above “DM Upload” as pictured below. 
When the connection is complete, the connecter will turn black (if red, connection 
has not been made correctly, try again) and the “DocumentMall Demo” caption 
will turn green. 

 
28. You will be prompted to configure DocumentMall upon completing the 

connection.  Click Yes.  If you chose not to, you can also double click on the 
DocumentMall object or rightclick and select “Configuration…” This configuration 
will step you through all the settings necessary for DocumentMall to successfully 
connect to a DocumentMall server and upload files.  The first piece of information 
is the file type you want your document to be archived with into DocumentMall.  
Select “PDF File” and click Next. 

 
 

29. The second prompt will ask you for the File Name. This is what will be used to 
identify the document once it is posted into a Document Mall cabinet. Here we 
would like to use data that is available in the data stream instead of a static value.  
To do so, we first must click the “Click here to select variable information” button.  
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*Note-After doing so, we see that a list will appear with the different fields that you 
can choose for your variable data.  If you want to go back to static input mode, you 
can do so by clicking the appropriate button for static information and then you will 
be able type static information. 
 

We want to use DealerName as our “File Name” value.  To do so, select DealerName 
from the list and click Next. 

 



Reform To DocumentMall  14 

 

 

                                                            

30. For “Title”, we would like to again use variable data from the print stream.  To do so, 

first click the button “Click here to select variable data”.  From the list that appears, 

select IssueDate and click Next. 

 
31. The next prompt will ask for the Subject. For “Subject”, we would like to use variable 

data from the print stream.  To do so, first click the button “Click here to select 

variable data”.  From the list that appears, select Doc Type and click Next. 
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32. Next piece of information needed is the DocumentMall account to use. This will list 
all accounts that have been set up in the Upload Agent. Select the FABSOFT account 
and click Next. 

 

 
 

33. Next it will ask you which Document Mall directory you would like to upload the file 
to. Select /Tutorial and click Next. 
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34. It will now ask for the permission set. Choose Tutorial=Tutorial, then click Next. 
 

 
 

35. It will ask you for the document type. Select the object PRICELIST and click Next. 
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*Now it will ask you to select the attributes associated with the PRICELIST document 
type. 
36. The first attribute is ISSUE DATE.  We would like to use variable data from the print 

stream for this attribute.  To do so, first click the button “Click here to select 
variable data”.  From the list that appears, select ISSUEDATE and click Next. 

 
37. The next attribute is the Branch. We would like to again use variable data from the 

print stream for this attribute.  To do so, first click the button “Click here to select 
variable data”.  From the list that appears, select branch and click Next. 
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38. The last attribute is AUTHORIZEDBY.  We would like to use variable data from the 
print stream for this attribute.  To do so, first click the button “Click here to select 
variable data”.  From the list that appears, select AuthorizedBy and click Finish. 

 

 
 

39. You have completing configuring your simple DocumentMall workflow.  Your 2 
objects (“DocumentMall Demo” and “DM Upload”) should both be green meaning 
they have been successfully configured and the workflow is ready to be created. 
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40. To make all the appropriate forms and changes, the workflow must be executed.  

This is done by clicking the “Execute” button  on the menu bar.   After 
execution, you will be notified about what has taken place.  Click OK. 

 

 
 

41. You can now close the Workflow Designer. Your form has been saved in your 
default forms directory.  A backup of your original DocumentMall.FOM file has 
been copied to the “Workflow Designer Original Forms” folder in your forms 
directory.  Any permanent form changes should be made to this original form as 
it is used throughout the form configuration process as a template.  If changes 
are made to the template, the workflow will need to be executed again to make 
those changes to the generated forms. 

 

42. To test out your settings and make sure that files can be uploaded, first we should 
open the form with the Reform Designer.  Navigate to your Forms directory and 
double click on DocumentMall.FOM.  When asked to open the associated TextFile, 
click Yes. Verify that the special fields exist on the right hand side of your form.  

 
43. Now, we can check if the Upload Agent is running.  

a.   If it is running, you should see the  icon in the system tray (next to the clock) 
 
b.  To start it, if it is not running. Go to  

Start>Programs>Reform…>DocumentMall> DocumentMall Upload Agent 
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44. In the Upload Agent, click the Start button to begin monitoring for DocumentMall 
jobs.  
 

 
 

45. Go to File>Print in the Reform Designer to send the document to DocumentMall.  
 

 
 



Reform To DocumentMall  21 

 

 

                                                            

46.  While it is printing, open the Upload Agent and switch to the Pending tab. You will 
notice that the document you just printed will be under the pending tab.  

 
 
*In a few seconds, the document upload will begin. You will notice the speedometer on 
the bottom right of the upload agent changing briefly while the file is uploading, and 
providing there are no errors in your configuration, the document will be uploaded and 
moved from the Pending tab to the Successful tab.  
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Now we want to log in to the Document Mall account and see our results. Open an 
Internet Explorer browser and navigate to http://share.documentmall.com.  
 
Enter the follow login credentials and click Login: 
Account: FABSOFT 
Login Name: tutorial 
Password: tutorial 

 
 
On the left column on the Document Mall interface, expand the Cabinets item by 
clicking the  icon next to it, and then click Tutorial.  
 

 
 
You will see the file that you just uploaded called AUTOLUXURY_CAR_DEALER.  
 

 
 
To view the PDF of your file, click on the file name AUTOLUXURY_CAR_DEALER.  Click 

the  icon to view the file information.  
 

http://share.documentmall.com/
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You can see that the attributes that we chose in the Setup Wizard are all attached to the 
document.  
 
The document has now been successfully archived into Document Mall. 
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Components of the DocumentMall Plugin 
DocumentMall Reform Plug-in 
The DocumentMall plug-in allows you to specify settings from within the Reform 
Designer that will allow Reform to push documents up to a DocumentMall account and 
organize them as needed. 
 

DocumentMall Upload Agent 
This program is responsible for uploading documents to DocumentMall.  The program 
can be run as a Windows service. 

 
 

Basic Functionality Summary 
The DocumentMall Upload Agent monitors its designated upload folders and processes 
requests as they are received.  Requests take the form of folders (containing the 
outlined files) deposited in the upload directory.  These files include the documents 
specific to the batch and the batch file itself, which contains detailed information about 
each of the documents in the batch. 
When a batch is found, the application first verifies that all needed content files are 
present (based on the information contained in the batch file).  If all files are present 
and accessible by the DocumentMall Upload Agent application (read/write access), the 
application prepares to send the batch to the DocumentMall system for processing.   
 

Basic Control Overview 
General Buttons 
Start/Stop: This button starts and stops the batch upload process. 
Options: Allows the administrator to adjust the program’s settings and options.  This will 
prompt for the administrative password. Settings should only be modified by Ricoh 
Certified installers.  If you need assistance with your settings, please contact Ricoh. 
Double Clicking: Double clicking on a batch opens the respective batch or result file for 
viewing/editing. 



Reform To DocumentMall  25 

 

 

                                                            

 
Right-Click Buttons (available from selecting a batch and right-clicking on it) 
View Results File: Opens the Results file for viewing in your default XML editor. 
View/Edit Batch File: Opens the Batch file for viewing/editing in your default XML 
editor. 
Open Batch Folder: Opens the containing directory for the batch/result file in Explorer. 
Copy to Clipboard: Copies the batch information to the clipboard. 
Retry: Retries the selected failed batch. (Upload Agent must be started) 
Retry All Failed: Retries all batches that have failed. (Upload Agent must be started) 
 

Configuring the DocumentMall Upload Agent 
To run the DocumentMall Upload Agent, open the shortcut in the Reform V12 start 
menu group. Go to: 
Start>Programs>Reform…>DocumentMall> DocumentMall Upload Agent 
 
To configure a DocumentMall account in the Upload Agent, open the Options window 
by going to Edit>Options in the Upload Agent. When it prompts you for a password, 
enter: dmuaconfig 
 
Click on the Accounts item in the left list.  

 To edit an account, select it in the Accounts drop-down menu, and change the 
values.  

 To add a new account, click the  button next to the Accounts drop-down 
menu. Type in your account name, press OK, and then fill in your username, password, 
and what type of account it is.  
Next, click on Folder Paths on the left hand side, and choose the paths to your Upload 
and Results directories. 
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The defaults are  
C:\Program Files\Reform…\Plugins\DocumentMall\Uploads 

and 
C:\Program Files\Reform…\Plugins\DocumentMall\Results 

Press Save to save your changes and close the window. Exit the DocumentMall Upload 
Agent. 
 
Go to Control Panel > Administrative Tools>Services to view installed services. Scroll 
down until you find an entry for DM_Upload_Client. Right-click the item and click Start. 
You will notice that the DocumentMall Upload Agent application will open immediately 
and start monitoring folders for upload jobs. 
 

 

Testing the Functionality  
To test the connection to DocumentMall from Reform, be sure of the following: 

-If you are running the DocumentMall Upload Agent as a standalone application, be 
sure that it is running 
-If you are running the DocumentMall Upload Agent as a service, be sure that the 
service is started and the monitor is running.  It is also important that the service 
logon account used has administrative privileges on the local computer. 
-The Reform Spooler is running and started (Start>Programs>Reform…>Spooler) 
 
 

Maintenance 
There are certain directories that need to be monitored for growth along with the 
DocumentMall plugin for Reform 12.  As a system processes more and more jobs, the 
size of these directories can grow very quickly.  Overall system performance can be 
affected by the large amounts of space that the files may take up.  Obsolete files should 
be deleted according to your needs and file retention specifications. It is recommended 
to monitor the following directories for growth: 
 
Directories: 
C:\Program Files\Reform…\Backups 
C:\Program Files\Reform…\Spooler\ImageQueue 
C:\Program Files\Reform…\Plugins\DocumentMall\Results 
C:\Program Files\Reform…\Plugins\DocumentMall\Uploads 
 


