Reform To Laserfiche

11/2/2011

Reform12

Laserfiche for
MOST

Reform12 Laserfiche



Reform To Laserfiche 2

About the MOST Laserfiche PIUS-iN........ccueei it 3
SYSTEM REQUITEMENTS ..ottt e 3
Hardware REQUIrEMENTES ... et e e e e e e e e e e e e e e e e e e e e s ennnnnnees 4
INSTAIATION 1ot e e e e e st e e s et e e s s b e e e e senreeeeeans 4
[aaToToTuulaY=q Y O R Yol o =TT o RN 5
Setting Global Variables........uiii i e 5
AsSIgZNING COllECLIONS tO USEIS ..eiiiiiiiiieiiiiiiee ettt e e st e e s saae e e s eaees 7
MOST Laserfiche TULOTIAl.....coiiiuiiiii e e e s s eaea e e e 8
Y T g L] g = o Lol OO UROROUORORRRPTRRRRPRRRORt 11
TrOUDIESNOOTING ..ottt e e s et e e e s e e e s earreeeens 12

form12
Laserfiche



Reform To Laserfiche 3

About the MOST Laserfiche Plug-in

The Laserfiche plug-in acts as a bridge between MOST and Laserfiche. It allows you to
archive documents processed by MOST to Laserfiche Repositories where your collection
of documents can be shared.

MOST along with Reform Enterprise/PDC maximizes the integration with Laserfiche by
enabling automatic delivery of document information from any operating system,
application or device. Whether a document is being printed scanned in using an MFP or
copier with MOST, or using MOST Desktop, Reform will capture the process, extract the
text and intelligently archive it to Laserfiche. With Reform’s alternative input options,
more of your valuable information can be effortlessly accessed and easily shared
company-wide through Laserfiche. Reform can control directory locations as well as
custom index information to simplify document retrieval. Fast and easy access to
important information is an extremely vital resource, and Reform’s integration
capabilities to Laserfiche let you obtain the most comprehensive document information
archive to improve the workflow of your business operations.

System Requirements
e Reform 12 Enterprise or Reform 12 PDC
e MOST Plugin
e Laserfiche Plugin
e MOST Laserfiche Plugin

e For Evaluation and Demonstration: Windows XP, Windows 2003 Server,
Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are
Supported)

e For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit
Operating Systems are Supported)

e Microsoft SQL Server (SQL Server Express will be automatically installed by the
Laserfiche installer if it is not present on the current system)

e Microsoft .NET Framework 2.0 (installed automatically if not present on the
current system)

e Laserfiche Server

All required Reform software downloads can be found at www.fabsoft.com >>
Downloads section.
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Hardware Requirements

e Production System Recommendation (These suggestions are only estimations.
High load environments may require multiple servers, or additional hardware.)
1. Pentium 4 Processor
4 GB RAM
HDD Space 100 GB (Redundancy recommended)
Battery Backup (UPS)
Dedicated server, no other software products except for virus and
security programs.
e Minimum System Requirements for demonstration purposes only
1. Pentium 4 Processor
2. 2GBRAM
3. HDD Space 30 GB

vk wnN

Hardware specifications depend greatly on the workload and throughput that is
required. Higher end processors and greater amounts of memory will increase the
amount of information and data that Reform can process thus improving overall system
throughput. For load balancing or failover, multiple servers can also be used. (Note: A
license for Reform and each plug-in is required for each server running the software.)
Before obtaining the server that you plan on utilizing for Reform, please check the plug-
ins” user manuals for System Requirements as well as they may require additional
hardware. For production systems, we also recommend redundant hard drives utilizing
the mirroring features of RAID (Redundant Array of Independent Disks) to minimize data
loss and expedite system recovery in the event of a hardware failure. Battery backups
are also suggested to maintain system uptime and reliability in case of power failures.

Installation
To install the Laserfiche Plug-in components, download and run the installer.

laserfiche. exe

Step through the prompts and accept the User License Agreement. The installation will
begin. Allow the installation to complete and then read on to the next section to learn
how to set up the MOST _Laserfiche integration.

The default installation directory for Reform 12 and its plugins is C:\Program
Files\Reform...\. If you have changed the path during the Reform installation routine,
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or if you are using a 64 bit operating system, please refer to the appropriate path
instead of the default one referenced throughout this documentation.

Importing MOST Screen

Please refer th the MOST manual for more information regarding MOST terminology,
MOST Setup, and Connection Test.

To import MOST screens for Laserfiche Go to Start > Programs > Reform... > MOST-
Laserfiche > Install MOST Screens

I TagDoc >|
I Laserfiche
@ MOST-Laserfiche

[ Reform PDC_viz-6

@ Skartup

|ﬂ Install Bubble Sheet For MOST J

» | B Laserfiche User Manual

If not already open, MOST designer will appear. You will be prompted if you want to
import Laserfiche into MOST. Click Yes. If asked if you want to overwrite files, click Yes.

\?/ Import Laserfiche into MOST?

You can leave the MOST Designer open as it will be used in the following section.

Setting Global Variables

We need to setup the communication between MOST and Laserfiche. To do so, we
have to configure certain parameters in MOST’s Global variables screen. If the MOST
Designer is not already open, go to Start>Programs>Reform...>MOST>Designer.

Go to Data>Global Variables on the menu bar.
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& MOST Designer g@gl

File  Edit  Wiew I Data I Tools  Window — Help

TR | g | Users and Groups. ..

Collections...

b Advanced Search Global Variables... = Most 2
—ratic Dat = Collections

akic Data. . .
) 4Line

b EditData : : )

Display Properties. .. Admin
i BubblaSheet

Proximity Card Data... -

» LogOuwt Emnail

' B H Lagerfiche

These are the Global Variables required for MOST to access your Laserfiche server. For
the variables LFServername, LFServerPort, LFProxyUsername and LFProxyPassword you
will have to enter valid information to connect to your Laserfiche server. After entering
each Variable Name be sure to click Update.

Variable Name = CommunicationType Value = Local

Variable Name = LFProxyPassword Value = “Your Laserfiche account password”
Variable Name = LFProxyUsername Value = “Your Laserfiche account username”
Variable Name = LFServername Value = “Your Laserfiche server name”

Variable Name = LFServerPort Value = “Your Laserfiche server port”

uhwWwNE

*CommunicationType specifies whether or not the MFP is reachable by IP from the
MOST server. If the MFP is reachable by IP from the MOST server, the
CommunicationType should be set to “Local”. If the MFP is on a remote (wide area)
Network, the CommunicationType should be set to “Remote”. (Remote printing may
be required in the MOST Manager)
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Global Y anables

Encrypt | Variahle W alue
F] CammunicationT ype Lacal
DreletedfterPrinting TRUE

F DreletePrint)obs TRUE

[ Emails ervert ame fabzaft-3de2222

F EmailServerType

F EmailT oS5 elf True

[ EmaillzeM ame

Emaill serPazsword
LFProwPagzword
ﬂ LFProsyl)zername admin

F] LFRepositan
.D LFServername fz-lazertiche
D LFServerPort

] LY alume

F] FPagetdode 1

F Frintdll obs TRUE

W ariable: |LFSewemame | | Update | [ Remove ]

W alue: |fs-|aserﬁche |

Assigning Collections to Users

1. Open your MOST Designer if not already opened (Start>Programs>Reform...

>MOST>Designer).

On the MOST Designer tool bar, click on Data > Users and Groups

3. Select the demo user from the User/Groups list. We will be adding the Laserfiche
collection for this user. The same process can be user for any user or group.

to add the

N

4. Select Laserfiche from the Available Collections and click the L
Laserfiche collection.
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& MOST Designer

File  Edit ‘View Data Tools Window  Help

* || Global Wariables % Users and Groups™ (X

b Advanced Seach

MOST_LDAP_SavaT o
Users/Groups General Settings MOST_LDAP_SaweloF

» Edit Data "
p MOST_Save ToFile
L T 0 E ] =
= Usa:js ogin Timeoul = Card Aeader: [ Require Pin Code MOST SaveT cFils_Stal
¥ Log Out Tmo MOST_TagDoc_Scan
m Scan Settings PrirtTobe
b Previevw = Groups i =]
. PrintTobe.2
Database Colar: File Type: | TIFF - MMR w
PrintTote.3
b Frocess Diomain Users

Sides: | One Sided v Secan Mode: B Tabs - 5¥GA
Admin Email

v
» Frocesz Al Size: | Auta Fesolutior: | 300 dpi w < | > a
» Process Data Sean Type: | Mised Density:
Users and Groups L
> PulDats Collection:
P ResetData Available Collections: Selected Collections:
BubbleSheet ~ | |
k5 Ta Global
4d S T [ ——
P Smart Search

5. File>Save or use the small save icon =l to save your changes.

MOST Laserfiche Tutorial

1. Loginto MOST at an MFP or use MOST Desktop (Start > Programs >
Reform...>MOST>Misc>MOST Desktop) using the demo account. Username
is demo, password is demo.

File
I orm.
Reform Your Business Platform
Ugername: | demo
Pazsword: I**** I Log In
Remember Me
82011 FabZaft w2 510028618
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2. You will now be logged into MOST, click the Laserfiche tab, you should see a
screen similar to below.

*In step two the Laserfiche servername should be there. If you do not see, you may

have entered incorrect information in the values for the setting global variables

section of this manual.

Step 1: Enter a Filename Step 3: Select a Template
Laserf iche | | | | |
................................................. . , N S s ey vl e TS coteri)
Status Step 2: $3|30t a Repository and specific folder vou before name of field means it’s required to be
would |ike to upload to el
+ FE-Laserf ichel. fabsoft.net
Log Out Scan

3. Click the box below Step 1 and enter the filename you would like to name the
document you are about to scan.

4. Under step 2, select a repository. Click the server, you should then see a list of

repository folders, select the one you would like to upload the scan to.

Under step 3, select the template you would like to upload the scan to.

6. Under step 4, you should now see a list of fields. The fields with a (*) are
mandatory, you must enter a value. All other fields you may or may not enter
values. To enter a specific field click the corresponding box outlined in red for the
field you would like to enter. You will see a popup, enter the value and click OK.

o1
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EufisIEd
Laserf ichel
Step 1: Enter a Filename Step 3: Select a Template
Lazerf iche |LFTegt]23 | | General | h |
i , e Step 41 Enter value for fields asterik(#)
Status Step 2: $e|ect a Repository and specific folder vou befare name of field means it's required to be
would |ike to upload to entared
- F5-Laserf iched. fabsoft.net Document
- Reform Tvpe
+ #d Hoc Category
+ Invoices hddressee
+ Perzonal
- Purchase Orders bhstract
- 010 Subject
Loz Out Scan

7. Select Scan. If using MOST Desktop, there is a .tif file in the Reform..>Misc
folder you can use. If using MFP, you can scan any page/s.

8. You can then check the status of Scan by selecting the Status tab. This screen
will show you the status of all the scans that you have made. Clicking the Clear
All we clear all of your scans. You can also logon to your Laserfiche account and
confirm that your scanned documents made it to the correct folders in Laserfiche.
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Lagerf ichel

Laserfiche File Status
Lazerf iche
Submitted Document hame Status
Status 10/4/2011 10:46:31 4M teanworks Successful
10742011 10: 45259 A statement Successful
10452011 10244240 4K kegff Succeszsful
Log Out Clear All

Maintenance

There are certain directories and SQL tables that need to be monitored for growth along
with the Laserfiche plugin for Reform 12. As a system processes more and more jobs,
the size of these directories and SQL tables can grow very quickly. Overall system
performance can be affected by the large amounts of space that the files may take up.
Also, there exists a 4GB database limit if using the Microsoft SQL Server Express 2005
supplied with this installation. Obsolete files/database entries should be deleted
according to your needs and file retention specifications. It is recommended to monitor
the following directories and SQL tables for growth:

Directories:

C:\Program Files\Reform...\Backups

C:\Program Files\Reform...\Spooler\ImageQueue
C:\Program Files\Reform...\Plugins\Laserfiche\Attachments

SQL Tables:
Reform_Laserfiche_Trans
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Troubleshooting

Q: Nothing is happening after the scan is processed. How can | determine the cause of an
issue?

A: Check the Event Log for errors related to Reform or the Laserfiche service. The Event
Log can be access by going to Control Panel > Administrative Tools > Event Log. This will
usually give you a good idea about why the Laserfiche plugin might be failing.

Other company or product names mentioned herein may be trademarks or registered
trademarks of their respective companies
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