
 Print To Me For MOST 

                                                         Print To Me 

4/27/2011 

 

 

 

 

 

 

 

 

 

 

 

 
 

 
 

 

Print To Me 
 

 

 



 Print To Me For MOST  2 
 

                           Print To Me 

Table of Contents 

About Print To Me ............................................................................................................... 3 

System Requirements ......................................................................................................... 3 

Hardware Requirements ..................................................................................................... 4 

Prerequisites ....................................................................................................................... 4 

Installation .......................................................................................................................... 4 

Plugin Registration and Licensing ....................................................................................... 4 

Importing MOST Screen .................................................................................................... 11 

Setting Global Variables .................................................................................................... 11 

Assigning Collection to Users ............................................................................................ 12 

MOST Configuration to Enable Remote Printing of Documents at the MFP.................... 15 

How To Setup PrintToMe Driver ....................................................................................... 17 

PrintToMe Tutorial ............................................................................................................ 18 

PrintToMe Services ........................................................................................................... 22 

Print To Me Mobile ........................................................................................................... 25 

Configuring Print To Me Mobile ................................................................................... 25 

Maintenance ..................................................................................................................... 32 

Troubleshooting ................................................................................................................ 33 

Selecting the Print To Me driver or viewing the properties of the driver is slow. ....... 33 

 
 

 

 

 

 

 



 Print To Me For MOST  3 
 

                           Print To Me 

About Print To Me  
Print To Me allows users to print documents from a PC to any Ricoh MFP as opposed to 
printing to a predetermined MFP or printer. MFPs are constantly being used by other 
employees, or can be unavailable due to paper jams, lack of supplies, or malfunctions. 
Printing documents to Print To Me enables users to access them from any MFP on the 
network, therefore if one MFP is unavailable, users can go to the next without reprinting 
the document or having to worry about privacy.  Print To Me also employs LDAP 
authentication for a secure printing environment. Both wired and wireless users will 
benefit from having a single printer (Print To Me) installed on their computers while 
giving them the flexibility to retrieve their printed documents from any MOST enabled 
Ricoh Device. 

Workflow with Print To Me 

 User prints a document to Print To Me through a standard Print Driver.  

 The Print To Me software recognizes the user, computer and document name 
that is printed. All of this information is stored on the MOST server.  

 The user can go up to any MFP on the network, login into MOST and print their 
documents.  

 MOST identifies the user and lists the user’s documents on the MFP screen.  The 
users can then request the print job, preview the print job, or delete it.   

 The user can select the document or documents needed, and print them directly 
to the MFP. They also have the ability to delete the document after printing. 

 All login requests and communication between the MFP and the MOST server 
are encrypted using 1024 bit RSA Key encryption.  

System Requirements 
 Reform 12 Enterprise or Reform 12 PDC 

 MOST Plugin 

 Print To Me Plugin  

 For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 
Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 
Supported) 

 For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 
Operating Systems are Supported) 

All required Reform software downloads can be found at www.fabsoft.com >> 
Downloads section. 

 

http://www.fabsoft.com/
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Hardware Requirements 

Please reference both the Reform 12 Documentation and MOST Documentation 
regarding Hardware Requirements.   

 

Prerequisites 

1. Make sure both Reform and MOST are installed and working correctly with 
your Ricoh MFPs. You should be able to login from the MFPs successfully, if not, 
please refer to the MOST installation and setup guide. 

 

2. The MOST Server must be on the same domain as the Active Directory server. 

 

3. Enable LDAP in the MOST Manager.  This setting is located in the MOST Manager 
by going to Edit >> Settings and navigating to the Authentication tab.  A Domain 
must be specified if using the Active Directory server type.  Please consult the 
MOST Manual for more information about the Authentication tab. Users should 
be able to login to the MOST on the MFP using their Active Directory/LDAP user 
name. 

 
Installation 
 
To install Print To Me to your existing Reform 12 installation, you will need to download 
and run the Print To Me installation executable  

 
 

Step through the prompts until the setup begins. Allow the Print To Me installation to 
complete. 
 
The default installation directory for Reform 12 and its plugins is C:\Program 
Files\Reform…\.  If you have changed the path during the Reform installation routine, 
or if you are using a 64 bit operating system, please refer to the appropriate path 
instead of the default one referenced throughout this documentation.  
 

Plugin Registration and Licensing 

When evaluating Reform 12, the plugins will also be in an evaluation mode for that 
period of time.  Once Reform has been purchased and licensed, the required plugins 
must also be licensed in order to continue functioning correctly.    
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Please see the “Reform 12 Licensing and Registration” section of the Reform 12 User 
Manual for more information on how to license Reform 12 Plug-ins.  After the license is 
entered, the Reform Spooler will need to be restarted to refresh the licenses. More 
information regarding the Reform Spooler Service can be found in the Reform 12 User 
Manual. 
 

Install PrintToMe Remote Software: 
Select Start\Reform\Print_To_Me\PrintToMe Remote Deployment Tool to install 

PrintToMe Remote.. 

 

Select PrintToMe Remote from the drop down and click Next. 

  

 
 
On the Credentials tab populate the Username, Password, and the Domain.  NOTE: You 

must you an administrative account preferably the same account you use to run your 

services. Click on the Verify Credentials button and after verifying your credentials 

click Next to be taken to the Configuration tab.  
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On the Configuration tab specify the Boot Time Out, Process Time Out, Simultaneous 

Installations, and Operating Systems.  You can leave these as default settings. 
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Click on the Client Settings button to view your PrintToMe Remote settings. These are 

the settings that will be pushed to individual workstation.  

 

. 

On the Target Systems tab you can specify your workstations via LDAP query, CSV, or 

manually entering the Computer’s Name. Click on the LDAP Lookup button to display 

your LDAP Structure.  You can select the group or sub group to display the list of the 

computers within the group. 
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All the computers will be selected on default, you can deselect by clicking on the 

checkbox.  For demo purposes only one of the workstations will be selected which is 

PrintServer1. 

 

 

 
 
 

Click on the Get Status button to check the status of the package you’re trying to install 

in this case we’re checking for PrintToMe.  You’ll see in the Status column that 

PrintToMe is not installed on PrintServer1. 
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Click on Next to be taken to the Begin Installations tab. Go to the Not Installed Tab to 

view the system that we want to install PrintToMe on.  Click on Install to begin the 

installation.   
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PrintToMe is currently being installed. 

 
 

You will be taken to the Results tab.  Within this tab you will see the following status 

tabs: Active, Successful, and Failed.  In the Successful tab you can see here we 

successfully deployed PrintToMe on PrintServer1. 
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Importing MOST Screen  
Please refer to the MOST manual for more information regarding MOST terminology, 
MOST Setup and Connection Test. 
http://fabsoft.com/Downloads/ReformEnt12/MOST/Reform12_MOST.pdf. 
 

To import MOST screens go to Start> Programs> Reform…> Print_To_Me> Install 
Screen to MOST Designer.   
 

 
 

Setting Global Variables 
We need to setup the communication beween MOST and PrintToMe.  To do so, we have 
to configure certain parameters in MOST’s Global variables screen.   If the MOST 
Designer is not already open, go to Start>Programs> Reform… >MOST>Designer. 
 
Go to Data>Global Variables 
 

 
 
There is a single PrintToMe global variable that is able to be configured.  PrintAllJobs 
and DeletePrintJobs are also associated with Print To Me but they should always be 
True.  Please see note below for more information. Select the variable, choose one of 
the available options from the drop down list and then click the update button.  

1. Variable Name =CommunicationType  Value= Local 
 

*CommunicationType specifies whether or not the MFP is reachable by IP from the 
MOST server.  If the MFP is reachable by IP from the MOST server, the 
CommunicationType should be set to “Local”.  If the MFP is on a remote (wide area) 
network, the CommunicationType should be set to “Remote”. 
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Click  File>Save or use the small save icon  to save all the global variables. 
 
 

Assigning Collection to Users 
 

1. Go to Start>Programs>Reform…>MOST>Designer 
2. On the MOST Designer toolbar click on Data>Users and Groups 

 

 
 

3. Click on Add.  
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4. You will need to add an Active Directory username or group you are planning to 
log in as. 
 

 
 

5. For the demonstration, we will be using the LDAP Group Domain Users 
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6. Highlight your username or group and select Print To Me from Available 

Collections box and click the    to add PrintToMe. Tip: Set Login Timeout to 
0 to disable the automatic timeout. 
 

 
 

7. Go to File>Save or use the small save icon  to save your changes. 
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MOST Configuration to Enable Remote Printing of Documents at the MFP 
 

*If CommunicationType global variable is set to Local (MFP can be reached by IP on a 
local network), this step can be skipped.  In order to print documents remotely (when 
a MFP is not reachable by IP), the CommunicationType should be set to Remote and 
the following steps should be taken. 
 
Remote Printing must be enabled in the MOST Manager if the CommunicationType is 
set to Remote in the Global Variables configuration.   
 

1. To do so, first make sure MOST Manager is open by going to 
Start>Programs>Reform…>MOST>Manager.  It may be running in your task bar, 

so check for the small  icon and double click on it to bring up MOST Manager. 
 

 
 

2. Go to Edit > Settings 
 

 
 

3. Go to the Devices tab. Here we need to check the Enable Remote Print checkbox 
if it is not already checked.  You must also specify your Reform installation’s 
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Queue directory which is usually C:\Program Files\Reform…\Queue.  Use the 

browse button  to select this directory.  The polling interval is how often the 
MFP will check this directory for print jobs.  If 30 seconds is not optimal for your 
environment, please change it the desired value. 
 
Note: The lower the interval, the more network traffic/communications will 
occur. 

 

 
 

4. After you have finished configuring Remote Printing, please click the Save 
button.  You will be prompted that the server must be restarted, click OK. 

 

 
 
You have successfully configured MOST to enable the remote printing of documents at 
your MFP. 
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How To Setup PrintToMe Driver 
 
Go to Start > Control Panel > Hardware > Devices and Printers.  Right click in the 
PrintToMe driver. Select Printer properties. 
 

 
The PrintToMe driver will start updating. 
 

 
In the Properties window.  

1. Click the Accessories tab. In the scrollbar choose Generic Model. 
 

 
 

2. Click Update Now.  
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3. After it is done updating, check the three options listed above. Click OK. 
 

 
 
PrintToMe Tutorial 
In this tutorial, we will demonstrate how to use the Print To Me print driver to send jobs 
to an MFP.  All the documents that the user prints will be stored on the MOST Server 
and listed on the two Print To Me tabs.  At that point, the desired document or 
documents can be printed directory to the MFP.  In order to see the printed documents, 
these steps must be carried out on an actual MFP and not the MFP Emulator (MOST 
Desktop).  
 

1. The installation routine automatically added a printer called Print To Me and 
shared it so that computers (workstations) can connect to it.  In order to send a 
print job to the MOST server and have access to it on the MFP, users print as 
they normally would but instead of selecting a specific printer, they will need to 
select the PrintToMe printer. 

 

 
 

2. In order to use Print to Me, the printer first must be installed on a PC that is on 
the same Domain as the MOST server and Active Directory server.  Log onto a PC 
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with the same user name that you will use to log into MOST with at the MFP.  
These two users names must match as only the documents printed by the user 
will be available when that user logs into the MFP. 
 

3. To install the printer on the PC, Go to Start > Run type in the \\<MOST Server 
Name or IP> and press OK. Replace the <MOST Server Name> with the name of 
your server example \\mymostserver.  This will open up the default shares for 
that server.  The PrintToMe driver is listed as PrintToM in order to adhere to 
Windows 3.x/DOS limitations. 

 

 
 

4. Double click on the “PrintToMe” printer and it will install automatically on your 
PC.  To confirm the installation, navigate to Printers and Faxes in the Control 
Panel to see the newly installed printer. 
 

5. Print a document to this PrintToMe printer from any application.  For the 
demonstration, we will be using the “Notepad” windows application with some 
sample text. 
 
 

file://mymostserver
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6. Log into the MFP and your document will be displayed on the Print To Me 
screen. There are two PrintToMe tabs in your PrintToMe collection.  This is to 
offer a variety of options while printing.  Either tab can be used.  We will proceed 
with the first tab.  Here you can see your document in the “Document Name” 
column and the date that it was submitted to PrintToMe in the “Submitted” 
column.  The Preview button can be used to preview your printed documents 
(you must select the document before clicking Preview). 
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7. Click the field under “Print To Me Job Settings:” which current reads Print and 
Delete Selected Documents.  This will prompt you with all the available printing 
and or deleting options.   
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8. The default setting is to “Print and Delete Selected Documents”.  Choose either 
this setting or any of the other printing related settings.  Click OK. 

 

 
 

9. Now select your document from the list so that it appears with a black 
background.  If you had multiple documents, you could have selected those as 
well.  Once selected, click the Process button.   This will perform whatever is 
selected in the Print To Me Job Settings. 
 

10. After clicking the Process button and if a printing operation was selected, your 
documents should have printed to the MFP. 

 
Troubleshooting: 

 Make sure the users have rights to the PrintToMe printer driver, right click over 
the printer driver select properties and make sure the users have enough 
security rights. 

 Make sure the Print To Me Process service is running (See section about 
services) and that it has the correct permissions. 

 Make sure the PrintToMe service is running (See section about services) and that 
it has the correct permissions. 

 Make sure the Print To Me Mobile service is running (See section about services) 
and that it has the correct permissions. 

 

PrintToMe Services 
There are three services associated with the Print To Me plugin.  They are: PrintToMe, 
RM_PrintToMe_Mobile and RM_PrintToMe_Process.  To view these services, go to 
Start > Programs > Control Panel > Administrative Tools > Services . 
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PrintToMe Service 
This service is responsible for the first stage of the PrintToMe process.  It monitors jobs 
that are sent to the PrintToMe printer driver.  Its first task is to capture the print job so 
that it can be later printed at an MFP.  It also updates the database with information 
regarding the print job such as the user who printed it, when it was printed and the 
document title.   
 
PrintToME Mobile Service 
The PrintToMe mobile service is used to monitor an email address' inbox for incoming 
email using the IMAP protocol.  When a new email is found, the application will 
download the attachments and retrieve the sender's information.  If LDAP is enabled, 
the service will attempt to query for the user's information based on the sender's email 
address.  It will then print any compatible attachments to the PrintToMe driver.  The 
typical PrintToMe process will then store the print ready file to be released at an MFP 
from the sender's account.  If LDAP is not enabled, PrintToMe can be configured to send 
an email response to the sender including a pin code that can be used to release the 
print job at the MFP. 
 
PrintToMe Process Service 
This service is responsible for the communication between the MOST server running the 
service and the MFP.  When a user selects a document to be printed and or deleted at 
the MFP, the MFP notifies the PrintToMe Process that the selected task should be 
carried out. The PrintToMe Process does the actual printing and or deleting of the 
documents when requested by the MFP. 
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Log On Accounts 
Depending on your environment, these services may require a domain account with 
administrative privileges on the local computer, and also needs access to database.  To 
set a Log On account for a service, right click on the desired service and go to Properties   
 

 
 

Go to the Log On Tab. 
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Here you need to fill in the “This Account” fields that will give the service administrative 
access.  You can use the Browse button to assist you in locating the desired account.  
After selected the account, fill in the Password associated with it.  Click OK once 
complete.  You will be asked to restart the service for the changes to take effect.  To do 
so, right click on the service and select Restart, or simply stop and start the service. 
 

Print To Me Mobile 
Print To Me Mobile allows users to print documents from a Mobile Device to any Ricoh 
MFP. Print To Me Mobile workflow: 
 

o The user sends a PDF (or other supported file type) as an email 
attachment to a specified, dedicated email address. (Example: 
PrintToMe@FabSoft.com) 

o The PrintToMe Mobile service monitors the email accounts inbox for 
incoming messages.  When a new message is found, it will download the 
attachment and print it to the designated printer driver on the Reform 
Server. This is typically the PrintToMe printer driver.  

o If LDAP is in use, the service will also query for the user’s information 
based on the sender’s email address. 

 If the user’s account is found, the document will automatically be 
available to the user when they log into MOST. 

 If the user’s account is not found, an email is sent back to their 
email address with a pin code that can be used to retrieve their 
document.  To log into MOST, the user must enter the pin code as 
their username, and no password. 

o The PrintToMe software then receives the information from the printer 
driver and processes it normally. 

o The user can then log into MOST on the MFP and retrieve their print job. 

 

Configuring Print To Me Mobile 

To use Print To Me Mobile, you must first successfully configure default PrintToMe.  
Then, continue with the steps below to configure the software to monitor the dedicated 
email address for incoming attachments. 
 
To start the PrintToMe Mobile configuration go to Start > Programs > Reform > 
Print_To_Me > Print To Me Mobile Configuration. 
 

mailto:PrintToMe@FabSoft.com
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The Settings dialog will open for configuration. 
 

1. Enter the IMAP information for your email server and account in the utility.   
 
IMPORTANT: This must be a dedicated account. The email account specified 
here will be monitored by Print To Me Mobile. When Print To Me Mobile 
monitors the mailbox, it will process and DELETE all incoming emails. If this is 
accidentally pointed to a personal account, all emails will be lost.     
 

2. If a proxy is required to connect to the server, please include that information as 
well.  Once you have configured your settings, click the “Test IMAP Settings” at 
the bottom of the screen to verify the connection is successful.  
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3. Next, the outbound email settings should be configured. These settings are used 

to send a pin code to the user if the user’s email address cannot be found within 
LDAP.  Click the “Test Settings” button to send a test email from the email 
address specified to itself to verify that it was successful.  

a. Note: The Reform Email plug-in must be configured and running for 
notifications to be sent.   
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4. The LDAP settings can be configured to be identical to MOST, or can have 

customized settings.  Typically, these should use the same settings as MOST. By 
default the Mail Object is “mail” and the User Object is “sAMAccountName”. 
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5. The Other settings allow you to configure the printer driver that the Print To Me 
mobile documents will be printed to. This should be set to the Print To Me 
driver. Here, you can also specify how often to check the IMAP server for new 
items in the inbox.  

6. If you want to be able to send word documents from your mobile device to a 
MFP, download OpenOffice from http://www.openoffice.org. Then, click the “…” 
button to  select the “soffice.exe” file from your Open Office installation. The 
default location on a 32 bit operating system is: “C:\Program 
Files\OpenOffice.org 3\program\soffice.exe”. 

http://www.openoffice.org/
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Click OK to save your settings 
 

 
 

 
If the PrintToMe Mobile Service has not been running, a message will appear asking if 
you want to start it. Click Yes to start the service automatically. 
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Print To Me Mobile is now configured and ready to be used. 
 
In order for PrintToMe Mobile to operate correctly with Open Office ensure the Print To 
Me Mobile service account is set to a local administrator on the computer (Local System 
and Network Service accounts will not work properly). Then, login to the computer using 
the specified service account and start Open Office manually. You will need to go 
through the quick registration screen before the application can run. Once this is done, 
Word documents can be sent through Print To Me Mobile. 
 
Resolving PrintToMe Speed Issues 
 
In some scenarios, the Ricoh Universal Printer Driver may respond slowly when viewing the 
properties, settings, or attempting to print from an application. As this is the typical driver used 
for Print To Me, it may affect the performance when selecting the Print To Me printer. 
According to the version notes available for the driver’s download, Version 3.3.0.0 and above 
have had improvements that help resolve these speed issues.  

 
Universal Printer Driver - Version 3.3.0.0 – Release Notes:  

 
- A new setting "Automatically Update Printer Information" has been added. This can be used to 
enable/disable bidirectional communication.  

  
2) Fixed  
- Switching to this driver from another driver in an application print dialogue, takes a long time.  
- Print performance is slow compared to other PCL drivers.  

  
Excerpt From: http://www.ricoh-usa.com  

 
Once the printer driver has been updated to a version supporting these features, it is 
recommended to disable the “bidirectional communication” option.  
 
To disable “bidirectional communication”:  

1. Go to Start > Control Panel > Printers.  

2. Right Click on the printer utilizing the Ricoh Universal Driver.  

3. Go to “Accessories” Tab.  

4. Uncheck the checkbox named “Automatically Update Printer Information”. (See 
screenshot below).  

5. Click “Apply” to save the changes.  
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6. The speed issue should be resolved.  

Maintenance 
There are certain directories and SQL tables that need to be monitored for growth along 
with the Print To Me plugin for MOST.  As a system processes more and more jobs, the 
size of these directories and SQL tables can grow very quickly.  Overall system 
performance can be affected by the large amounts of space that the files may take up.  
Also, there exists a 4GB database limit if using the Microsoft SQL Server Express 2005 
supplied with this installation. Obsolete files/database entries should be deleted 
according to your needs and file retention specifications.  It is recommended to monitor 
the following directories and SQL tables for growth: 
 
Directories: 
C:\Program Files\Reform…\Queue\Print_To_Me 
C:\Program Files\Reform…\Plugins\Print_To_Me\Mobile 
 
SQL Tables: 
PrintToMe 
 
 
Other company or product names mentioned herein may be trademarks or registered 
trademarks of their respective companies 
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Troubleshooting 

Selecting the Print To Me driver or viewing the properties of the 
driver is slow. 

 

In some scenarios, the Ricoh Universal Printer Driver may respond slowly when viewing 

the properties, settings, or attempting to print from an application.  As this is the typical 

driver used for Print To Me, it may affect the performance when selecting the Print To 

Me printer. According to the version notes available for the printer driver’s download, 

Version 3.3.0.0 and above have had improvements that help resolve these speed issues. 

 

 
 

Once the printer driver has been updated to a version supporting these features, it is 

recommended to disable the “Automatically Update Printer Information” option. 

 

To disable “Automatically Update Printer Information”: 

1. Go to Start > Control Panel > Printers. 

2. Right Click on the printer utilizing the Ricoh Universal Driver. 

3. Go to “Accessories” Tab. 

4. Uncheck the checkbox named “Automatically Update Printer Information”. (See 

screenshot below). 

5. Click “Apply” to save the changes. 

6. The speed issue should be resolved. 

Universal Printer Driver - Version 3.3.0.0 – Release Notes: 

… 

- A new setting "Automatically Update Printer Information" has been added. This 

can be used to enable/disable bidirectional communication.  

… 

2) Fixed  

- Switching to this driver from another driver in an application print dialogue, 

takes a long time.  

- Print performance is slow compared to other PCL drivers. 

… 

 

Excerpt From: http://www.ricoh-usa.com 
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