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System Requirements 

 Reform 12 Enterprise or Reform 12 PDC 

 MOST Plugin  

 LanFax Plugin  

 MOST LanFax Plugin 
 For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 

Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 
Supported) 

 For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 
Operating Systems are Supported) 

 

All required Reform software downloads can be found at www.fabsoft.com >> 
Downloads section. 

 

Hardware Requirements 

Please reference both the LanFax Plugin Documentation and MOST Documentation 
regarding Hardware Requirements.   

 

Other Requirements 

 MOST and LanFax  plugins must be configured before installing. 

 A LanFax driver must be installed before proceeding with the installation. 

 

Installation 
To install MOST-LanFAX to your existing Reform 12 installation, you will need to 
download and run the MOST-LanFAX.exe installation executable. 
 

 
 
Step through the prompts, and the installation will begin. After you have completed the 
installation of MOST-LanFax, the Reform Spooler Service must be restarted.  Open up 
the Spooler by going to Start>Programs>Reform..>Spooler.  Click the Refresh button or 
the red stop button and then the blue start button.   
 

http://www.fabsoft.com/
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The default installation directory for Reform 12 and its plugins is C:\Program 
Files\Reform…\.  If you have changed the path during the Reform installation routine, 
or if you are using a 64 bit operating system, please refer to the appropriate path 
instead of the default one referenced throughout this documentation.  
 
 

Importing Most Screen  
Please refer to the MOST manual for more information regarding Most terminology, 
Most Setup and Connection Test.  

 
To import the MOST screens that you will be using with LanFax go to 
Start>Programs>Reform…>MOST-LAN-Fax>Install MOST screens 
 
 

 
 
If not already open, the MOST Designer will appear and you will be prompted to import 
the screens.  Click Yes. 
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Setting Global Variables 
We need to setup the communication beween MOST and LanFax.  To do so, we have to 
configure certain parameters in MOST’s Global variables screen.   If the MOST Designer 
is not already open, go to Start>Programs> Reform… >MOST>Designer. 
 
On the MOST Designer’s menu, go to Data>Global Variables  
 

 
 
There are two LanFax global variable required.  CommunicationType specifies how 
statuses are printed to the MFP.  LanFaxUserCode is required if you wish to send faxes 
while the Faxing feature is locked on the MFP. Please see notes below for more 
information. Select the variable, enter its value in the provided box and then click the 
update button.  The CommunicationType global variables uses a drop down list with 
available options for your convenience. 
 

1. Variable Name =CommunicationType  Value= Local 
2. Varibale Name =LanFaxUserCode Value= 

 
*CommunicationType specifies whether or not the MFP is reachable by IP from the 
MOST server.  If the MFP is reachable by IP from the MOST server, the 
CommunicationType should be set to “Local”.  If the MFP is on a remote (wide area) 
network, the CommunicationType should be set to “Remote”. 
 
*LanFaxUserCode – This specifies a UserCode that has access to the faxing feature.  
This will allow faxes to be sent even if the faxing panel is locked on the device.  User 
Authentication Management must be set to “User Code”.  An address book entry must 
be created for the user code.  This user code must have access to the facsimile 
function.   
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Click  File>Save or use the small save icon  to save all the global variables. 
 

Assigning Collection to Users 
1. If MOST Designer is not already open, Go to 

Start>Programs>Reform…>MOST>Designer 
2. On the MOST Designer tool bar click on Data>Users and Groups 
3. Under Users, click on demo (the user demo is used for the tutorial, but you can 

add this collection to any user). Select LanFax from the Available Collection and 

click the   to add the LanFax collection. Go to File> Click on Save or click the 

 icon in the toolbar. 
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Setting up your MOST Lan-Fax Driver and Line Type 
Go to Start>Programs >Reform…> MOST-LAN-Fax> Most-Lan-FAX Setup 
 

1. Select your LanFax Driver (This is the LanFax Driver you’ve installed to send your 
fax document) and click Next. 
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2. Select the Line Type and click Finish. 

 
3. The rest of the fields are optional. Click on Skip until the wizard is completed. 
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Once all the tests are successful and the LanFax driver is configured, we can continue 
the setup process.    You will be asked to restart the computer in the next section which 
will allow these newly configured values to take place.  To manually restart the service, 
please see the Troubleshooting section of this manual. 
 

LanFax Connection Test Utility 
This included Connection Test Utility is used to check the integrity of various settings 
when setting up a MOST server to work together with LanFax. It checks several settings 
to make sure that they are configured properly.  
 
Go to Start>Programs>Reform..>LanFax>Check Fax System  
Go to Connection Test Tab 
 

 
 

1. Checks LanFax plug-in registration  
2. Confirms the LanFax API is compatible with the LanFax plug-in 

3. Locates LanFax Printer Drivers 

4. Confirms PDF printing components are installed and configured 

5. Confirms Smart Device Monitor is installed (Go to SmartDevice Monitor 
Installation Tab to install). IT IS IMPORTATNT TO RESTART YOUR COMPUTER 
AFTER INSTALLING SMARTDEVICE MONITOR. THIS ENSURES THAT THE RICOH 
FAX SERVICE WILL START UP THE NEXT TIME YOUR COMPUTER TURNS ON. 
 

If configured correctly, all tests will show successfully confirmed. 
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MOST Configuration to Enable Remote Printing of Fax Statuses 
 

*If CommunicationType global variable is set to Local (MFP can be reached by IP on a 
local network), this step can be skipped.  In order to print documents remotely (when 
a MFP is not reachable by IP), the CommunicationType should be set to Remote and 
the following steps should be taken. 
 

 
 
Remote Printing must be enabled in the MOST Manager if the CommunicationType is 
set to Remote in the Global Variables configuration.   
 

1. To do so, first make sure MOST Manager is open by going to 
Start>Programs>Reform…>MOST>Manager.  It may be running in your task bar, 

so check for the small  icon and double click on it to bring up MOST Manager. 
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2. Go to Edit > Settings 
 

 
 

3. Go to the Devices tab. Here we need to check the Enable Remote Print checkbox 
if it is not already done so.  You must also specify your Reform installation’s 
Queue directory which is usually C:\Program Files\Reform…\Queue.  Use the 

browse button  to select this directory.  The polling interval is how often the 
MFP will check this directory for Fax Statuses.  If 30 seconds is not optimal for 
your environment, please change it to the desired value. 
 
Note: The lower the interval, the more network traffic/communications will 
occur. 
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4. After you have finished configuring Remote Printing, please click the Save 
button.  You will be prompted that the server must be restarted, click Yes. 

 

 
 
You have successfully configured MOST to enable the remote printing of Fax Statuses at 
your MFP. 
 

MOST LanFax Tutorial  
At this point, you should have a basic understanding of the functionality of MOST. In this 
tutorial, we’re going to be using the MOST Desktop to simulate an MFP running MOST 
and connecting to a MOST server. This tutorial assumes MOST connectivity has already 
been configured and established. (The MFP required for testing the Print Status 
functionality of this tutorial. Please refer to the MOST manual on how to setup MOST on 
the MFP or any other MOST related issues.) 
 
The emulator shows you exactly what you would see on an MFP, and it functions in the 
same way. This same process could be tested with the same exact steps, but by 
installing MOST on the MFP by following the instructions in the MOST manual. 
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1. Login to MOST at an MFP or use MOST Desktop (Start > Program > 
Reform…>MOST>Misc>MOST Desktop) using the username and password for 
which you gave the LanFax collection to.  In the tutorial, we configured the user 
demo, password demo.  Click Log In. 
 

 
 

2. The emulator will now connect to the MOST server and login. Once it logs in, you 
will see a series of collections and tabs. For this tutorial, we will be using the 
LanFax collection and tabs which you have made available to the user. 

 

 
 

3. From your LanFax collection you will see the Lookup screen which allows you to 
fax documents to multiple recipients.  The first thing we want to do is go to the 
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add contacts tab.  On the left, click on Add PB tab and fill out fields with the 
following information: 
Name: John Doe 
Company: Xyz Inc. 
Fax Number: Enter a valid fax number 
Verify Fax: Enter the same fax number entered above 
Phone Number: 1234567890 
City/State: Cedar Grove/NJ 
 
Click on Save Contact to add the contact  

 

 
 
After clicking Save Contact, we want to add another user to the phonebook.  
Add the following user: 
 
Name: Jane Doe 
Company: 123 Comp. 
Fax Number: Enter a valid fax number 
Verify Fax: Enter the same fax number entered above 
Phone Number: 9071234567 
City/State: Daly City/CA 
 
Click on Save Contact to add the contact to the phonebook. 
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4. On the left, click on the Lookup tab.  Click on the Search Faxbook button to 
display your newly added contacts (If contacts are not shown, make sure the 
Reform Spooler service is running and has the correct login credentials to carry 
out contact operations).  Leaving the search field blank will display all the 
available contacts. Select your contacts from the Faxbook listbox and click on 
Add Recipient button to populate the Recipient box.  You can also use the 
Manual Fax Number button to enter a fax number using the onscreen keyboard.  
Next, on the Notes field type in Important Announcement! and click Send Fax.  
To use a cover page, select from the combo box.  
Note: Make sure the Cover Sheet Files (FCP files) are stored in this directory 
C:\WINDOWS\system32\spool\drivers\w32x86\3. 

 

 



LANFax For MOST  16 
 

 

                                                                                                  LANFax For MOST 

 
5. We want to send another fax, this time using the Manual tab which lets us 

manually enter fax information.  On the left, click on the Manual tab and fill out 
the fields. Click on Send Fax button. To use a cover page, select from the combo 
box.  
Note: Make sure the Cover Sheet Files (FCP files) are stored in this directory 
C:\WINDOWS\system32\spool\drivers\w32x86\3. 
 
Name = Arnel Larry 
Notes = News Letter 
Fax Number = 2014567894 
 

 
 
 

6. Wait a moment and then click on the Status tab on the left hand side to view the 
status of your fax. 
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7. MFP is required to print the status. From your MFP select your document from 
the list.   You also have an option if you just want to see the first page of the fax 
document or all pages. Click on Print Status.  The first page will print the status 
of your fax followed by your document.  
 

8. On the left, click on the Edit PB tab, and select Jane Doe to be edited.  If your list 
is blank, click Faxbook and leave the search field blank to search all contacts.  
We will edit the following fields by replacing with these new values: Name = 
Mary Jane Doe, Company = Star Magic, Phone=2457894561. Click on Save 
Contact.   
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Wait a few seconds and click on Faxbook to refresh the list.  You should be able 
to see the changes you made. 

 
9. On the left Click on the Del PB tab.  Click on Faxbook to refresh the list if it does 

not have the latest changes you made in the previous step.  
 

 
 
 

10. Select John Doe and click on the Remove Contact button to delete from the List.  
Click on Faxbook to refresh the list (leave search blank).  Mary Jane Doe should 
be the only one left in the list. 
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Ricoh Fax Service 
A single service is installed with the Ricoh LANFAX plugin.  The purpose of this service is 
to communicate with the installed Fax device.  When you setup your fax enabled form, 
you had setup the line type and the driver for your fax system.  When data is printed to 
that form, it sends the document, line type and driver up to the SQL database.  This 
service monitors entries in that database in order to relay them to the actual fax device.  
This allows for tracking of documents as well as error correction and control.   
 
The service is installed during the Ricoh LANFAX plugin installation.  After the 
installation, you are prompted to restart your computer so that this service can be 
started.  The Ricoh Fax Service should be set to Automatic and should be started after 
restarting.  To view currently installed services, go to Start>Control 
Panel>Administrative Tools > Services. 
 

 
 

It is recommended to run the service under a domain account with administrative 
privileges on the local computer.  To do so, right click on the service and go to 
Properties.   Next, click on the Log On tab.  Use the “This Account” setting to enter the  
desired service account.  
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Click OK when complete.  The service may need to be restarted for the changes to take 
effect. 
 

Maintenance 
There are certain directories and SQL tables that need to be monitored for growth along 
with the Ricoh LanFax plugin for Reform 12.  As a system processes more and more jobs, 
the size of these directories and SQL tables can grow very quickly.  Overall system 
performance can be affected by the large amounts of space that the files may take up.  
Also, there exists a 4GB database limit if using the Microsoft SQL Server Express 2005 
supplied with this installation. Obsolete files/database entries should be deleted 
according to your needs and file retention specifications.  It is recommended to monitor 
the following directories and SQL tables for growth: 
Directories: 
C:\Program Files\Reform…\Backups 
C:\Program Files\Reform…\Spooler\ImageQueue 
C:\Program Files\Reform…\Plugins\DeviceViewer\FaxJobs\ 
 
SQL Tables: 
LanFaxPhoneBook 
RicohFaxTrans 
 

Troubleshooting 
Q: Faxes are not reaching the LANFax printer. 
A: You may have to restart the Ricoh Fax Service. 

1. Go to Control Panel>Administrative Tools>Services  
2. Find the service Ricoh Fax Service. 
3. Right-click on the service and click Restart. This will cycle the fax service. 
4. You may close the Services panel. 

 
Try sending another fax. You should see it briefly enter the queue of the LANFax printer 
before it is processed.  If still not working, make sure you can manually send faxes to the 
LANFAX driver before configuring Reform to do so. 
 
 
 
 
 
 
 
 

Other company or product names mentioned herein may be trademarks or registered 
trademarks of their respective companies 


