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About the Ricoh LANFax Plugin 
The Ricoh LANFax plug-in will allow Reform 12 to interact with a LANFax-enabled Multi 
Function Peripheral in order to automatically distribute documents to your fax system. 
 

System Requirements 
 Reform 12 Enterprise or Reform 12 PDC 

 Ricoh LANFax Plugin 

 For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 
Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 
Supported) 

 For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 
Operating Systems are Supported) 

 Smart Device Monitor (included with installation) 

 LANFax-enabled Multi Function Peripheral (supported drivers listed below) 

 Microsoft SQL Server (SQL Server Express will be automatically installed) 

 Microsoft .NET Framework 3.5 (installed automatically if not present on the 
current system) 

 Internet Information Services (IIS) 

 

All required Reform software downloads can be found at www.fabsoft.com >> 
Downloads section. 

 

Hardware Requirements 

 Production System Recommendation (These suggestions are only estimations. 
High load environments may require multiple servers, or additional hardware.) 

1. Pentium 4 Processor 
2. 4 GB RAM 
3. HDD Space 100 GB (Redundancy recommended) 
4. Battery Backup (UPS) 
5. Dedicated server, no other software products except for virus and 

security programs. 

 Minimum System Requirements for demonstration purposes only 
1. Pentium 4 Processor 
2. 2 GB RAM 
3. HDD Space 30 GB 

 
Hardware specifications depend greatly on the workload and throughput that is 
required.  Higher end processors and greater amounts of memory will increase the 
amount of information and data that Reform can process thus improving overall system 
throughput.  For load balancing or failover, multiple servers can also be used. (Note: A 

http://www.fabsoft.com/
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license for Reform and each plug-in is required for each server running the software.) 
Before obtaining the server that you plan on utilizing for Reform, please check the plug-
ins’ user manuals for System Requirements as well as they may require additional 
hardware.  For production systems, we also recommend redundant hard drives utilizing 
the mirroring features of RAID (Redundant Array of Independent Disks) to minimize data 
loss and expedite system recovery in the event of a hardware failure.  Battery backups 
are also suggested to maintain system uptime and reliability in case of power failures.     

Supported Drivers 

 RICOH LAN-Fax M3 and greater which is connected to the Local Area Network 

 RICOH LAN-Fax F3 and greater which is connected to the Local Area Network 
 

Installation 
To install the Ricoh LANFax plug-in to your existing Reform 12 installation, download 
and run the Ricoh LANFax installation executable. Before you begin the installation, it is 
important to note that you must already have a Ricoh device with a supported LANFax 
driver installed and working on this computer. 
 
If you are running Reform on a Windows 2003 Server, please see the Installing Internet 
Information Services (IIS) 2003 section of this manual before continuing 
 
If you are running Reform on Windows Vista, Windows 7 or Windows 2008 Server, 
please see the Configuring Internet Information Services (IIS) 7 section of this manual 
before continuing. 
 
If you meet all the requirements, please run the executable. 
 

 
Step through the prompts until the setup begins. Allow the LANFax installation to 
complete. 
 
The default installation directory for Reform 12 and its plugins is C:\Program 
Files\Reform…\.  If you have changed the path during the Reform installation routine, 
or if you are using a 64 bit operating system, please refer to the appropriate path 
instead of the default one referenced throughout this documentation.  
 

Plugin Registration and Licensing 

When evaluating Reform 12, the plugins will also be in an evaluation mode for that 
period of time.  Once Reform has been purchased and licensed, the required plugins 
must also be licensed in order to continue functioning correctly.    
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Please see the “Reform 12 Licensing and Registration” section of the Reform 12 User 
Manual for more information on how to license Reform 12 Plug-ins.  After the license is 
entered, the Reform Spooler will need to be restarted to refresh the licenses. More 
information regarding the Reform Spooler Service can be found in the Reform 12 User 
Manual. 
 

Connection Test and SmartDevice Monitor 
Next, we need to run the connection tests and install some additional software.  
 
Run the Ricoh Fax Client by going to: 

Start>Programs>Reform…>LAN-Fax>Check Fax System 
 

The first thing we have to do is make sure that SmartDevice Monitor is installed. Click on 
the SmartDevice Monitor Installation tab. If it tells you that the Monitor needs to be 
installed, click the Launch Client Setup button to run the installer for the SmartDevice 
Monitor.  

 
 

The SmartDevice Monitor installer is simple to run through. Keep the default settings for 
a Full Install, but on the screen below, be sure to check the option to run the 
SmartDevice Monitor for Client at startup. 
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Allow the setup to install the SmartDevice Monitor. After it finishes installing, restart 
your computer to complete the installation. If the SmartDeviceMonitor has already 
been installed, it is still important to restart your computer before proceeding in order 
to ensure that the RicohFax service has been started. 
 
After your computer restarts, open the Ricoh Fax Client. Click on the SmartDevice 
Monitor Installation tab. It should now say that the SmartDevice Monitor is installed. 
 

 
 

Now you are ready to perform a connection test. Click on the Connection Test tab, and 
step through each test. 

1. Checks to make sure the Ricoh LANFax Plug-In is correctly registered. 
2. Checks compatibility between the LANFax API and the Ricoh Fax Plug-in. 
3. Scans for all available LANFax-enabled printers. 
4. Checks for availability of PDF printing components. 
5. Makes sure the SmartDevice Monitor is installed. 

 

 
 

After you have successfully passed the 5 connection tests, you are ready to incorporate 
LANFax into your first form.  
 
Proceed to the next section: “Setting up your First Ricoh LANFax-Enabled Form.” 
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Setting up your First Ricoh LANFax-Enabled Form 
This tutorial will walk you through the steps of setting up a form to send a fax using a 
LANFax-enabled printer. 
 
First, the Reform Designer must be started.  To open it, go to 

Start>Programs>Reform…>Designer. 

1. For the example, we will be creating a new form with an existing template. Go to 
File>New>New. Select the Fax template and click OK. 
 

 
 

2. When it asks if you would like to open a text file for designing, select No. 
 

3. Next, go to File>Save to save your form. Name it Fax.FOM. 
 
4. You can now close the Reform Designer since we have our form which we will be 

using alongside the Workflow Designer to route the document. 

 

*Now that we have our form, we can begin to create the desired Ricoh LANFAX 

workflow using the Workflow Designer.  First, the Workflow Designer must be started.   

5. To open it, go to Start>Programs>Reform… >Workflow Designer. 

6. Once open, we must go to File > New… 
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7. At the below screen, select “Document Automation” and click Ok. 

 
 

8. You will now notice that your Inputs, Processes and Outputs have been populated by 

the various plugins you have installed (RicohFax being one of the Outputs) 



Reform To Ricoh LANFax  9 
 

 

 

 

9. Once opened, we can start adding the necessary components to the workflow.  

First, drag and drop a Form and File object onto the workflow by clicking and 

holding your mouse on Form and File and then moving your mouse over to the 

workflow and releasing the mouse button.  

 

 
 

*You will be prompted with the following dialog: 
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10. Enter a description for the object you just added.  This is done by typing in the 

provided box.  Type “RicohFax Demo” and click Finish. This will take you back to 

your workflow. 

11. Now we are ready to configure the “RicohFax Demo” form and input file.  To do so, 
right click on the newly added object and select “Configuration…” or simply 
double-click on it. 

 
12. You are now presented with the Input Setup window.  First, we want to select the 

TextFile or data stream that our form will be using.  To do so, you can simply begin 
typing in the box, or you can browse to find it.  We want to select the Fax.out file.  
Click the small folder icon to bring up a window which will let us choose that file.  
Select the file and click Open.   
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13. After choosing the text file, you are taken back to the Input Setup page so that you 

can now select a form.  Click the small folder icon to bring up a window which will 
let us choose the desired Fax.FOM form file.  Select the FOM file and click Open.  

 
14. Now that you have both your Input Text File and Reform Form selected, the setup 

of Form and File is complete.  You can quickly double check that the correct files 
are selected and then click Finish.  
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15. You will also be prompted to add a page-break field to the forms.  At this point, we 

want to select No. 

 

16. To finish the Fax workflow, we want to add a RicohFax Output.  We use the same 
drag and drop procedure as with the “Form and File” (see step 9).  Take your 
mouse and drag the “RicohFax” object from under Output onto the workflow 
somewhere below your Input.  Once you release your mouse, you will be prompted 
to describe “RicohFax”.  Type “Ricoh LANFAX” in the box and then click Finish. 

 

 

17. Once you click Finish, you are taken back to your workflow.  Your RicohFax will 
have a Red Caption because it is not yet configured. To configure RicohFax, you 
must first connect the Form and File object titled “RicohFax Demo”.  To do so, first 
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select the “Add Connector” button from the menu bar.  Next, drag your mouse 
from the small “x” underneath “RicohFax Demo” to the small “x” above “Ricoh 
LANFAX” as pictured below. When the connection is complete, the connecter will 
turn black (if red, connection has not been made correctly, try again) and the 
“RicohFax  Demo” caption will turn green. 

 

 
18. You will be prompted to configure RicohFax upon completing the connection.  Click 

Yes.   If you click No, you can begin the configuration by double clicking on the 

RicohFax object or right-clicking and selecting “Configuration…”.  This configuration 

will step you through all the settings necessary for RicohFax to successfully connect 

to your Ricoh LanFax driver and send faxes.  The first piece of information needed is 

your Username. This username should be the name you are currently logged in as. 

This will allow you to view the fax statuses in the Device Viewer. Type your 

username and click Next. 
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19. Next is the “Sender’s Company Name”.  Here we would like to use data that is 
available in the data stream instead of a static value.  To do so, we first must click 
the “Click here to select variable information” button.  

 
*Note-After doing so, we see that a list will appear with the different fields that you 
can choose for your variable data.  If you want to go back to static input mode, you 
can do so by clicking the appropriate button for static information and then you will 
be able type static information. 

 

20. We want to use the dynamic field ShipToName as the “Sender’s Company Name”. 
Select ShipToName from the list (You will have to scroll down) and click Next. 
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21. For “Sender’s Name”, we would like to again use variable data from the print 

stream.  To do so, first click the button “Click here to select variable data”.  From 

the list that appears, select ClientName and click Next. 

 
 

22. Next, it will ask you to enter the Department Name of the person sending the fax. 

Type in the value Accounting, and click Next. 
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23. Next, it will ask you to enter the Phone Number (NOT the fax number!) of the 

person sending the fax. Enter the value 973-555-0123, and click Next. 

 
 

24. Next, it will ask you to enter the Fax Number of the person sending the fax. Enter 

the value 201-555-1234, and click Next. 
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25. For “Recipient’s Company”, we would like to use variable data from the print 

stream.  To do so, first click the button “Click here to select variable data”.  From 

the list that appears, select ShipToName (scroll down) and click Next. 

 
 

26. For “Recipient’s Contact Name”, we would like to again use variable data from the 

print stream.  To do so, first click the button “Click here to select variable data”.  

From the list that appears, select ClientName and click Next. 
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27. Next, it will ask you to enter the Department Name of the person receiving the fax. 
Type in the value ShippingReceiving, and click Next. 

 
 

28. For “Note / Memo”, we would like to use variable data from the print stream.  To do 

so, first click the button “Click here to select variable data”.  From the list that 

appears, select Description and click Next. 
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29. Next, enter the Recipient Fax Number for the machine you wish to send the fax to. 
This number is where the fax will be sent.  

*PLEASE MAKE SURE THIS NUMBER CAN RECEIVE FAXES PROPERLY!* 

 
 

30. The wizard will now ask for the Line Type of the MFP. Select the Line Type for the 
Fax (Default is G3) and click Next. 
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31. Last, the wizard will now collect information about the LANFax driver you want to 
use. Select the LAN-Fax driver to use and click Finish. 

 
 

32. You have completed configuring your simple RicohFax workflow.  Your 2 objects 
(“RicohFax Demo” and “Ricoh LANFAX”) should all be green meaning they have 
been successfully configured and the workflow is ready to be created. 

 

 
33. To make all the appropriate forms and changes, the workflow must be executed.  

This is done by clicking the “Execute” button  on the menu bar.   After 
execution, you will be notified about what has taken place.  Click OK. 
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34. You can now close the Workflow Designer. Your form has been saved in your 
default forms directory.  A backup of your original Fax.FOM file has been copied to 
the “Workflow Designer Original Forms” folder in your forms directory.  .  Any 
permanent form changes should be made to this original form as it is used 
throughout the form configuration process as a template. If changes are made to 
this template, you will have to execute your workflow again to see the changes in 
the forms. 

 

35. The Spooler should now be started by clicking Start>Programs>Reform…>Spooler.  
Once it is open, press the Start button.  It should now say Start in the lower left 
corner. 

a. If it was already running, it will need to be stopped and restarted so that 

it recognizes the new forms that were created by the Workflow Designer. 
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36. Navigate to your \Reform\Backups\ directory. Select the Fax.out file, right click the 

file, and select Copy. 

 
 

37. Navigate to your \Reform\Spooler\ directory. Paste the file into the Spooler 

directory. (Pasting the data stream to this folder simulates printing from Windows, 

AS400, Unix, etc.) 

 
 

38. When the Spooler Application begins processing the file, you will notice the file 
name change to something similar to the image below. 

 
39. Once the document is faxed, the demonstration is complete.  If you are not getting 

your output, Reform Spooler might not have the correct permissions to process the 

file.  Please see the Reform 12 manual for more information.  You can re-print the 

document by copying the file from the backup directory to the spooler directory 

again.  You can also create another new form using the Workflow Designer. 
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You can also view the status of the LANFax job by opening the Device Viewer. This is 

covered in the next section. 

Monitoring the Fax Status from the Device Viewer 

The Device Viewer is a web-based monitoring system packaged with the Ricoh LANFax 
Plug-in that allows you to view the status of different jobs sent through Reform 
(Microsoft NET Framework 3.5 required to use the Device Viewer). Using the Device 
Viewer, you can see up to the minute status changes on an easy to use interface. 
You can open the Device Viewer by going to: 

Start>Programs>Reform…>LAN-Fax>Fax Web Client 
 

 
 

You will see a login screen (pictured above). Device Viewer automatically fetches your 
current Windows username that you are logged in with, and lets you log in with that 
name. To log in, you simply click the Login button. After you log in, you will see the main 
Device Viewer panel. 
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You will notice 3 different tabs on top of the main status area: Successful, Pending, and 
Failed. You can switch between these 3 tabs to view the status of any process sent to 
LANFax.  By default, you will only see faxes sent from your username. 
 
Customizing Views 
You can customize which columns will be displayed in the status panes by expanding the 
View Options list on the right side of page. This list contains all of the possible columns 
that can be displayed. By default, they are all selected and visible. Uncheck columns that 
you do not want to appear in the status pane. 

 
Managing Failed LANFax Jobs 
Jobs found under the Failed tab were unable to be correctly sent. This could be due to a 
multitude of problems. However, these jobs can be edited and re-sent to be tried again. 
 

 
 
Once on the Failed tab, you will see entries for each failed job. On the left of each job 
you will see 3 links: Preview, Delete, and Edit. 
 
Preview – This allows you to download a copy of the document that has failed. 
Delete – Completely deletes the job from the database. This is irreversible. 
Edit – This allows you to edit each field to correct any issues that may have caused the 
faxing to fail. After modifying the field(s), you can re-send the job so that LANFax may 
try to process it again. 
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After you have changed the appropriate fields, click on the Resend link on the left side. 
The page will refresh and the item you just modified will be moved to the Pending page 
until it is ready to be processed.  
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Recommendation to Improve Performance 
If you disable Communication Result Reports on your MFP, you can prevent delays in fax 
status updates. The Communication Result Report feature can cause these delays if the 
MFP has an open tray, is out of paper, or for any other reason is unable to print the 
report.  
 
To disable the Communication Result Report feature on your MFP, follow these steps: 

1. From the MFP controls, press the User Tools button. 
2. From the MFP screen, select Facsimile Features. 
3. Select the Administrator Tools tab from the MFP screen. (Initial settings tab on 

newer MFPs). 
4. Hit the Next button on the MFP screen at the bottom right corner of the screen 

to proceed to the second page of administration options. 
5. Select the Parameter Settings button on the MFP screen. 
6. Select the 03 button on the MFP screen. 
7. Deselect the 0 button that should appear to be pressed in and show a value of 1 

above it.  After deselecting the button, its current value should read 0. 
8. Select the OK button on the MFP screen and continue to select the Exit buttons 

on the previous screens until back at the screen you desire. 
 

Attachment Setup 
To configure Reform to use attachments with Ricoh LANFax, click on the Attachment 
Setup button beside the Transport Type dropdown list in Page Setup to call up the 
Attachment Setup dialog box.  

Note: The Ricoh LANFax plug-in only supports PDF attachments.  The Workflow 
Designer automatically configures this for you. 

 

Fax Cover Page  
To use the LANFax cover page in your faxes, select Fax Cover Page under the 
Automation submenu of the Options menu as usual. Instead of browsing for a cover 
page, type in the fax cover name that exists in your LANFax System. To use LANFax’ 
default cover page, type ‘System Default’ in the Cover Page File box. 
 
To view a list of available cover pages or to create new ones, please open the LanFax 
Cover Page editor by going to Start>LanFax-Utilities>Lan Fax Cover Sheet Editor. 
 

Ricoh Fax Service 
A single service is installed with the Ricoh LANFAX plugin.  The purpose of this service is 
to communicate with the installed Fax device.  When you setup your fax enabled form, 
you had setup the line type and the driver for your fax system.  When data is printed to 
that form, it sends the document, line type and driver up to the SQL database.  This 
service monitors entries in that database in order to relay them to the actual fax device.  
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This allows for tracking of documents as well as error correction and control.  If 
switching LANFax drivers, this service may need to be restarted. 
 
The service is installed during the Ricoh LANFAX plugin installation.  After the 
installation, you are prompted to restart your computer so that this service can be 
started.  The Ricoh Fax Service should be set to Automatic and should be started after 
restarting.  To view currently installed services, go to Start>Control 
Panel>Administrative Tools > Services. 
 

 
 

It is recommended to run the service as a domain account with administrative privileges 
on the local computer.  To do so, right click on the service and go to Properties. Next, 
click on the Log On tab.  Use the “This Account” setting to enter the desired service 
account.  Click OK when complete.  The service may need to be restarted for the 
changes to take effect. 
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Maintenance 
There are certain directories and SQL tables that need to be monitored for growth along 
with the Ricoh LanFax plugin for Reform 12.  As a system processes more and more jobs, 
the size of these directories and SQL tables can grow very quickly.  Overall system 
performance can be affected by the large amounts of space that the files may take up.  
Also, there exists a 4GB database limit if using the Microsoft SQL Server Express 2005 
supplied with this installation. Obsolete files/database entries should be deleted 
according to your needs and file retention specifications.  It is recommended to monitor 
the following directories and SQL tables for growth: 
Directories: 
C:\Program Files\Reform…\Backups 
C:\Program Files\Reform…\Spooler\ImageQueue 
C:\Program Files\Reform…\Plugins\DeviceViewer\FaxJobs\ 
 
SQL Tables: 
LanFaxPhoneBook 
RicohFaxTrans 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Other company or product names mentioned herein may be trademarks or registered 
trademarks of their respective companies. 
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Installing/Configuring Internet Information Services (IIS) 2003 
Internet Information Services is required to operate Device Viewer. This section will 
walk you through how to install IIS 2003, as well as configuring the installation to ensure 
proper Device Viewer functionality. This installation will require the Windows 2003 
Service Pack 2 CD/DVD to be inserted. 
 
Go to Start>Control Panel>Add/Remove Programs. 
 

 
 

In Add/Remove Programs, click the Add/Remove Windows Components button. 
 

 
 

You will see a list of Windows components that you can install. To find Internet 
Information Services, click on Application Server, then click the Details button. 
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Another window will pop up with several components you can install. We need to install 
Internet Information Services, so check the entry for IIS. You will notice that Enable 
network COM+ access will be selected—this is normal. Click the OK button. 

 

 
 

Click the Next button to begin the installation process. 
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The installation will now begin. After a few seconds, a prompt will appear asking you to 
choose the location of the files on the CD/DVD. Click on the Browse button to bring up 
an open file dialog. 
 

 
 

 
 

On the Service Pack 2 DVD, the file you need to locate can be found in: 
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D:\English\WindowsServer2003R2withSP2\Enterprise\32bit\i386\ CONVLOG.EX_ 

 

 
 

After you select the file, click OK to close the open file dialog, then click Retry in the 
Copy Error prompt. The installation will resume. 
 
After the installation is complete, you can close out of Add/Remove Programs. At this 
point, you should install the Ricoh LanFax plugin, and then return back to this section 
afterwards for configuring Internet Information Services to allow Device Viewer to 
function properly. 
 
After you have installed the Ricoh LanFax plugin: 
We are going to change some IIS settings that will allow Device Viewer to run in a 
Windows 2003 environment. 
 
Go to Start>Administrative Tools>Internet Information Services (IIS) 
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Expand the tree-view on the left panel under SystemName > Application Pools. Right-
click DefaultAppPool and select Properties. 
 

 
 

On the Identity tab, select the Predefined option, and choose Local System from the 
drop-down menu. Click OK to save your changes. 

 

 
 

On the left pane in the IIS Manager, click on Web Service Extensions. We need to allow 
the following extensions:  

 All Unknown ISAPI Extensions 

 Active Server Pages 

 ASP.NET v2.0.50727 

 Server Side Includes 
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Right-click each of these entries and click Allow. If a warning appears, ignore it and click 
Yes.  
 

 
 

Repeat these steps until all 4 of the aforementioned extensions have Allowed status, as 
shown below. 
 

 
 

The last thing we have to do is double-check that the correct version of ASP.NET is being 
used.  
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On the left pane, expand the tree-view Web Sites>Default Web Site. Right-click on 
Device Viewer and select Properties. 
 

 
 

In the Properties window, go to the ASP.NET tab and change the ASP.NET version to 
2.0.*. Click OK to close the Properties window, and you can now close the IIS Manager. 
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To ensure that Internet Information Services is now properly configured, try opening an 
Internet Explorer window and opening Device Viewer by navigating to: 

 
http://localhost/DeviceViewer 

 
If you are presented with the main login screen, you have correctly configured IIS to 
properly operate Device Viewer. 

 
Configuring Internet Information Services (IIS) 7 
This section will walk you through configuring DAC/DeviceViewer with IIS 7 in a 
Windows Server 2008 environment. 
 

1. Go to Start>Administrative Tools>Internet Information Services (IIS) Manager. 
2. Click on Application Pools in the Connections pane. 
 

 
 

3. In the Application Pools list, right-click on DAC/DeviceViewer and click Advanced 
Settings. 

 

http://localhost/DeviceViewer
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4. Set the following Properties: 

a. .NET Framework Version = v2.0 
b. Enable 32-Bit Applications = True 
c. Managed Pipeline Mode = Classic 
d. Identity = Local System 

5. Click OK to save your changes. 
6. In the Connections pane, expand Sites, expand Default Web Site, and select 
DAC/DeviceViewer. 

 

 
 

7. In the center pane, right-click on .NET Users and click Basic Settings. 
 

 
 
8. Click Connect As… Select the option Application User (pass-through 
authentication) and click OK. 
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9. Click OK in the Edit Application window to save your changes and close the 
window. 

10. Double-click Authentication in the central pane. 

 
11. Enable ASP .NET Impersonation and Windows Authentication. To enable an 
option, right-click on the item in the list and click Enable. 

12. Click on DAC/DeviceViewer in the Connections pane again to display the 
configuration categories in the central pane. Double-click HTTP Response Headers. 

 
Click Set Common Headers on the Actions pane. 
 

 
 

13. Check the Expire Web content option, and set it to 30 days. Click OK to save 
your changes. 

 

 
 

14. In the left pane, select your computer. 
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15. Double-click ISAPI and CGI Restrictions. 

 
16. Allow the following items in the list: 

 Active Server Pages 
 ASP.NET v2.0.50727 
 

 
17. You are finished configuring Internet Information Services 7. The Microsoft .NET 
Framework 3.5 SP1 may be required to be installed on the server.  

Troubleshooting 
Q: Faxes are not reaching the LANFax printer. 
A: You may have to restart the Ricoh Fax Service. 

1. From the Control Panel, open Printers and Faxes. 
2. Right-click on the LANFax printer you are trying to fax from. Click Pause Printing 

to pause the printer.  
3. Try sending another fax to the LANFax printer. 
4. After the fax is processed, check your LANFax printer print queue for a pending 

document. 
If there is a pending document in the queue, resume the printing and the document 
should be successfully faxed. If the queue is empty, continue on to step 5 to cycle 
the fax service. 
5. Go to Start>Run. Enter services.msc and press OK. 
6. Find the service Ricoh Fax Service. 
7. Right-click on the service and click Restart. This will cycle the fax service. 
8. You may close the Services panel. 
9. Go back into Printers and Faxes.  
10. Right-click the LANFax printer you just paused, and choose Resume Printing. 
11. You may close the Printers and Faxes window. 

Try sending another fax. You should see it briefly enter the queue of the LANFax printer 
before it is processed.  If still not working, make sure you can manually send faxes to the 
LANFAX driver before configuring Reform to do so. 
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Q: Fax status is coming back as “Not Authorized”. 
A: This implies that Faxing has been locked on the MFP.  The RicohLANFax plugin allows 
you to manually send a UserCode to the MFP that has access to the Faxing feature.  This 
will allow faxes to be sent even if the faxing panel is locked on the device.  Using the 
MFP’s Web Image Monitor, User Authentication Management must be set to “User 
Code” and an address book entry must be created for the user code.  Once you have 
taken the steps to create this UserCode, a Special Field should be added to your form.  
The name of this Special Field should be “LanFaxUserCode”.  To add a Special Field in 
the Reform Designer, first open the form you are using for faxing. Then click on the 
Design/Linked Text button in the toolbar and select Add Special Field. 
 

 
 

By clicking and dragging with your mouse cursor, draw the Special Field object onto your 
form. 
 

 
 

In the properties for the newly created special field, change the Name to 
LanFaxUserCode and enter the appropriate UserCode as the Text Value.  Your UserCode 
will be displayed in the Special Field object. 
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After creating this object, try resending your fax by going to File>Print (assuming you 
have the data stream open in the form).  If you have correctly configured the UserCode 
in the Web Image Monitor, your faxes should send successfully.  


