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About the RightFax Plug-in 
The Reform Rightfax plug-in will allow Reform 12 to interact with a RightFax server in 
order to automatically distribute documents to your fax system. 
 

System Requirements 
 Reform 12 Enterprise or Reform 12 PDC 

 RightFax Plugin 

 For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 
Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 
Supported) 

 For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 
Operating Systems are Supported) 

 RightFax FaxUtil application installed on the Reform Server (for client) 

 

All required Reform software downloads can be found at www.fabsoft.com >> 
Downloads section. 

 

Hardware Requirements 

 Production System Recommendation (These suggestions are only estimations. 
High load environments may require multiple servers, or additional hardware.) 

1. Pentium 4 Processor 
2. 4 GB RAM 
3. HDD Space 100 GB (Redundancy recommended) 
4. Battery Backup (UPS) 
5. Dedicated server, no other software products except for virus and 

security programs. 

 Minimum System Requirements for demonstration purposes only 
1. Pentium 4 Processor 
2. 2 GB RAM 
3. HDD Space 30 GB 

 

Hardware specifications depend greatly on the workload and throughput that is 
required.  Higher end processors and greater amounts of memory will increase the 
amount of information and data that Reform can process thus improving overall 
system throughput.  For load balancing or failover, multiple servers can also be used. 
(Note: A license for Reform and each plug-in is required for each server running the 
software.) Before obtaining the server that you plan on utilizing for Reform, please 
check the plug-ins’ user manuals for System Requirements as well as they may require 
additional hardware.  For production systems, we also recommend redundant hard 
drives utilizing the mirroring features of RAID (Redundant Array of Independent Disks) 
to minimize data loss and expedite system recovery in the event of a hardware failure.  

http://www.fabsoft.com/
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Battery backups are also suggested to maintain system uptime and reliability in case of 
power failures.  

 

Installation 
To install the Reform Rightfax plugin to your existing Reform 12 installation, download 
and run the Reform Rightfax installation executable. 
 

 
 

Step through the prompts, and the installation will begin. Allow the installation to 
complete and then read on to the next section to learn how to implement Reform 
Rightfax to your forms. 
 
The default installation directory for Reform 12 and its plugins is C:\Program 
Files\Reform…\.  If you have changed the path during the Reform installation routine, 
or if you are using a 64 bit operating system, please refer to the appropriate path 
instead of the default one referenced throughout this documentation.  
 
 

Plugin Registration and Licensing 

When evaluating Reform 12, the plugins will also be in an evaluation mode for that 
period of time.  Once Reform has been purchased and licensed, the required plugins 
must also be licensed in order to continue functioning correctly.    
 

Please see the “Reform 12 Licensing and Registration” section of the Reform 12 User 
Manual for more information on how to license Reform 12 Plug-ins.  After the license is 
entered, the Reform Spooler will need to be restarted to refresh the licenses. More 
information regarding the Reform Spooler Service can be found in the Reform 12 User 
Manual. 
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Setting up your First RightFax-Enabled Form 
In this tutorial, we are going to create a new form from an existing template, and then 
configure it using the Workflow Designer to send documents to a RightFax server. The 
RightFax Plug-in can be easily configured by using the Workflow Designer. 
 
First, the Reform Designer must be started.  To open it, go to 

Start>Programs>Reform…>Designer. 

1. For the example, we will be creating a new form with an existing template. Go to 
File>New>New. Select the Fax template and click OK. 
 

 
 

2. When it asks if you would like to open a text file for designing, select No. 
3. Next, go to File>Save to save your form. Name it Fax.fom. 
4. You can now close the Reform Designer since we have our form which we will be 

using alongside the Workflow Designer to route the document. 

 

*Now that we have our form, we can begin to fulfill the desired RightFax workflow using 

the Workflow Designer.  First, the Workflow Designer must be started.   

5. To open it, go to Start>Programs>Reform…>Workflow Designer. 

6. Once open, we must go to File > New… 
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7. Select “Document Automation” and click Ok. 

 
8. You will now notice that your Inputs, Processes and Outputs have been populated by 

the various plug-ins you have installed (RightFax being one of the Outputs) 
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9. We can start adding the necessary components to the workflow.  First, drag and 

drop a Form and File object onto the workflow by clicking and holding your mouse 

on Form and File and then moving your mouse over to the workflow and releasing 

the mouse button.  

 
*You will be prompted with the following dialog: 

 
 

10. Enter a description for the object you just added.  This is done by typing in the 

provided box.  Type “RightFax Demo” and click Finish. This will take you back to 

your workflow. 

11. Now we are ready to configure the “RightFax Demo” form and input file.  To do so, 
right click on the newly added object and select “Configuration…” or simply 
double-click on it. 
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12. You are now presented with the Input Setup window.  First, we want to select the 
TextFile or data stream that our form will be using.  To do so, you can simply begin 
typing in the box, or you can browse to find it.  We want to select the Fax.out file.  
Click the small folder icon to bring up a window which will let us choose that file.  
Select the file and click Open.   

 
13. After choosing the text file, you are taken back to the Input Setup page so that you 

can now select a form.  Click the small folder icon to bring up a window which will 
let us choose the desired Fax.FOM form file.  Select the FOM file and click Open.  
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14. Now that you have both your Input Text File and Reform Form selected, the setup 
of Form and File is complete.  You can quickly double check that the correct files 
are selected and then click Finish.  

 
 

15. You will also be prompted to add a page-break field to the forms.  At this point, we 
want to select No. 

 

16. To finish the Fax workflow, we want to add a RightFax Output.  We use the same 
drag and drop procedure as with the Form and File (see step 9).  Take your mouse 
and drag the “RightFax” object from under Output onto the workflow somewhere 
below your Input.  Once you release your mouse, you will be prompted to describe 
RightFax.  Type “RightFax” in the box and then click Finish. 
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17. Once you click Finish, you are taken back to your workflow.  Your RightFax will 
have a Red Caption because it is not yet configured. To configure RightFax, you 
must first connect the Form and File object titled “RightFax Demo”.  To do so, first 
select the “Add Connector” button from the menu bar.  Next, drag your mouse 
from the small “x” underneath “RightFax Demo” to the small “x” above “RightFax” 
as pictured below. When the connection is complete, the connecter will turn black 
(if red, connection has not been made correctly, try again) and the “RightFax 
Demo” caption will turn green. 

 
18. You will be prompted to configure RightFax upon completing the connection.  Click 

Yes.   If you chose not to, you can also double click on the RightFax object or 
rightclick and select “Configuration…”.  This configuration will step you through all 
the settings necessary for RightFax to successfully connect to your RightFax server 
and send faxes. The first page will ask for the server name and the user name that 
will be used to connect to the RightFax server. Fill in the ServerName and the 
Account Type, and then click the Next button.  
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19. The next piece of information the configuration requires is the FaxNumber where to 
send the fax to.  Enter in a valid fax number by typing it in the provided box and then 
click Next. 

 

20. Next is the “Recipient’s Name”.  Here, we would like to use data that is available in 
the data stream instead of a static value.  To do so, we first must click the “Click 
here to select variable information” button.  

 
*Note-After doing so, we see that a list will appear with the different fields that you 
can choose for your variable data.  If you want to go back to static input mode, you 
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can do so by clicking the appropriate button for static information and you will then 
be able type static information. 
 

21. We want to use the dynamic field ClientName as the “Recipient Name”.  Select 
ClientName from the list and click Next. 

 
22. For “Recipient’s Company Name”, we would like to again use variable data from the 

print stream.  To do so, first click the button “Click here to select variable data”.  

From the list that appears, select ShipToName (scroll down) and click Next. 
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23. Type in a value for the Recipient’s Phone Number, and click Next.  

 
 

24. Type in “Quote Information” for the Subject and click Next. 
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25. For “Notes”, we would like to again use variable data from the print stream.  To do 

so, first click the button “Click here to select variable data”.  From the list that 

appears, select Description and click Finish. 

 

 
 

26. You have completing configuring your simple RightFax workflow.  Your 2 objects 
(“RightFax Demo” and “RightFax”) should all be green meaning they have been 
successfully configured and the workflow is ready to be created. 
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27. To make all the appropriate forms and changes, the workflow must be executed.  

This is done by clicking the “Execute” button  on the menu bar.   After 
execution, you will be notified of the configuration that has taken place.  Click OK. 

 

 
 

28. You can now close the Workflow Designer. Your form has been saved in your 
default forms directory.  A backup of your original Fax.FOM file has been copied to 
the “Workflow Designer Original Forms” folder in your forms directory.  Any 
permanent form changes should be made to this original form as it is used 
throughout the form configuration process as a template. If changes are made to 
this template, you will have to execute your workflow again to see the changes in 
the forms. 

29. The Spooler should now be started by clicking Start>Programs>Reform…>Spooler.  
Once it is open, press the Start button.  It should now say Start in the lower left 
corner. 

a. If it was already running, it will need to be stopped and restarted so that 

it recognizes the new forms that were created by the Workflow Designer. 
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30. Navigate to your \Reform\Backups\ directory. Select the Fax.out file, right click the 

file, and select Copy. 

 
 

31. Navigate to your \Reform\Spooler\ directory. Paste the file into the Spooler 

directory. (Pasting the data stream to this folder simulates printing from Windows, 

AS400, Unix, etc.) 

 
 

32. When the Spooler Application begins processing the file, you will notice the file 
name change to something similar to the image below. 
 

 
 
33. Once the document is faxed, the demonstration is complete. If you are not getting 

your output, Reform Spooler might not have the correct permissions to process the 

file.  Please see the Reform 12 manual for more information.  You can re-print the 

document by copying the file from the backup directory to the spooler directory 

again.  You can also create a new form and configure it using the Workflow Designer. 

*Check your RightFax server to make sure the fax was successfully sent. 
*Check your RM_RightFAX_Monitor Service to see if it is running 
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Attachment Setup 

To configure Reform to use attachments with Reform Rightfax, open your Reform 
Designer. Open the form you would like to adjust and go to File > Page Setup. Click on 
the Attachment Setup button beside the Transport Type dropdown list in Page Setup to 
call up the Attachment Setup dialog box. The Attachment Setup dialog allows you to 
choose from various file types, resolutions and color formats for your attachments. 
 
The recommended attachment type for the RightFax plugin is a TIFF image with Group 4 
compression.  The Workflow Designer automatically configures this for you. 
 

Note: You can change the Color format to Gray Scale or Color, but you will 
experience a noticeable speed difference. 

 

Fax Cover Page  

To use the RightFax cover page in your faxes, open your Reform Designer. Open the 
form you would like to adjust and select Options > Automation > Fax Cover Page. 
Instead of browsing for a cover page, type in the fax cover name that exists in your 
RightFax System. To use RightFax’s default cover page, type System Default as the Cover 
Page, as pictured below. 
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Maintenance 
There are certain directories that need to be monitored for growth along with the 
RightFax plugin for Reform 12.  As a system processes more and more jobs, the size of 
these directories can grow very quickly.  Overall system performance can be affected by 
the large amounts of space that the files may take up.  Obsolete files should be deleted 
according to your needs and file retention specifications. It is recommended to monitor 
the following directories for growth: 
 

Directories: 
C:\Program Files\Reform…\Backups 
C:\Program Files\Reform…\Spooler\ImageQueue 
 

Troubleshooting 

 The RightFax Client must be installed on the computer running Reform. Reform 
communicates with RightFax using Port 445; this port must be permitted if any 
firewalls or network monitors are running. 

 Check all RightFax server settings including username and servername. 

 Make sure you are able to ping the fax server from the server running Reform. 

 Verify that the RightFax FaxUtil can connect to your RightFax server properly. 

 
Q: Nothing is happening after the form is processed. How can I determine the cause of 
an issue? 
A: Check the Event Log for errors related to Reform or RightFax.  The Event Log can be 
access by going to Control Panel > Administrative Tools > Event Log.   This will usually 
give you a good idea about why the faxes might be failing.   

 
 

Rightfax Service permissions: 

 Go to RM_RightFAX_Monitor Service and go into the properties. In the log on 
tab, use a administrator account and password to run the service as. 
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