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System Requirements 
 Reform 12 Enterprise or Reform 12 PDC  

 MOST Plugin  

 SharePoint Plugin  

 MOST SharePoint Plugin 

 For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 
Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 
Supported) 

 For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 
Operating Systems are Supported) 

 Microsoft .NET Framework 2.0 (this will be automatically installed if the installer 
does not find it on the system)  

 Microsoft SQL Express 2005 (SQL Server Express will be automatically installed by 
the SharePoint installer if it is not present on the current system)   

 SharePoint 2007, for demonstrations a SharePoint account is provided 

 

All required Reform software downloads can be found at www.fabsoft.com >> 
Downloads section. 

 

Hardware Requirements 

Please reference both the SharePoint Plugin Documentation and MOST 
Documentation regarding Hardware Requirements.   

 
Installation 
To install MOST-SharePoint to your existing Reform 12 installation, you will need to 
download and run the MOST-SharePoint installation executable.  

 
 

Step through the prompts and accept the User License Agreement. The installation will 
begin.  Allow the installation to complete and then read on to the next section to learn 
how to set up MOST SharePoint integration.   
 
You may see a prompt about a printer being already installed.  Click Close to continue. 

http://www.fabsoft.com/
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The default installation directory for Reform 12 and its plugins is C:\Program 
Files\Reform…\.  If you have changed the path during the Reform installation routine, 
or if you are using a 64 bit operating system, please refer to the appropriate path 
instead of the default one referenced throughout this documentation.  
 
After the installation, the MOST Manager should be restarted (may be running as a 
service) as it requires newly added files to be loaded upon startup.  To open the MOST 
Manager, go to Start>Programs>Reform…>MOST>Manager. Press the red Stop button 
and then the green Start button to restart it. 
 

 
 

The Reform Spooler Service must also be restarted.  Open up the Spooler by going to 
Start>Programs>Reform…>Spooler.  Click the Refresh button or the red stop button 
and then the blue start button.   
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Importing MOST Screen  
Please refer to the MOST manual for more information regarding MOST terminology, 
MOST Setup, and Connection Test. 

 
To import MOST screens for SharePoint Go to Start > Programs > Reform…> MOST-
SharePoint > Install MOST Screens 
 

 
 

If not already open, MOST Designer will appear.  You will be prompted if you want to 
Import SharePoint into MOST.  Click Yes. If asked if you want to overwrite files, click Yes.  
 

 
 

You can leave MOST Designer open as it will be used in the following section. 
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Setting Global Variables 
We need to setup the communication beween MOST and SharePoint.  To do so, we 
have to configure certain parameters in MOST’s Global variables screen.   If the MOST 
Designer is not already open, go to Start>Programs> Reform… >MOST>Designer. 
 
Go to Data>Global Variables on the menu bar. 
 

 
 
These are the Global Variables required to access our Hosted Demonstration SharePoint 
server.  Your SharePoint server settings may differ.  Select each variable one by one, 
enter its value in the provided box and then click the update button. 
CommunicationType, SPCacheType and SPModel global variables allow you to select 
available values from a drop down list.   
 

1. Variable Name =CommunicationType  Value= Local 
2. Variable Name=SPCacheType Value =Full 
3. Variable Name=SPModel Value=HOSTED  
4. Variable Name = SPProxyPassword Value= Go To: 

http://most3.fabsoft.net/SharePoint/ to get the current password. 
5. Variable Name = SPProxyUserName Value= tutorial 
6. Variable Name=SPDomain Value=  
7. Variable Name=SPSiteURLs Value=https://fabsoft2microsoftonlinecom-

4.SharePoint.microsoftonline.com 
8. Variable Name=SPUserNamePadding Value=@fabsoft2.microsoftonline.com 
 

*CommunicationType specifies whether or not the MFP is reachable by IP from the 
MOST server.  If the MFP is reachable by IP from the MOST server, the 
CommunicationType should be set to “Local”.  If the MFP is on a remote (wide area) 
network, the CommunicationType should be set to “Remote”. (Remote printing may 
be required in the MOST Manager) 
 
Note: SPModel has two options, Hosted and Internal.  Hosted should be used if each 
user’s SiteURL is the same.  Internal should be used if a username has to be appended to 
each user’s SiteURL. 
 

http://most3.fabsoft.net/SharePoint/
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SPAdminPassword and SPAdminUsername global variables are only required if using 
mulitple SharePoint Sites. 
 
For our demonstration server, we use a Proxy Username and Password in order to 
authenticate to the Hosted SharePoint server.  This means that any user who logs into 
MOST and utilizes the SharePoint colection will be doing so using the Proxy information.  
If a Proxy Username and Password is not specified, the user’s MOST credentials will be 
used to authenticate to SharePoint.  The SPUsernamePadding variable is used to append 
the SharePoint server information to the user’s login name in order to authenticate 
using the full credentials.  
 

Click  File>Save or use the small save icon  to save all the global variables. 
 
 

Assigning Collection to Users 
1. Open your MOST Designer if not already opened (Start>Programs> Reform… 

>MOST>Designer). 
2. On the MOST Designer tool bar, click on Data > Users and Groups 
3. Select the demo user from the User/Groups list.  We will be adding the 

SharePoint collection for this user.  The same process can be used for any user or 
group.   
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4. Select SharePoint from the Available Collections and click the   to add the 
SharePoint collection.  
 

 
 

5. File>Save or use the small save icon  to save your changes. 
 
 
 
 
 

MOST Configuration to Enable Remote Printing of Documents at the MFP 
 

*If CommunicationType global variable is set to Local (MFP can be reached by IP on a 
local network), this step can be skipped.  In order to print documents remotely (when 
a MFP is not reachable by IP), the CommunicationType should be set to Remote and 
the following steps should be taken. 
 
Remote Printing must be enabled in the MOST Manager if the CommunicationType is 
set to Remote in the Global Variables configuration.   
 

1. To do so, first make sure MOST Manager is open by going to 
Start>Programs>Reform…>MOST>Manager.  It may be running in your task bar, 

so check for the small  icon and double click on it to bring up MOST Manager. 
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2. Go to Edit > Settings 
 

 
 

3. Go to the Devices tab. Here we need to check the Enable Remote Print checkbox 
if it is not already done so.  You must also specify your Reform installation’s 
Queue directory which is usually C:\Program Files\Reform…\Queue.  Use the 

browse button  to select this directory.  The polling interval is how often the 
MFP will check this directory for documents to print.  If 30 seconds is not optimal 
for your environment, please change it to the desired value.   

 



SharePoint For MOST  10 

 

 

                                                                                                                                                          SharePoint For MOST 

 
 

4. After you have finished configuring Remote Printing, please click the Save 
button.  You will be prompted that the server must be restarted, click Yes. 

 

 
 

You have successfully configured MOST to enable the remote printing of SharePoint 
documents at your MFP. 

Using Caching with SharePoint 

To make the communication between SharePoint and MOST quicker and more efficient, 
the MOST SharePoint plugin allows you to enable caching via the SPCacheType global 
variable.  There are two options for SPCacheType: Full or None.  If the None setting is 
used for SPCacheType, MOST will communicate with the SharePoint server each time 
the SharePoint tabs are accessed.  If Full caching is used, each user will have a cache file 
saved on the MOST server which contains the available SharePoint directories and files.  
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Instead of having to connect to SharePoint each time to retrieve this list, MOST 
SharePoint will use the cache file.  
 
If using Full caching, it is recommended that you run the SharePoint Full Cache 
Builder.exe located in C:\Program Files\Reform…\Plugins\MOST2\ regularly in order to 
“rebuild” the cache files with the up to date SharePoint server contents.  This periodic 
update will allow any updates, such as file deletion or new directories, to be updated in 
each user’s cache file.  The simplest way to schedule the process to run this update 
periodically is to use the MOST Manager.   
 

1. Go to Start>Programs>Reform…>MOST>Manager.  It may be running in your 

task bar, so check for the small  icon and double click on it to bring up MOST 
Manager. 

 

 
 

2. Go to Edit > Settings 
 

 
 

3. Go to the Processes tab.  
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4. Here, we want to select the  C:\Program Files\Reform…\Plugins\MOST2\ 

SharePoint Full Cache Builder.exe file.  To do so, click the  button to browse 
for the file.  Select SharePoint Full Cache Builder.exe  and click Open. 
 

 
 

5. The Interval is how often MOST will run the exe and update each user’s cache.  It 
is recommended to set this to 60 minutes (1 hour).  Depending on your 
environment, a shorter or longer time period may work better.  After setting the 
interval, click the Add button. 
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6. After adding the file, it will show up in the Scheduled Processes list.  You can 
now click Save. 
 

 
 

7. You will be prompted that the server must be restarted, click Yes. 
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You have successfully configured MOST to rebuild your SharePoint cache automatically 
every 60 minutes. 
 
 

MOST SharePoint Tutorial 

The emulator shows you exactly what you would see on an MFP, and it functions in the 
same way (SharePoint documents cannot be printed using the emulator, it requires an 
MFP). This same process could be tested with the same exact steps, but by installing 
MOST on the MFP by following the instructions in the MOST manual. (Please refer to the 
MOST manual on how to setup MOST in the MFP or any other MOST related issues.) 
 

1. Login to MOST at an MFP or use MOST Desktop (Start > Program > 
Reform…>MOST>Misc>MOST Desktop) using the demo account.  Username is 
demo, password is demo. 

 
 

2. The emulator will now connect to the MOST server and login. It may take several 
seconds to log in, since MOST must connect to the SharePoint server to retrieve 
the account settings. If logging in for the first time, you may see a message in the 
upload directory.  This is because your user’s SharePoint list is being built for the 
first time.  Please wait about 2 minutes and then click the Log Out button.   
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3. Now log back in with the same credentials (Username=demo, Password=demo).  
This time when you log in you will notice that your upload directory list has been 
populated with available SharePoint sites.  To expand a SharePoint site, click the 
+ symbol next to its name.   
 

 
 

4. Clicking the “+” will display the available directories in the selected SharePoint 
Site. 
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5. Select Tutorial from the list.  After making the selection you will notice in the 
Attributes box the attributes associated with the directory are displayed.  

 
 

6. In the Filename field, type in a file name. Using a unique name will make it easier 
to locate the file using the SharePoint web interface. Ex filename: John Doe - 
MOST Demo 

7. Enter today’s date in the date field. 
8. Enter 100075 in the Deal Number field 
9. Enter your name in the Customer Name field.  
10. After filling out all the fields, place your documents in the feeder and click on 

Scan to SP.  If using MOST Desktop, it will ask you to select a file to simulate your 



SharePoint For MOST  17 

 

 

                                                                                                                                                          SharePoint For MOST 

scan.  Your scan document should be sent to SharePoint along with the 
attributes. 
*Note – Please make sure the SharePoint service is running. Otherwise the 
document won’t be uploaded. Please see the section SharePoint Service in this 
document for more information on how to manually start the service.  

 
 

11. Click on the SPStatus tab to see the status of your document.  It may take a few 
seconds to refresh the list. We have sent a couple more documents for 
demonstration purposes. 
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12. Click on the SPPrint tab.  If using MOST Desktop, you will only be able to Preview 
the document as an MFP is required to do the printing.  In this tab, you will see 
the document that you just submitted.  Navigate through the SharePoint site on 
the screen to the Tutorial directory.  Select the John Doe MOST Demo.PDF file.  
Click on Preview to preview the document.  Click on the Print button to print the 
document.  
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Viewing your document in FabSoft’s SharePoint Demonstration Site 
 

1. Open your internet browser and copy this address  
http://most3.fabsoft.net/SharePoint/ 
 

 
 

2. You will be asked to enter the username and password on the next screen so 
please take note of the Username and Password.  Click on Continue. 
 

3. Enter the username and password from the previous screen. Click Ok. 
 

http://most3.fabsoft.net/SharePoint/
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4. On the left side under Documents, click on Tutorial to see your uploaded 

document. 
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5. Documents uploaded are listed below. You can open the document and also 
view the attributes associated with the document. 
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SharePoint Service 
Go to Start > Programs > Control Panel > Administrative Tools > Services 
To start the service: right click on SharePointService > Properties. Under Service status, 
click on Start. 

 
 

This service acts as a liaison between Reform 12 and Microsoft SharePoint.  It allows for 
Reform to upload documents and their properties to the SharePoint server.  Depending 
on your environment, it may be required that this service is run under a local 
administrative account 
 

Maintenance 
There are certain directories and SQL tables that need to be monitored for growth along 
with the SharePoint plugin for Reform 12.  As a system processes more and more jobs, 
the size of these directories and SQL tables can grow very quickly.  Overall system 
performance can be affected by the large amounts of space that the files may take up.  
Also, there exists a 4GB database limit if using the Microsoft SQL Server Express 2005 
supplied with this installation. Obsolete files/database entries should be deleted 
according to your needs and file retention specifications.  It is recommended to monitor 
the following directories and SQL tables for growth: 
 
Directories: 
C:\Program Files\Reform…\Backups 
C:\Program Files\Reform…\Spooler\ImageQueue 
C:\Program Files\Reform…\Plugins\SharePoint\Uploads 
 
SQL Tables: 
SharePointTrans 
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Troubleshooting 
Q: Nothing is happening after the form is processed. How can I determine the cause of 
an issue? 
A: Check the Event Log for errors related to Reform or the SharePoint service.  The Event 
Log can be access by going to Control Panel > Administrative Tools > Event Log.   This will 
usually give you a good idea about why the MOST SharePoint plugin might be failing.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Other company or product names mentioned herein may be trademarks or registered 
trademarks of their respective companies 


