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About the SharePoint Plug-in 
The SharePoint plug-in acts as a bridge between Reform and SharePoint.  It allows you 
to archive documents processed by Reform to SharePoint Document Libraries where 
your collection of documents can be shared. 
 
Reform Enterprise/PDC maximizes the integration with Microsoft’s SharePoint by 
enabling automatic delivery of document information from any operating system, 
application or device. Whether a document is being printed from the host, scanned in 
using an MFP or copier, or generated by a user from an application, Reform will capture 
the process, extract the text and intelligently archive it to SharePoint. With Reform’s 
alternative input options, more of your valuable information can be effortlessly 
accessed and easily shared company-wide through SharePoint. Reform can control 
directory locations as well as custom index information to simplify document retrieval. 
Fast and easy access to important information is an extremely vital resource, and 
Reform’s integration capabilities to SharePoint let you obtain the most comprehensive 
document information archive to improve the workflow of your business operations. 
 

System Requirements 
 Reform 12 Enterprise or Reform 12 PDC  

 SharePoint Plugin  

 For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 
Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 
Supported) 

 For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 
Operating Systems are Supported) 

 Microsoft SQL Server (SQL Server Express will be automatically installed by the 
SharePoint installer if it is not present on the current system)  

 Microsoft .NET Framework 2.0 (installed automatically if not present on the 
current system)  
 

All required Reform software downloads can be found at www.fabsoft.com >> 
Downloads section. 

 

Hardware Requirements 
 Production System Recommendation (These suggestions are only estimations. 

High load environments may require multiple servers, or additional hardware.) 
1. Pentium 4 Processor 
2. 4 GB RAM 
3. HDD Space 100 GB (Redundancy recommended) 

http://www.fabsoft.com/
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4. Battery Backup (UPS) 
5. Dedicated server, no other software products except for virus and 

security programs. 

 Minimum System Requirements for demonstration purposes only 
1. Pentium 4 Processor 
2. 2 GB RAM 
3. HDD Space 30 GB 

 
Hardware specifications depend greatly on the workload and throughput that is 
required.  Higher end processors and greater amounts of memory will increase the 
amount of information and data that Reform can process thus improving overall system 
throughput.  For load balancing or failover, multiple servers can also be used. (Note: A 
license for Reform and each plug-in is required for each server running the software.) 
Before obtaining the server that you plan on utilizing for Reform, please check the plug-
ins’ user manuals for System Requirements as well as they may require additional 
hardware.  For production systems, we also recommend redundant hard drives utilizing 
the mirroring features of RAID (Redundant Array of Independent Disks) to minimize data 
loss and expedite system recovery in the event of a hardware failure.  Battery backups 
are also suggested to maintain system uptime and reliability in case of power failures.     
 

 

Installation 
To install the SharePoint Plug-in components, download and run the installer. 
 

 
Step through the prompts and accept the User License Agreement. The installation will 
begin.  Allow the installation to complete and then read on to the next section to learn 
how to set up the SharePoint integration.  
 
The default installation directory for Reform 12 and its plugins is C:\Program 
Files\Reform…\.  If you have changed the path during the Reform installation routine, 
or if you are using a 64 bit operating system, please refer to the appropriate path 
instead of the default one referenced throughout this documentation.  
 

Plugin Registration and Licensing 
When evaluating Reform 12, the plugins will also be in an evaluation mode for that 
period of time.  Once Reform has been purchased and licensed, the required plugins 
must also be licensed in order to continue functioning correctly.    
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Please see the “Reform 12 Licensing and Registration” section of the Reform 12 User 
Manual for more information on how to license Reform 12 Plug-ins.  After the license is 
entered, the Reform Spooler will need to be restarted to refresh the licenses. More 
information regarding the Reform Spooler Service can be found in the Reform 12 User 
Manual. 
 

Sending Your First Document to SharePoint 
After installing the SharePoint plug-in, it is important to confirm that the SharePoint 
Service is running. This can be done by restarting the PC or by manually starting the 
service. For more information on starting it manually, please see the Starting 
SharePoint Service section at the end of this manual.  
 

 

Very Important: 
To get the current username and password for Reform’s demonstration 
SharePoint account, go To: http://most3.fabsoft.net/SharePoint/ (Please take 
note of the username and password for it will be used throughout the 
configuration.)  The username is: tutorial@fabsoft2.microsoftonline.com , since 
the password is updated regularly it will need to be retrieved from this website. 
 

 
 

http://most3.fabsoft.net/SharePoint/
mailto:tutorial@fabsoft2.microsoftonline.com
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First, the Reform Designer must be started.  To open it, go to 

Start>Programs>Reform…>Designer. 

 

1. For the example, we will be creating a new form with an existing template. Go to 
File > New > New. Select the SHAREPOINT.FTM and click OK. 

 

 
 
2. When it asks if you would like to open a text file for designing, select No. 

 
3. Next, go to File>Save to save your form. Name it SharePointPackingSlip.FOM 
 
4. You can now close the Reform Designer since we have our form which we will be 

using alongside the Workflow Designer to route the document. 

 

*Now that we have our form, we can begin to create the desired SharePoint workflow 

using the Workflow Designer.  First, the Workflow Designer must be started.   

5. To open it, go to Start>Programs>Reform…>Workflow Designer. 

6. Once open, we must go to File > New… 

 

7. Select “Document Automation” and click Ok. 
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8. You will now notice that your Inputs, Processes and Outputs have been populated by 

the various plugins you have installed (SharePoint being one of the Outputs) 
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9. Once opened, we can start adding the necessary components to the workflow.  

First, drag and drop a Form and File object onto the workflow by clicking and 

holding your mouse on Form and File and then moving your mouse over to the 

workflow and releasing the mouse button.  

 
*You will be prompted with the following dialog: 

 
 

10. Enter a description for the object you just added.  This is done by typing in the 

provided box.  Type “SharePoint Demo” and click Finish. This will take you back to 

your workflow. 

11. Now we are ready to configure the “SharePoint Demo” form and input file.  To do 
so, right click on the newly added object and select “Configuration…” or simply 
double-click on it. 
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12. You are now presented with the Input Setup window.  First, we want to select the 
TextFile or data stream that our form will be using.  To do so, you can simply begin 
typing in the box, or you can browse to find it.  We want to select the 
SharePointPackingSlip.out file.  Click the small folder icon to bring up a window 
which will let us choose that file.  Select the file and click Open.   

 

 
 

13. After choosing the text file, you are taken back to the Input Setup page so that you 
can now select a form.  Click the small folder icon to bring up a window which will 
let us choose the desired SharePointPackingSlip.FOM form file.  Select the FOM 
file and click Open.  
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14. Now that you have both your Input Text File and Reform Form selected, the setup 
of Form and File is complete.  You can quickly double check that the correct files 
are selected and then click Finish.  

 

 
 

15. You will also be prompted to add a page-break field to the forms.  At this point, we 
want to select No. 
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16. To finish the SharePoint workflow, we want to add a SharePoint Output.  We use 
the same drag and drop procedure as with the “Form and File” (see step 9).  Take 
your mouse and drag the “SharePoint” object from under Output onto the 
workflow somewhere below your Input.  Once you release your mouse, you will be 
prompted to describe “SharePoint”.  Type “SharePoint Upload” in the box and 
then click Finish. 

 

 

17. Once you click Finish, you are taken back to your workflow.  Your SharePoint will 
have a Red Caption because it is not yet configured. To configure SharePoint, you 
must first connect the Form and File object titled “SharePoint Demo”.  To do so, 
first select the “Add Connector” button from the menu bar.  Next, drag your 
mouse from the small “x” underneath “SharePoint Demo” to the small “x” above 
“SharePoint Upload” as pictured below. When the connection is complete, the 
connecter will turn black (if red, connection has not been made correctly, try again) 
and the “SharePoint Demo” caption will turn green. 
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18. You will be prompted to configure SharePoint upon completing the connection.  

Click Yes.  If you clicked No, you can double click on the SharePoint object or 
rightclick and select “Configuration…” to begin the setup.  This configuration will 
step you through all the settings necessary for SharePoint to successfully connect 
to a SharePoint server and upload files.  The first piece of information is the file 
type you want your document to be archived with into SharePoint.  Select “PDF 
File” and click Next. 
 

 
 
19. To use the Reform demonistration SharePoint account, copy/paste or type in the 

following for the ServerURL: 
https://fabsoft2microsoftonlinecom-4.SharePoint.microsoftonline.com/ 
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20. Enter the Username. Click Next.   
The username is: tutorial@fabsoft2.microsoftonline.com , since the password is 
updated regularly it will need to be retrieved from our website. (Refer to this site to 
get the current credentials for Reform Tutorial: 
http://most3.fabsoft.net/SharePoint/) 
 

 

mailto:tutorial@fabsoft2.microsoftonline.com
http://most3.fabsoft.net/sharepoint/
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21. Type in the password and click on Next. 
(Refer to this site to get the current credentials for Reform Tutorial 
http://most3.fabsoft.net/SharePoint/) 

 
 

22. Skip the domain field by clicking on Skip. 
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23. You might need to wait a few minutes while it’s loading the SharePoint properties. If 
you entered any incorrect information, close any dialogs that may come up and try 
the configuration again.  When the wizard window appears, type in a Filename. 
Using a unique file name will help you find the file easier later. Click Next. 

 

 
 
24. Select Tutorial for the Document Library where you would like to upload your 

document. Click Next. Note: If you are using a different SharePoint server than the 
one described in this tutorial, you may see different libraries available. 
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25. Select Tutorial for the directory and click Next. 
 

 
 

26. The following screen asks for the CUSTOMER NAME that the upload will be 
archived under.  Here we would like to use data that is available in the data stream 
instead of a static value.  To do so, we first must click the “Click here to select 
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variable information” button. Note: The attributes available for configuration are 
based on the directory selected. If you select a different document library or folder, 
you may see different attributes than the ones listed in the next few steps of this 
manual. 

 

 
 

*Note-After doing so, we see that a list will appear with the different fields that you can 
choose for your variable data.  We will be selecting from this list, but if you needed to 
still type static data, you can do so by clicking the appropriate button for static 
information and then typing it in. 
 
27. Now we want to use ShipAddress as our “CUSTOMER NAME” value.  Select 

ShipAddress  from the list and click Next 
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28. For “DATE”, we would like to again use variable data from the print stream.  To do 

so, first click the button “Click here to select variable data”.  From the list that 

appears, select ShipDate and click Next. 

 
29. Type in 121280 for the Deal Number and click Finish. 

 



Reform To SharePoint                                                                           19 

 

 

                                                                                                                                                                                                                                                                                                                              SharePoint 

 
 

30. You have completing configuring your simple SharePoint workflow.  Your 2 objects 
(“SharePoint Demo” and “SharePoint Upload”) should all be green meaning they 
have been successfully configured and the workflow is ready to be created. 

 

 
 

31. To make all the appropriate forms and changes, the workflow must be executed.  

This is done by clicking the “Execute” button  on the menu bar.   After 
execution, you will be notified about what has taken place.  Click OK. 
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32. You can now close the Workflow Designer. Your form has been saved in your 

default forms directory.  A backup of your original SharePointPackingSlip.FOM file 
has been copied to the “Workflow Designer Original Forms” folder in your forms 
directory.  Any permanent form changes should be made to this original form as 
it is used throughout the form configuration process as a template. If changes are 
made to this template, you will have to execute your workflow again to see the 
changes in the forms. 

 

 
33. To test out your settings and make sure that files can be uploaded, first we should 

open the form with the Reform Designer.  Navigate to your Forms directory and 
double click on SharePointPackingSlip.FOM.  When asked to open the associated 
TextFile, click Yes. Verify that the special fields exist on the right hand side of your 
form.  

 
34. Go to File>Print in the Designer to send the document to SharePoint. 

 
Note: make sure that SharePoint Service is running. For more information please see the  
Starting SharePoint Service section at the end of this document to start it manually.  
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Viewing your document in FabSoft’s SharePoint Demonstration 
Site 
 

1. Open your internet browser and copy this address  
http://most3.fabsoft.net/SharePoint/ 
 

 
 

2. You will be asked to enter the username and password on the next screen so 

please take note of the Username and Password.  Click on Continue. 
 

3. Enter the username and password from the previous screen. Click Ok. 
 

http://most3.fabsoft.net/SharePoint/
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4. On the left side under Documents, click on Tutorial to see your uploaded 

document. 
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5. Documents uploaded are listed in the Tutorial Library. You can open the 
document and also view the attributes associated with the document. 
 

 

 
Maintenance 
There are certain directories and SQL tables that need to be monitored for growth along 
with the SharePoint plugin for Reform 12.  As a system processes more and more jobs, 
the size of these directories and SQL tables can grow very quickly.  Overall system 
performance can be affected by the large amounts of space that the files may take up.  
Also, there exists a 4GB database limit if using the Microsoft SQL Server Express 2005 
supplied with this installation. Obsolete files/database entries should be deleted 
according to your needs and file retention specifications.  It is recommended to monitor 
the following directories and SQL tables for growth: 
 
Directories: 
C:\Program Files\Reform…\Backups 
C:\Program Files\Reform…\Spooler\ImageQueue 
C:\Program Files\Reform…\Plugins\SharePoint\Uploads 
 
SQL Tables: 
SharePointTrans 
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Starting SharePoint Service 
Go to Start > Programs > Control Panel > Administrative Tools > Services 
Right click on RM_SharepointMonitor > Properties. Under Service status click on Start. 
 

 
 

This service acts as a liaison between Reform 12 and Microsoft SharePoint.  It allows for 
Reform to upload documents and their properties to the SharePoint server.   

 
 

Troubleshooting 
Q: Nothing is happening after the form is processed. How can I determine the cause of 
an issue? 
A: Check the Event Log for errors related to Reform or the SharePoint service.  The Event 
Log can be access by going to Control Panel > Administrative Tools > Event Log.   This will 
usually give you a good idea about why the SharePoint plugin might be failing.   
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