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About the Reform Tracker Plug-in 
The Reform Tracker plug-in allows for seamless Printer and MFP monitoring.  There are 
two main components which are the monitoring and reporting.  The monitoring 
component is able to retrieve information about print jobs such as the number of black 
and white/color pages, the amount of copies, time and date printed and a various 
amount of user information.  The reporting component is able to intelligently gather this 
data about the print jobs and compile it into user friendly reports.  Also, if using MOST 
enabled MFPs, the Reform Tracker is able to configure and lock functions based on 
devices or LDAP users and groups.  It can also monitor and limit the number of black and 
white/color copies made. 
 
The printing portion of Reform Tracker has two modes: Passive and Active.  Passive 
monitoring simply monitors the print traffic and stores the information so that reports 
can be generated. The active mode allows for limits to be set on the printer drivers, as 
well as allowing the users to redirect print jobs to other devices.  If the user has 
exceeded their limit, or no device is permitted to print a large document, users also 
have the ability to send the document as a PDF to their own email address with the click 
of a button. 

 
System Requirements 
¶ Reform 12 Enterprise or Reform 12 PDC  

¶ Reform Tracker Plug-in  

¶ Reform Email Plug-in is optional. The email plug-in is only required if you would 
ƭƛƪŜ ǘƻ ǊŜŘƛǊŜŎǘ ǇǊƛƴǘ Ƨƻōǎ ǘƻ ǘƘŜ ǳǎŜǊΩǎ ŜƳŀƛƭ ŀŘŘǊŜǎǎΦ 

¶ For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 
Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 
Supported) 

¶ For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 
Operating Systems are Supported) to run Reform v12 

¶ Microsoft Visual Studio Report Viewer(Installed with Reform Tracker installation 
if not present on the current system) 

¶ Microsoft SQL Server (SQL Server Express will be automatically installed by the 
MOST installer) 

¶ Microsoft .NET Framework 2.0 (installed automatically)  Microsoft SQL Express 
2005 (installed automatically) 

 
 
 

All required Reform software downloads can be found at www.fabsoft.com >> 
Downloads section. 

http://www.fabsoft.com/
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Hardware Requirements 

¶ Production System Recommendation (These suggestions are only estimations. 
High load environments may require multiple servers, or additional hardware.) 

1. Pentium 4 Processor 
2. 4 GB RAM 
3. HDD Space 100 GB (Redundancy recommended) 
4. Battery Backup (UPS) 
5. Dedicated server, no other software products except for virus and 

security programs. 

¶ Minimum System Requirements for demonstration purposes only 
1. Pentium 4 Processor 
2. 2 GB RAM 
3. HDD Space 30 GB 

 

Printer Requirements 
¶ It is recommended that the Universal PCL6 Driver is used for Ricoh devices. 

 

Reform Tracker Pre-Requisites  
 

Tracker requires the ports to be open through the windows firewall (or other firewall if 
installed): 
 

¶ TCP 139 

¶ TCP 445 

¶ UDP 137 

¶ UDP 138 
 
These ports are used for File/Printer Sharing and are required to deploy the software to 
the PCs.   
 
 
Also, the tracker software will also need to run as a Windows Service.  The service will 
need to run as an account that is administrator on the workstations it will run on.  Also, 
an account with permission to install the software onto the workstation will also be 
needed to deploy. 
 
Two accounts are needed: 
 

¶ Service account that is administrator on the workstation. Used to run the 
software. 
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¶ Account that is administrator on the workstation and can access the 
computer remotely. Used to deploy the software. 
 

The client can enter the credentials.  FabSoft does not need to know the passwords etc. 
 
 

Installation 
 

To install the Reform Tracker plugin, download and run the installer. 
 

 
 
Step through the prompts and accept the User License Agreement. The installation will 
begin.  Allow the installation to complete and then read on to the next section to learn 
how to set up Reform Tracker integration.  
 
The default installation directory for Reform 12 and its plugins is C:\ Program 
Files\wŜŦƻǊƳΧ\ .  If you have changed the path during the Reform installation routine, 
or if you are using a 64 bit operating system, please refer to the appropriate path 
instead of the default one referenced throughout this documentation.  
 
bƻǘŜΥ LŦ ŘǳǊƛƴƎ ǘƘŜ ƛƴǎǘŀƭƭŀǘƛƻƴΣ ȅƻǳ ŜƴŎƻǳƴǘŜǊ ǘƘŜ ŘƛŀƭƻƎ ά¢Ƙƛǎ ǇǊƻƎǊŀƳ Ƙŀǎ ƪƴƻǿƴ 
ŎƻƳǇŀǘƛōƛƭƛǘȅ ƛǎǎǳŜǎέ ǇƭŜŀǎŜ ŎƭƛŎƪ ǘƘŜ άwǳƴ ǇǊƻƎǊŀƳέ ōǳǘǘƻƴ ǘƻ ŎƻƴǘƛƴǳŜΦ  ¢ƘŜ wŜŦƻǊƳ 
software and plug-ins have been tested on all supported operating systems without 
issues. 
  

 
 
CƻǊ tǊƛƴǘ vǳŜǳŜ aƻƴƛǘƻǊ ŀǇǇƭƛŎŀǘƛƻƴ ƭƛŎŜƴǎƛƴƎΣ ǇƭŜŀǎŜ ǎŜŜ ǘƘŜ άFabSoft License Manager 
- Print Queue Monitor Applicationέ ǎŜŎǘƛƻƴ ƻŦ ǘƘƛǎ ƳŀƴǳŀƭΦ 
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Once Tracker is installed, the Web.config file has 3 entries which point to specific file 

paths.  This is to allow for settings files to be moved outside the website directory. 

 

Plugin Registration and Licensing 

When evaluating Reform 12, the plugins will also be in an evaluation mode for that 
period of time.  Once Reform has been purchased and licensed, the required plugins 
must also be licensed in order to continue functioning correctly.    
tƭŜŀǎŜ ǎŜŜ ǘƘŜ άwŜŦƻǊƳ мн [ƛŎŜƴǎƛƴƎ ŀƴŘ wŜƎƛǎǘǊŀǘƛƻƴέ ǎŜŎǘƛƻƴ ƻŦ ǘƘŜ wŜŦƻǊƳ мн ¦ǎŜǊ 
Manual for more information on how to license Reform 12 Plug-ins.  After the license is 
entered, the Reform Spooler will need to be restarted to refresh the licenses. More 
information regarding the Reform Spooler Service can be found in the Reform 12 User 
Manual. 
 
CƻǊ tǊƛƴǘ vǳŜǳŜ aƻƴƛǘƻǊ ŀǇǇƭƛŎŀǘƛƻƴ ƭƛŎŜƴǎƛƴƎΣ ǇƭŜŀǎŜ ǎŜŜ ǘƘŜ ά[ƛŎŜƴǎƛƴg Print Queue 
aƻƴƛǘƻǊ όCŀōǎƻŦǘ [ƛŎŜƴǎŜ aŀƴŀƎŜǊύέ ǎŜŎǘƛƻƴ ƻƴ ǘƘƛǎ ƳŀƴǳŀƭΦ tŀƎŜ слΦ 

About the Analysis Reporting Tool 
The goal of the document is to allow the user to install the Reform Tracker and deploy 
the Tracker agents across their environment. The Tracker can run for 60 days at no cost, 
this will allow the user to understand their current printing and copying environment. 
Once the 60 days has expired the agents will stop working, at this point the user can 
purchase the license to continue the already installed Tracker system. 
 

Which Operating Systems are supported on client computers? 
The FabSoft packages in this installer utility current support Windows XP, Windows 
Vista, Windows 7, Windows Server 2003, and Windows Server 2008.  All editions of each 
prior mentioned operating system are suitable to receive a FabSoft package. 
 

Requirements 
Reform: http://www.fabsoft.com/Downloads/ReformEnt12/reformentweb.exe  

http://www.fabsoft.com/Downloads/ReformEnt12/reformentweb.exe
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Tracker: http://www.fabsoft.com/Downloads/ReformEnt12/Tracker/ReformTracker.exe  

MOST (optional): http://www.fabsoft.com/Downloads/ReformEnt12/most/most.exe  

 

Note: MOST is used to track copy usage on Ricoh MFPs and printers. 

 

Installation Method  
The most common installation method is to install Reform on a Windows server or 
dedicated workstation. This Reform computer can accept print jobs from a multitude of 
devices. Windows XP, Vista, 2003 or 2008 are acceptable OS to install as the main Reform 
Tracker server. 
 

Software Installation  
Install Reform ς use the link above to install Reform 
 
 
Register for a 60 day Evaluation key: 
Next, you must register Reform. We are going to be obtaining a 60-day evaluation key. Run 
the Spooler by going to {ǘŀǊǘҔtǊƻƎǊŀƳǎҔwŜŦƻǊƳΧҔ{ǇƻƻƭŜǊ. It will ask you to register your 
copy of Reform. Click the Evaluate button.  
 
Enter your email address, and then click Get New Evaluation Code. This will launch an 
Internet Explorer window in which will let you request a 60-day evaluation key to be 
emailed to you.  
Click the Submit button. If it says that an evaluation key has been mailed to you, check your 

email for a key to arrive. Then, in the Evaluation Registration window, paste the key from 

your email into the Activation Code box and click OK . You now have an unrestricted 60 

days use of the Reform product suite. 

 

 

Installation of Tracker  
 
Install Tracker ς use the link above to install Tracker select all the defaults 

 
Install Workstation Tracker Agents: 
Select Start\Reform\Reform_Tracker\Tracker Agent Installation Console to install 

Workstation Tracker. 

 

Select Workstation Tracker from the drop down and click Next.  
 

http://www.fabsoft.com/Downloads/ReformEnt12/Tracker/ReformTracker.exe
http://www.fabsoft.com/Downloads/ReformEnt12/most/most.exe
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On the Credentials tab populate the Username, Password, and the Domain.  NOTE: You 

must you an administrative account preferably the same account you use to run your 

services. Click on the Verify Credentials button and after verifying your credentials 

click Next to be taken to the Configuration tab.  
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On the Configuration tab specify the Boot Time Out, Process Time Out, Simultaneous 

Installations, and Operating Systems.  You can leave these as default settings. 
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Click on the Client Settings button to view your Workstation Tracker settings. These are 

the settings that will be pushed to individual workstation.  

 

Enter in your email address in the Evaluation Email section ï The email address that will 

be used to request an evaluation code for the software. Note: You will not receive an 

email at this address. The software will generate the code internally. Take the defaults for 

the rest of these settings. 

 

 

 
 

 

 

 

 

 

 

 



Reform Tracker                                                                                       12 

 

 

                                                                                                                                                                                                                                                           Reform Tracker 

On the Target Systems tab you can specify your workstations via LDAP query, CSV, or 

manually entering the Computerôs Name. Click on the LDAP Look up button to display 

your LDAP Structure.  You can select the group or sub group to display the list of the 

computers within the group. 
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All the computers will be selected on default, you can deselect by clicking on the 

checkbox.  For demo purposes only one of the workstations will be selected which is 

PrintServer1. 
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Click on the Get Status button to check the status of the package youôre trying to install 

in this case weôre checking for Tracker.  Youôll see in the Status column that Tracker is 

not installed on PrintServer1.  The coverage column displays how many printers are 

installed on the selected machine 0 means none of the 4 printers are being tracked. 
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Click on Next to be taken to the Begin Installations tab. Go to the Not Installed Tab to 

view the system that we want to install Tracker on.  Click on Install  to begin the 

installation.   
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Tracker is current being installed. 
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 You will be taken to the Results tab.  Within this tab you will see the following status 

tabs: Active, Successful, and Failed.  In the Successful tab you can see here we 

successfully deployed Tracker on PrintServer1. 

 

 
 

 

 

 
 
 
 
 
 
 
 



Reform Tracker                                                                                       18 

 

 

                                                                                                                                                                                                                                                           Reform Tracker 

Configuring Printer Queue Monitor Demonstration 
(Passive_Mode) 
.ȅ ŘŜŦŀǳƭǘΣ ǘƘŜ tǊƛƴǘŜǊ vǳŜǳŜ aƻƴƛǘƻǊ ŀǇǇƭƛŎŀǘƛƻƴ Ǌǳƴǎ ƘƛŘŘŜƴ ƛƴ ŀ ǳǎŜǊΩǎ ǎȅǎǘŜƳΦ  Lƴ 
order to access the graphical user interface, a command line parameter must be passed. 
The installation has created a shortcut that supplies this parameter.   
 

1. Go to Start > Programs > Reform > Reform_Tracker > Print Monitor Console 
 

 
 

2. The Printer Queue Monitor will now appear.  This is the graphical user interface of 
the Printer Queue Monitor service that would run in the background of a print 
server or on each client PC (depending on the printing environment).   
 

 
 

3. We first need to configure the Print Queue Monitor and specify which Printers we 
want to monitor. Go to File>Setup. 
 

 
 

4. Select the Printer you want to monitor. 
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5. Click the + button to add the printer to the list. 
 

 
 

6. After you have added all your devices, click the Next button. 
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7. IMPORTANT:   Make sure the ά{ŀǾŜ tǊƛƴǘŜŘ /ƻƴǘŜƴǘέ box is checked in the General 
{ŜǘǘƛƴƎǎΦ άSave Printed Contentέ ƛǎ ǊŜǉǳƛǊŜŘ ōȅ ǘƘŜ tǊƛƴǘŜǊ vǳŜǳŜ aƻƴƛǘƻǊ ƛƴ ƻǊŘŜǊ 
ǘƻ ƎŜƴŜǊŀǘŜ t5Cǎ ŀƴŘ 9ƳŀƛƭǎΦ .ȅ ŘŜŦŀǳƭǘΣ ǘƘŜ άRemove Print Jobέ ōƻȄ ƛǎ ŎƘŜŎƪŜŘ ŀǎ 
well.  It is recommended to keep this on as well.  All other settings should be kept as 
defaults.  Click Next. 
 

 
 
8. Set Notifiers Delay at 2000 and Notifiers retries at 100. Check the box that says Log 

Print Events to Windows Event Log.  
 

 
 
9. Leave Image Format as tif . Set the DPI at 200.  Click Finish. 
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10. The configuration of the Print Queue Monitor is complete.  Close the Printer Queue 
Monitor window. NOTE: The Print Queue Monitor console should not be open while 
the service is running as they will  conflict with each other. 

 
11. The Print Queue Monitor service can now be started and set to automatic since we 

have configured it.  Go to Control Panel>Administrative Tools>Services.  Right click 
on Print Queue Monitor> Start.  Depending on your environment, the service logon 
account may need to be changed in order for the Printer Queue Monitor to function 
properly.  
 

 
 

12. To change the service account for Print Queue Monitor, right click on it and go to 
Properties.   
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13. In the General tab, set the Startup type to Automatic. 

 

 
 

14. Go to the Log On tab.  Here you will need to specify which account to run the service 
as.  It is recommended to use a domain account with administrative access on the 
local computer.  Click OK.   
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You will need to restart the service after changing service accounts.  To do so, right click 
on the service and go to Restart or simply stop and start the service. 
 
15. For Passive Mode, the Reform Tracker Process (RM_TrackerProcess) must also be 

started and set to automatic startup.  It is also recommended to run this service as a 
domain account with administrative privileges on the local computer in order to 
successfully access your LDAP system.  

 

 
 
16. Follow the same steps as done with the Print_Queue_Monitor service (page 20.)  

 
17. To ensure that the Print Queue Monitor is monitoring the printer(s), we will send a 

test page to the printer.  Open up Printers and Faxes from the Control Panel.  Right 
click on a printer that is being monitored and go to Properties. 

 

 
 

18. Click the Print Test Page button to send a Windows generated test page to the 
printer and then click OK. 
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19. Once the print job has completed, you can check the reporting system to verify that 
it was tracked properly.  If you do not see your print job listed, please make sure the 
RM_TrackerProcess service is running. Note: If you notice inconsistent print job 
ƛƴŦƻǊƳŀǘƛƻƴΣ ǎǳŎƘ ŀǎ ƴƻǘ ōŜƛƴƎ ŀōƭŜ ǘƻ ƳƻǳǎŜ ƻǾŜǊ ƻƴ ǘƘŜ ά±ƛŜǿ 5ƻŎǳƳŜƴǘέ ƻǇǘƛƻƴ ƻǊ 
not getting the correct values for Black/White and Color pages, please see the 
ǘǊƻǳōƭŜǎƘƻƻǘƛƴƎ ǎŜŎǘƛƻƴ ǘƛǘƭŜŘ άwŜǎǘŀǊǘƛƴƎ ǘƘŜ ¢ǊŀŎƪƛƴƎ /ƻƳǇǳǘŜǊέΦ  
 



Reform Tracker                                                                                       25 

 

 

                                                                                                                                                                                                                                                           Reform Tracker 

Generating Reports 
The Tracker Reporting tool is used to view detailed information about the print jobs that 
are monitored by the Reform Tracker.  For our demonstration, we have sent a couple 
more jobs to the printer. 
 
Note: If web page does not open, be sure to have the ISS configured. (See Configure 
Web Reports section on page 70.) 
 
1.  Run Tracker Web Reports by going to 

Start>Program>ReformΧ>Reform_Tracker>Website for Reporting Tracker Usage. 
 

 
 

2. Step 1: Define Date Range.  This is the time period for which the report will retrieve 
data.  There are two ways to configure the date range: 

i. Select Manually Select Dates 
ii. Selecting one of the available predefined date ranges (Year to Date, 

Month to Date, etc) 
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3. Step 2: Select the filters. You can choose User, Location, MFPs. Click the drop down 
box for ¦ǎŜǊΩǎ bŀƳŜΦ  Here you will see all the users that have printed to a 
monitored printer.  Select a user from the list. 
 

 
 
 

4. Step 3: Pick Report Type. Notice that you will now have access to a list of various 
reports that can be displayed.  Use the drop drown box to select the Summary 
report from the list. 
 

 
 
5. Step 4: Pick Report: Depending on the Report Type, the Reports change in the 

second dropdown list. Pick Activity from the list that appears from selecting 
Summary. 
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6. Step 5: Retrieve Report.  Click the Generate Report button to access all the 

information related to the filters that were setup in the previous step. 

 

 
 
 

7. hƴ ǘƘŜ ǊƛƎƘǘ ƘŀƴŘ ǎƛŘŜ ƻŦ ȅƻǳǊ ǎŎǊŜŜƴΣ ȅƻǳ ǿƛƭƭ ǎŜŜ ŀ άwŜǇƻǊǘ ƛǎ ōŜƛƴƎ ƎŜƴŜǊŀǘŜŘέ 
message. 

 

 
8. ¢ƘŜ ǊŜǇƻǊǘ ǿƛƭƭ ƴƻǿ ŘƛǎǇƭŀȅ ǘƘŜ ǳǎŜǊΩǎ ǇǊinter usage.  It breaks up the print jobs into 

black and white Volume and Color Volume.   
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 Depending on the type of report you choose, the report will have one or more 
pages. 
 
9. To see more detailed usage for this user, change Select Report Type ŦǊƻƳ Ψ{ǳƳƳŀǊȅΩ 
ǘƻ Ψ¦ǎŜǊǎΩ and leave the report as overview. Click on Generate Report. 
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10. Locate the toolbar in the upper part of the page. You can see it has two pages. 

Choose the second page and you will see a detailed overview of each user  
 

 
 

11. You have completed the generating reports tutorial.  Please feel free to view some 
other reports from the report list.   
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Configuring Print Queue Monitor Demonstration (Active_Mode) 
Configuring the Print Queue Monitor for Active Mode should only be done once Passive 
Mode has been correctly configured. In addition to tracking print jobs, Active mode 
allows the Print Queue Monitor to interact with the user and redirect print jobs to other 
ŘŜǾƛŎŜǎ ƻǊ ǘƘŜƛǊ ŜƳŀƛƭ ŀŘŘǊŜǎǎΦ [ƛƳƛǘǎ ŀǊŜ ŎƻƴŦƛƎǳǊŜŘ ōŀǎŜŘ ƻƴ ǘƘŜ ǳǎŜǊΩǎ ǳǎŜǊƴŀƳŜ ƻǊ 
their Primary LDAP Group. To configure User/Group Limits or Printer Limits, please see 
the corresponding section in this user manual. 
 
1. To enable Active Mode, Go to Start > Programs > Reform > Reform_Tracker > 

Reform Tracker Printer Utility. 

 

 
2. On the menu, go to Edit > Tracker Settings. 

 

3. /ƘŀƴƎŜ ǘƘŜ ǎŜǘǘƛƴƎ tǊƛƴǘ ¢ǊŀŎƪŜǊ aƻŘŜ ǘƻ ά!ŎǘƛǾŜέ ŀƴŘ ŎƭƛŎk Save Settings 
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4. The PrintQueueMonitor service must be restarted for the setting change to take 
ŜŦŦŜŎǘΦ tƭŜŀǎŜ ǎŜŜ ǘƘŜ άwŜǎǘŀǊǘƛƴƎ ǘƘŜ {ŜǊǾƛŎŜǎ - tǊƛƴǘvǳŜǳŜaƻƴƛǘƻǊέ ǎŜŎǘƛƻƴ ƻŦ ǘƘŜ 
manual for more information. 

5. In order to interact with the PrintQueueMonitor, a client side application must be 
started.  Go to: wŜŦƻǊƳΧ\ Plugins\ Tracker\ ClientMonitor\ ClientFiles\  and run the 
TrackerInteractive_Monitor.exe. 

6. Now that Active mode is enabled, the next time a document is printed to a print 
driver that is being monitored, ǘƘŜ ǳǎŜǊΩǎ ƛƴŦƻǊƳŀǘƛƻƴ ŀƴŘ ŀǾŀƛƭŀōƭŜ ǇǊƛƴǘŜǊǎ ǿƛƭƭ ōŜ 
stored in the system with a default limit.   Try sending a 1 page print job (the default 
limit is 1 page) to a tracked printer in order to populate the available printers list 
(User or group limits should have been already configured by following the steps in 
the Configuring User/Group Limits section of this manual).  To configure the default 
printer limit, please see the corresponding section in this user manual.  

7. You can view current printing, user, and default limits by using the Reform Trakcer 
Printer Utility. Go to Start > Programs > Reform > Reform_Tracker > Reform Tracker 
Printer Utility .  Here you can view all the information that the PrintQueueMonitor is 
using to decide if a print job should be allowed or if it needs interaction with the 
ǳǎŜǊΦ  CƛǊǎǘ ƛǘ ŎƘŜŎƪǎ ǘƘŜ ǳǎŜǊΩǎ ƭƛƳƛǘǎ ǘƘŀǘ ŀǊŜ ŘŜŦƛƴŜŘ ƛƴ ǘƘŜ User Limits tab.  It then 
ŎƘŜŎƪǎ ǘƘŜ ǇǊƛƴǘŜǊΩǎ ƭƛƳƛǘǎ ǿƘƛŎƘ ŀǊŜ ŘŜŦƛƴŜŘ ƛƴ ǘƘŜ Printer Limits tab.  You can edit 
these values by doubling clicking in the appropriate color/black entries.   For more 
ƛƴŦƻǊƳŀǘƛƻƴ ŀōƻǳǘ tǊƛƴǘŜǊ [ƛƳƛǘǎΣ ǇƭŜŀǎŜ ǎŜŜ ǘƘŜ ǎŜŎǘƛƻƴ ǘƛǘƭŜŘ ά/ƻƴŦƛƎǳǊƛƴƎ 9ȄƛǎǘƛƴƎ 
tǊƛƴǘŜǊ [ƛƳƛǘǎέΦ  ¢ƻ ŎƻƴŦƛƎǳǊŜ 5ŜǾƛŎŜ /ƻǎǘǎΣ ǇƭŜŀǎŜ ǎŜŜ ǘƘŜ ǎŜŎǘƛƻƴ ǘƛǘƭŜŘ ά/ƻƴŦƛƎǳǊƛƴƎ 
5ŜǾƛŎŜ /ƻǎǘǎέΦ 

 

8. If the document that is being printed contains too many pages for the selected 
printer, but another printer can print the document, the user is prompted with the 
following dialog. The user can then redirect the print job to a printer that permits 
ǘƘŜ ŘƻŎǳƳŜƴǘΩǎ Ŏƻƭƻr and monochrome pages. It will also allow the user to re-route 
the printed document as a PDF to their email address as an alternative. Before the 
email ability can be used, it must first be configured with your SMTP server 
information. Please see the Configuring Emailing a Printed Document section of this 
user manual. 
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9. If the document that is being printed contains too many pages for any of the 
installed printers, the user is prompted with the following dialog. It will allow the 
user to re-route the printed document as a PDF to their email address. 

 
 

10. If the user has reached their limit, the following dialog will be displayed. It will allow 
the user to re-route the printed document as a PDF to their email address. 
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Configuring Emailing a Printed Document  
To configure emailing a printed document, the Reform Email Plug-in is required. In the 
wŜŦƻǊƳ ¢ǊŀŎƪŜǊ ƛƴǎǘŀƭƭŀǘƛƻƴΣ ŀ ŦƻǊƳ άtǊƛƴǘ¢ƻt5CΦŦƻƳέ ƛǎ ŎǊŜŀǘŜŘΦ ¢Ƙƛǎ ŦƻǊƳ ƛǎ ǳǎŜŘ ǘƻ 
redirect print jobs to an email address. This form must be configured with your email 
server information.  For more information on configuring the email plug-in, please see 
the Reform Email user manual. 
 
1. To configure the PrintToPDF form, we must first open the Reform Designer. To do 

this, go to Start > Programs > Reform > Designer 
2. On the menu, go to File > Open. 
3. Select the PrintToPDF.fom form. 
4. Along the far right side of the form, you will see several text objects. We must 

configure only a few fields to send the email. 
a) EmailServerName ς Name or IP of the SMTP Server. (For this application, 

only SMTP servers can be used.) 
b) EmailUserName ς Optional username for the SMTP server. 
c) EmailUserPassword ς Optional password for the SMTP server. 

5. ¢ƻ ŜŘƛǘ ŀ ŦƛŜƭŘΣ ǎŜƭŜŎǘ ƛǘ ƛƴ ǘƘŜ hōƧŜŎǘǎ ƭƛǎǘΦ ¢ƘŜƴ ŎƭƛŎƪ ǘƘŜ άΧέ ōǳǘǘƻƴ ƴŜȄǘ ǘƻ ǘƘŜ ¢ŜȄǘ 
property in thŜ ǇǊƻǇŜǊǘƛŜǎ ƭƛǎǘΦ 9ƴǘŜǊ ǘƘŜ ǾŀƭǳŜ ŦƻǊ ǘƘŜ ŦƛŜƭŘΣ ŀƴŘ ŎƭƛŎƪ άhYέ 
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6. Once the information is complete for each field, save the form by clicking File > Save. 

Configuring User/Group Limits 
¢ƘŜ ²ƻǊƪŦƭƻǿ 5ŜǎƛƎƴŜǊ ƛǎ ǳǎŜŘ ǘƻ ŎƻƴŦƛƎǳǊŜ ǘƘŜ ¦ǎŜǊǎΩ ŀƴŘ DǊƻǳǇǎΩ ƭƛƳƛts. 

1. To open it, go to Start>Programs>ReformΧ> Workflow Designer. 

2. Go to File>New>Document Restrictions and click Ok. 
 

 
 

3. You will now notice that your Inputs, Processes and Outputs have been populated. 
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4. We can now start adding the necessary components to the workflow.  First, drag 

and drop a User or Group object onto the workflow by clicking and holding your 

mouse on User or Group and then moving your mouse over to the workflow and 

releasing the mouse button.  

 

 
 

*You will be prompted with the following dialog. Here you can search for the user or 

group you want to configure limits for.  When searching, you can limit the results by 

entering a Username into the first field or you can leave it blank to show all users.  In 

the Domain field, type in the domain. Click Finish to begin the search 
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5. Your search results will display and we can now choose the group we want to 

configure. Select the User and click Finish. 

 
6. We will also specify that each user within this group will receive their own 

individual limit. Since users can be part of multiple groups, limits are configured 
ōŀǎŜŘ ƻƴ ǘƘŜ ǳǎŜǊΩǎ tǊƛƳŀǊȅ DǊƻǳǇ ǿƛǘƘƛƴ [5!tΦ /ƭƛŎƪ Next 

 

Individual Limits If Joe and Bill are in the Domain Users 
group. Each of them have their own 
limit.  If Joe scans, it will not reduce 
.ƛƭƭΩǎ ǊŜƳŀƛƴƛƴƎ ǎŎŀƴǎΦ ό9ŀŎƘ ǳǎŜǊ ƛƴ 
Domain Users has their own limit.) 

Non Individual Limits If Joe and Bill are in the Sales group. 
Their entire group has one limit.  If Joe 
ǎŎŀƴǎΣ ƛǘ ǿƛƭƭ ǊŜŘǳŎŜ .ƛƭƭΩǎ ǊŜƳŀƛƴƛƴƎ 
scans. (The entire Sales group has a 
single limit.) 
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7. Now you are will ŎƻƴŦƛƎǳǊŜ άUser or Group 1έΦ  It will automatically go to the 
configuration after you click Next on previous screen or, to do so, right click on the 
newly added object and select ά/ƻƴŦƛƎǳǊŀǘƛƻƴΧέ or simply double-click on it. 

 
8. Check on the Printing Restriction box and then click Next. 

 

 
 

9. Fill in the desired limits for Black and White pages and Color pages and click Next. 
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10. This is where you choose how often you will be resetting the copying limits (The 

RM_Tracker Automaǘƛƻƴ ǎŜǊǾƛŎŜ Ƴǳǎǘ ōŜ ǊǳƴƴƛƴƎΣ ǎŜŜ ǘƘŜ ά!ǳǘƻƳŀǘŜŘ wŜǇƻǊǘǎ ŀƴŘ 
[ƛƳƛǘǎ {ŜǊǾƛŎŜέ ǎŜŎǘƛƻƴ ƻŦ ǘƘƛǎ ƳŀƴǳŀƭύΦ  Lǘ ƛǎ ǊŜŎƻƳƳŜƴŘŜŘ ǘƻ ǎŜƭŜŎǘ ǘƘŜ ŦƛǊǎǘ Řŀȅ ƻŦ 
the current month if using the monthly limits approach.  This will ensure that when 
the next month arrives, limits will be reset automatically to their original values.  For 
example, if today was 1/15/2010, you would set the date to 1/1/2010.  On 
2/1/20010, the limits would be reset to their original values.  Click Finish. 

 

 
 

 

11. You have completed configuring your User or Group 1. Click Finish and the 
camptions will change from Red to Green and the text will show the Username.  
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12. No changes have been made to your system as of now.  You can still go back and 

make any necessary adjustments to any part of the workflow.  To save the 
configurations, the workflow must be executed.  This is done by clicking the 

άExecuteέ ōǳǘǘƻƴ  on the menu bar.   After execution, you will be 
notified about what has taken place.  Click OK. 

 

 
 

13. The system is now updated with the limits that you have configured. 

14. The workflow can be saved by going to File>Save for future reference and 
adjustments.  You may want to save it as the tutorial continues in the next section 
with adding the Report object. 

Configuring the SMTP Server 
 

1. To begin, drag and drop SMTP Server object somewhere underneath the User or 
Group (now called User) object.  
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2. ²Ŝ Ƴǳǎǘ ƴƻǿ ŎƻƴƴŜŎǘ ǘƘŜ άDomain Usersέ ƻōƧŜŎǘ ǘƻ ά{a¢t {ŜǊǾŜǊ мέ using the 
ŀǊǊƻǿ ŎƻƴƴŜŎǘƻǊΦ  {ŜƭŜŎǘ άAdd Connectorέ from the menu bar and then drag an 
arroǿ ŦǊƻƳ ǘƘŜ άDomain Usersέ ƻōƧŜŎǘ ǘƻ ά{a¢t {ŜǊǾŜǊ мέ object as shown below 

 
3. Now you are will ŎƻƴŦƛƎǳǊŜ άSMTP Server 1έΦ  To do so, right click on the newly 

added object and select ά/ƻƴŦƛƎǳǊŀǘƛƻƴΧέ or simply double-click on it 
 

 
4. Complete the required fields in the SMTP Server Setup. Then click Next. Check the 

Send a test email box if you wish to test before continuing.  
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5. Fill the send to box with an email you would like to test with. Click Next.  

 

 
 

6. It will say that the Setup is complete. Click Finish. A message will appear saying that 

the email was sent.  
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Configuring the Report Object (Optional) 
1. This tutorial continues the previously configured workflow consisting of a Domain 

Users input and Printing Restrictions process.  The Report output can also be 
added and configured to provide automated reporting (The RM_Tracker 
!ǳǘƻƳŀǘƛƻƴ ǎŜǊǾƛŎŜ Ƴǳǎǘ ōŜ ǊǳƴƴƛƴƎΣ ǎŜŜ ǘƘŜ ά!ǳǘƻƳŀǘŜŘ wŜǇƻǊǘǎ ŀƴŘ [ƛƳƛǘǎ 
{ŜǊǾƛŎŜέ ǎŜŎǘƛƻƴ ƻŦ ǘƘƛǎ Ƴŀƴǳŀƭ ŦƻǊ ƳƻǊŜ ƛƴŦƻǊƳŀǘƛƻƴύΦ  ¢ƻ ōŜƎƛƴΣ ŘǊŀƎ ŀƴŘ ŘǊƻǇ ŀ 
Report object somewhere underneath the Printing Restrictions 1 object. 

  

 
 



Reform Tracker                                                                                       43 

 

 

                                                                                                                                                                                                                                                           Reform Tracker 

2. ¸ƻǳ ŀǊŜ ƴƻǿ ǘŀƪŜƴ ōŀŎƪ ǘƻ ȅƻǳǊ ǿƻǊƪŦƭƻǿΦ  ²Ŝ Ƴǳǎǘ ƴƻǿ ŎƻƴƴŜŎǘ ǘƘŜ άSMTP 
Server 1έ ƻōƧŜŎǘ ǘƻ ά¢ǊŀŎƪŜǊ wŜǇƻǊǘ мέ ǳǎƛƴƎ ǘƘŜ ŀǊǊƻǿ ŎƻƴƴŜŎǘƻǊΦ  {ŜƭŜŎǘ άAdd 
Connectorέ from the menu bar and then drag an arrow froƳ ǘƘŜ άSMTP Server 1έ 
ƻōƧŜŎǘ ǘƻ ά¢ǊŀŎƪŜǊ wŜǇƻǊǘ мέ object as shown below.  

 
3. ¸ƻǳ ǿƛƭƭ ōŜ ǇǊƻƳǇǘŜŘ ǘƻ ŎƻƴŦƛƎǳǊŜ ǘƘŜ ά¢ǊŀŎƪŜǊ wŜǇƻǊǘ мέ ƻōƧŜŎǘΦ /ƭƛŎƪ Yes. If you 

select No, you can still double click on the ά²ŜŜƪƭȅ wŜǇƻǊǘ 1έ object or rightclick 
and select άConfigurationέ to configure it. 
 

 
 

4. The first thing we want to configure is the type of report that is going to be run.  

Use the browse button  to select a report.  Go to 
Programs\Reform\Plugins\Tracker\WebSite\Reports\Masters Users Overview.rdlc 
and click Open. 
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5. Use the drop down to select the time period the report should display.  Select 
Month to Date. 

 

 
 

6. Leave the output directory blank as it is optional.  Click Next.  
 

 
 
7. Now you can choose the starting date and frequency to generate and email your 

report. The Reform Automation service will check this date daily and decide 
whether a report should be generated or not.  If you want a report emailed the first 
time the service runs, set the start date to something over a week ago.  We also 
want this report emailed so we check On ǘƘŜ άEmail this reportέ ŎƘŜŎƪōƻȄΦ  /ƭƛŎƪ 
Next.    
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8. Enter a subject and body for your email. Click Next. 
 

 
 

9. You have completed configuring the Report object.  Click Finish. 
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10. All your objects have been configured and their captions should be green. 

 
 

11.  To save the configurations, the workflow must be executed (Everything 
configured in the other objects will overwrite any previously executed settings).  

¢Ƙƛǎ ƛǎ ŘƻƴŜ ōȅ ŎƭƛŎƪƛƴƎ ǘƘŜ άExecuteέ ōǳǘǘƻƴ  on the menu bar.   After 
execution, you will be notified about what has taken place.  Click OK. 

 

 

Configuring the Filter 
1. To begin, drag and drop the Filter object somewhere underneath the Report 

(now called Master Users Overview) object.  
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2. You must connect the Filter to the Report before configuring it. If you do not 
connect it before, when you double click it, a pop message will appear.  
 

 
 

3. Choose Add Connector from the options in the top and point the filter to the 
Report.  

 
4. Now you are will ŎƻƴŦƛƎǳǊŜ άFilter 1έΦ  To do so, right click on the newly added 

object and select ά/ƻƴŦƛƎǳǊŀǘƛƻƴΧέ or simply double-click on it. 
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5. For the demonstration, we will select the User Login Name as the filter. Click 

Finish 
 

 
 
6. Select the user name as the value to filter by. Click Finish 
 

 
 

7. All your objects have been configured and their captions should be green 
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8. To save the configurations, the workflow must be executed.  This is done by 

ŎƭƛŎƪƛƴƎ ǘƘŜ άExecuteέ ōǳǘǘƻƴ  on the menu bar.   After execution, 
you will be notified about what has taken place.  Click OK. 

 

 
 

9. Your settings have saved and all automated processes will be carried out as 
scheduled 

Automated Reports and Limits Service 
The Reform Tracker plugin allows you to configure an automated reporting system.  The 
RM_Tracker Automation service is in charge of generating and emailing these reports.  
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The service is installed by Reform Tracker and is set to start automatically.  It runs every 
6 hours and checks if there are any reports to be generated and/or limits to be reset. 
Using the Workflow Designer, you can configure an unlimited number of reports which 
are then generated and emailed out (if configured) by the service.  This service also 
allows you to automatically reset limits monthly, quarterly or yearly depending on the 
needs of your organization.  The schedule for resetting limits automatically is configured 
using the Workflow Designer as well.   
 
To ensure the service is running, go to Control Panel>Administrative Tools>Services 
and look for RM_Tracker Automation.  The startup type should be automatic and the 
status should say started.   
   

 
 

It is recommended that this service be run as a domain account with administrative 
privileges on the local computer. To do so, please follow the steps in the section titled 
άService Logon Accountέ ǳƴŘŜǊ Troubleshooting.  Those are steps for the 
PrintQueueMonitor Service but they can be applied to this service as well. 

Configuring Default Printer Limits 
1. To start the Printer Configuration Utility, go to Start > Programs > Reform > 

Reform_Tracker > Reform Tracker Printer Utility. 
2. Go to the Default Printer Limits tab. 
3. Here, you will see an entry where the Server name and Printer name are both 
ά5ŜŦŀǳƭǘέΦ  ¢Ƙƛǎ ŜƴǘǊȅ ƛǎ ǳǎŜŘ ǘƻ ŘŜǘŜǊƳƛƴŜ ǿƘŀǘ ƭƛƳƛǘǎ ƴŜǿ ǇǊƛƴǘŜǊǎ ǎƘƻǳƭŘ ƘŀǾŜ 
by default.  To change the values, simply click on the value you would like to 
ŎƘŀƴƎŜΣ ŀƴŘ ŜƴǘŜǊ ǘƘŜ ƴŜǿ ǾŀƭǳŜΦ tǊŜǎǎ ά9ƴǘŜǊέ ǘƻ ŎƻƴŦƛǊƳ ǘƘŜ ŎƘŀƴƎŜΦ ¢ƘŜ 
change is submitted to the database immediately. 
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Configuring Existing Printer Limits 
.ŜŦƻǊŜ ŎƻƴŦƛƎǳǊƛƴƎ ŀ ǇǊƛƴǘŜǊΩǎ ŎƻƭƻǊ ŀƴŘ Ƴƻnochrome limits, a user must print to a 
device. The first time a user prints their available printer drivers are inserted into the 
system automatically with a set of default limits.  Once they are added, the Printer 
Configuration Utility can be used to update the limits. 
 

1. To start the Printer Configuration Utility, go to Start > Programs > Reform > 
Reform_Tracker > Reform Tracker Printer Utility. 

 

 
 

2. To update a limit, simply click on the value you would like to change, and enter 
ǘƘŜ ƴŜǿ ǾŀƭǳŜΦ tǊŜǎǎ ά9ƴǘŜǊέ ǘƻ ŎƻƴŦƛǊƳ ǘƘŜ ŎƘŀƴƎŜΦ ¢ƘŜ ŎƘŀƴƎŜ ƛǎ ǎǳōƳƛǘǘŜŘ ǘƻ 
the database immediately. 
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Configuring Device Costs 
1. To start the Printer Configuration Utility, go to Start > Programs > Reform > 

Reform_Tracker > Reform Tracker Printer Utility. 
 

2. Go to the Device Costs tab. 
 

3. Here, you will see an entry for each printer that was printed to.  To change the 
cost values, simply click on the value you would like to change, and enter the 
ƴŜǿ ǾŀƭǳŜΦ tǊŜǎǎ ά9ƴǘŜǊέ ǘƻ ŎƻƴŦƛǊƳ ǘƘŜ ŎƘŀƴƎŜΦ ¢ƘŜ ŎƘŀƴƎŜ ƛǎ ǎǳōƳƛǘǘŜŘ ǘƻ ǘƘŜ 
database immediately. 
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Importing Tracker MOST Screen  
Please refer to the MOST manual for more information regarding MOST terminology, 
MOST Setup, and Connection Test. 

 
To import MOST screens for Reform Tracker, Go to Start > Programs > 
wŜŦƻǊƳΧҔwŜŦƻǊƳψ¢ǊŀŎƪŜǊ > Install MOST Screen 
 

 
 

If not already open, MOST Designer will appear.  You will be prompted if you want to 
Import Tracker into MOST.  Click Yes. If asked if you want to overwrite data, click Yes.  
 

 
 

You can leave MOST Designer open as it will be used in the following section. 
 

Configuring MFP to use Reform Tracker 
(Before attempting to configure the Reform Tracker, MOST should be setup and 
working.  It is also highly recommended that LDAP be enabled and working in the MOST 
Manager) 

1. Go to Start>Programs>ReŦƻǊƳΧ>MOST>Install to MFPs. 

 
 

2. Go to Edit>ah{¢ {ŜǘǘƛƴƎǎΧ Go to the Device tab and set Copy Counter = True, and 
check all the lock functions. Click Save. 
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a. ¢ƘŜ /ƻǇȅ /ƻǳƴǘŜǊ ǎŜǘǘƛƴƎ ŜƴŀōƭŜǎ ǘƘŜ aCt ǘƻ ƘŀǾŜ ŎƻƴǘǊƻƭ ƻǾŜǊ ǳǎŜǊǎΩ 
copying habits.  If set to TruŜΣ ȅƻǳ Ƴǳǎǘ ŜƴǘŜǊ ǘƘŜ aCtΩǎ ǳǎŜǊƴŀƳŜ ŀƴŘ 
password. The MFP Username and Password should be the same as the 
ŎǊŜŘŜƴǘƛŀƭǎ ǳǎŜŘ ǘƻ ƭƻƎ ƛƴǘƻ ǘƘŜ aCtΩǎ ²Ŝō LƳŀƎŜ aƻƴƛǘƻǊΦ  

b. The Lock Function settings allow you to lock down the MFP until a user logs 
in to MOST.  Each user that logs into MOST can have access to different 
functions such as copying, faxing, scanning and access to the document 
server.  By default, all users will be locked out of the functions that you 
select until the user or group is configured using the Workflow Designer. 

 

3. Now we need to update the settings by (re)installing MOST on the MFP. At the main 
MFP Control Center window you can enter a start and stop IP range to scan your 
network for MFPs.  If an MFP is found click Next. 

 
 

4. A window appears with two tabs: Installed and Not installed.  Depending on whether 
MOST has already been installed on the MFP it found, it will appear on the 
appropriate tab.   
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5. For the demonstration, we already have MOST installed on the MFP so we will be 

doing an Update.  Click on Update MOST to update MOST in the MFP with the new 
settings from the Control Center. (If you were installing MOST for the first on the 
MFP, you would need to click Install MOST from the Not Installed tab).  Once the 
MOST installation is complete, close the MFP Control Center.  You can now proceed 
with configuring the Reform Tracker.  

Licensing Print Queue Monitor (FabSoft License Manager) 
The FabSoft License Manager is used to license the Print Queue Monitor application and 
service.  When running Reform in evaluation mode, the FabSoft License Manager is not 
required.  
 
In order to license the Print Queue Monitor application, the FabSoft License Manager 
must be started.  To do so, navigate to:  wŜŦƻǊƳΧ\ Plugins\ ClientTools\  and run the 
application: ReformLicenseMgr.exe.   
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Here you would enter your Serial Number and Activation key for the FabSoft License 
aŀƴŀƎŜǊ ŀǎ ǿŜƭƭ ŀǎ ǘƘŜ tǊƛƴǘ vǳŜǳŜ aƻƴƛǘƻǊ !ŎǘƛǾŀǘƛƻƴ ƪŜȅΦ  tƭŜŀǎŜ ǎŜŜ ǘƘŜ άwŜŦƻǊƳ мн 
[ƛŎŜƴǎƛƴƎ ŀƴŘ wŜƎƛǎǘǊŀǘƛƻƴέ ǎŜŎǘƛƻƴ ƻŦ ǘƘŜ wŜŦƻǊƳ мн ¦ǎŜǊ Manual for more information 
on how to obtain license information.   
 
Verify Licenses button shows your activation key and how many licenses you have.  
 

 
 
After doing so, click the Restart Service button.  
 

 
 

 Then click the Recreate License File button. 
 

 
 
The $FabSoftLicMgr$.lct file will be saved in the wŜŦƻǊƳΧ\ Spooler\  directory.  A 
confirmation popup will appear.  Click OK. 
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¢ƘŜ Cŀō{ƻŦǘ [ƛŎŜƴǎŜ aŀƴŀƎŜǊ Ǌǳƴǎ ŀǎ ŀ ǎŜǊǾƛŎŜ ŎŀƭƭŜŘ Ψwaψ[ƛŎŜƴǎŜψ{ŜǊǾŜǊΩ ŀƴŘ ƛt is 
recommended to configure the service logon account with a domain account that has 
administrative privileges on the local computer.  To do so, go to Start > Control Panel > 
Administrative Tools > Services. Right click on the RM_License_Server service and go to 
properties.  Go to the Log On tab and set the service logon account.  You will have to 
restart the service after updating the credentials. 
 
After licensing the Print Queue Monitor in the FabSoft License Manager, the Print 
Queue Monitor on the Reform Server must be started in console mode where you can 
specify the location of the $FabSoftLicMgr$.lct file.  Go to Start > Programs > Reform > 
Reform_Tracker > Print Monitor Console.  /ƭƛŎƪ ǘƘŜ άSpecify the Network-Licensing 
CƛƭŜΧέ ōǳǘǘƻƴΦ   
 

 
 
You will be prompted that administrative rights are required to register the product.  
Click OK to continue. 
 

 
 

Use the browse button to navigate to wŜŦƻǊƳΧ\ Spooler\  and select the 
$FabSoftLicMgr$.lct file.  Verify the path and click OK.   
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The Print Queue Monitor will now start.  It should be run in console mode or as a 
service, but not both (see the Configuring Printer Queue Monitor Demonstration 
section). 
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Uninstalling Workstation Tracker 
To uninstall run the installer. 
 
Step through the wizard.  After reading the welcome message click Next  to go to the 
next screen and select the Fabsoft Package to install. 
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On the Credentials tab populate the Username, Password, and the Domain.  NOTE: You 

must you an administrative account preferably the same account you use to run your 

services. Click on the Verify Credentials button and after verifying your credentials 

click Next to be taken to the Configuration tab.  
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On the Configuration tab specify the Boot Time Out, Process Time Out, Simultaneous 

Installations, and Operating Systems.  You can leave most of the default settings. 
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On the Target Systems tab you can search your target systems via LDAP, CSV, or 

manually adding the system by entering the Computer Name. Click on the LDAP 

Lookup button to display your LDAP Directory.  You can select the group or sub group 

to display the list of the computers within the group. 
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All the computers will be selected on default, you can deselect by clicking on the 

checkbox.  For demo purposes only one of the workstations will be selected which is 

PrintServer1. 
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Click on the Get Status button to check the status of the package youôre trying to 

uninstall.  Youôll see in the Status column that Tracker is installed on PrintServer1.  The 

coverage column displays how many printers are installed on the selected machine 4/4 

means all of the 4 printers are being tracked. 
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Click on Next to be taken to the Begin Installations tab. Go to the Not Installed Tab to 

view the system that we want to install Tracker on.  Click on Uninstall  to begin the un-

installation.   
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You will be taken to the Results tab.  Within this tab you will see the following status 

tabs: Active, Successful, and Failed.  In the Successful tab you can see here we 

successfully uninstalled Tracker on PrintServer1. 
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Troubleshooting 

Keep Printed Documents 

1. For the Printer Queue Monitor to function, it must have control over the documents 
printed to the monitored printers.  It is important to verify that this option was 
correctly set on the print driver.  Open Printers and Faxes from the Control Panel.  
For each monitored printer, right click and select Properties.  
 

 
 

2. Dƻ ǘƻ ǘƘŜ !ŘǾŀƴŎŜŘ ǘŀōΦ  aŀƪŜ ǎǳǊŜ ǘƘŜ άKeep Printed Documentsέ ŎƘŜŎƪōƻȄ ƛǎ 
checked.  If not checked, please check it and try your print job again. 
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Service Logon Account 

1. Please go to Services in Administrative Tools (Control Panel) and make sure that 
the Print Queue Monitor service has the correct permissions entered for the logon 
account.  By default, the service account is setup as Network Service.  Depending 
on your environment, it may or may not have enough permission to function.   

 

 
 

2. It is recommended that this service be configured with a domain account that has 
administrative privileges on the local computer.  To do so, right click on the service 
and go to properties.  Go to the Log On tab and set the service logon account.  You 
will have to restart the service after doing so. 
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PDF Images of Print Jobs 

If you are having trouble viewing the PDF images of print jobs while using the Tracker 
Reporting tool or emails are not being sent, it is important to check that the Reform 
Spooler is running.   
Open the Reform Spooler by going to Start>Programs>ReformΧҔ{ǇƻƻƭŜǊΦ   
 

 
1. Make sure that the Print_Queue_Monitor and PrintToPDF forms are present in 

the forms list.  If it is not, refresh the Spooler using the refresh button in the 
menu bar.   

2. Make sure the service is started by checking the lower left hand corner. 
3. Make sure the service account has the appropriate permissions. 

 

Restarting the Services 

Print Queue Monitor 

 

1. Please go to Start > Control Panel > Administrative Tools > Services. 
2. CƛƴŘ ŀƴŘ ǎŜƭŜŎǘ άtǊƛƴǘ vǳŜǳŜ aƻƴƛǘƻǊέ ƛƴ ǘƘŜ ƭƛǎǘ ƻŦ ǎŜǊǾƛŎŜǎΦ  

 

 

3. /ƭƛŎƪ ǘƘŜ άwŜǎǘŀǊǘέ ōǳǘǘƻƴ ŀǘ ǘƘŜ ǘƻǇ ƻŦ ǘƘŜ {ŜǊǾƛŎŜǎ ǿƛƴŘƻǿΦ  
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LDAP Query Service 

 

1. This service is responsible for querying LDAP for user information such as email 
address, full name, and primary group.  When a client PC prints a document, the 
information is sent to the server, where this service runs the query, and returns the 
results. 

2. Please go to Start > Control Panel > Administrative Tools > Services. 
 

3. CƛƴŘ ŀƴŘ ǎŜƭŜŎǘ άwaψ¢ǊŀŎƪŜǊ[5!tέ ƛƴ ǘƘŜ ƭƛǎǘ ƻŦ ǎŜǊǾƛŎŜǎΦ  

4. /ƭƛŎƪ ǘƘŜ άwŜǎǘŀǊǘέ ōǳǘǘƻƴ ŀǘ ǘƘŜ ǘƻǇ ƻŦ ǘƘŜ {ŜǊǾƛŎŜǎ ǿƛƴŘƻǿΦ  
 

Restarting the Tracking Computer 

It may be necessary to restart the computer which is running the PrintQueueMonitor 
before attaining accurate print tracking results.  If you notice that the Reporting system 
does not allow you to view the printed documents and you are getting zero black/white 
pages and zero color pages, a restart of your computer will be required.   
 
After the computer has restarted, please verify that only the PrintQueueMonitor service 
or the PrintQueueMonitor console (not both) is running.  For Passive mode, verify that 
the RM_TrackerProcess service is also running.  For Active mode, please run the 
TrackerInteractive_Monitor.exe as stated in the Active Mode configuration tutorial.   
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Configure IIS 

 
IIS7 (Windows 7 and 2008) 

Using the Server Manager add the 2 Roles, Application Server and Web Server 

 
In the Application Server wizards select the Web Server (IIS) Support 

 
 
In the Web Server (IIS) Wizard select the following components 
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