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About the Laserfiche Plug-in 
The Laserfiche plug-in acts as a bridge between Reform and Laserfiche.  It allows you to 
archive documents processed by Reform to Laserfiche Repositories where your 
collection of documents can be shared. 
 
Reform Enterprise/PDC maximizes the integration with Laserfiche by enabling automatic 
delivery of document information from any operating system, application or device. 
Whether a document is being printed from the host, scanned in using an MFP or copier, 
or generated by a user from an application, Reform will capture the process, extract the 
text and intelligently archive it to Laserfiche. With Reform’s alternative input options, 
more of your valuable information can be effortlessly accessed and easily shared 
company-wide through Laserfiche. Reform can control directory locations as well as 
custom index information to simplify document retrieval. Fast and easy access to 
important information is an extremely vital resource, and Reform’s integration 
capabilities to Laserfiche let you obtain the most comprehensive document information 
archive to improve the workflow of your business operations. 
 

System Requirements 
 Reform 12 Enterprise or Reform 12 PDC  

 Laserfiche Plugin  

 For Evaluation and Demonstration: Windows XP, Windows 2003 Server, 
Windows Vista, Windows 7 or Windows 2008 Server (64 Bit Operating Systems are 
Supported) 

 For Production Systems: Windows 2003 Server or Windows 2008 Server (64 Bit 
Operating Systems are Supported) 

 Microsoft SQL Server (SQL Server Express will be automatically installed by the 
Laserfiche installer if it is not present on the current system)  

 Microsoft .NET Framework 2.0 (installed automatically if not present on the 
current system)  
 

All required Reform software downloads can be found at www.fabsoft.com >> 
Downloads section. 

 

Hardware Requirements 
 Production System Recommendation (These suggestions are only estimations. 

High load environments may require multiple servers, or additional hardware.) 
1. Pentium 4 Processor 

http://www.fabsoft.com/
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2. 4 GB RAM 
3. HDD Space 100 GB (Redundancy recommended) 
4. Battery Backup (UPS) 
5. Dedicated server, no other software products except for virus and 

security programs. 

 Minimum System Requirements for demonstration purposes only 
1. Pentium 4 Processor 
2. 2 GB RAM 
3. HDD Space 30 GB 

 
Hardware specifications depend greatly on the workload and throughput that is 
required.  Higher end processors and greater amounts of memory will increase the 
amount of information and data that Reform can process thus improving overall system 
throughput.  For load balancing or failover, multiple servers can also be used. (Note: A 
license for Reform and each plug-in is required for each server running the software.) 
Before obtaining the server that you plan on utilizing for Reform, please check the plug-
ins’ user manuals for System Requirements as well as they may require additional 
hardware.  For production systems, we also recommend redundant hard drives utilizing 
the mirroring features of RAID (Redundant Array of Independent Disks) to minimize data 
loss and expedite system recovery in the event of a hardware failure.  Battery backups 
are also suggested to maintain system uptime and reliability in case of power failures.     
 

 

Installation 
To install the Laserfiche Plug-in components, download and run the installer. 
 

 
Step through the prompts and accept the User License Agreement. The installation will 
begin.  Allow the installation to complete and then read on to the next section to learn 
how to set up the Laserfiche integration.  
 
The default installation directory for Reform 12 and its plugins is C:\Program 
Files\Reform…\.  If you have changed the path during the Reform installation routine, 
or if you are using a 64 bit operating system, please refer to the appropriate path 
instead of the default one referenced throughout this documentation.  
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Plugin Registration and Licensing 
When evaluating Reform 12, the plugins will also be in an evaluation mode for that 
period of time.  Once Reform has been purchased and licensed, the required plugins 
must also be licensed in order to continue functioning correctly.    
 

Please see the “Reform 12 Licensing and Registration” section of the Reform 12 User 
Manual for more information on how to license Reform 12 Plug-ins.  After the license is 
entered, the Reform Spooler will need to be restarted to refresh the licenses. More 
information regarding the Reform Spooler Service can be found in the Reform 12 User 
Manual. 
 

Sending Your First Document to Laserfiche 
After installing the Laserfiche plug-in, it is important to confirm that the Laserfiche 
Service is running. This can be accomplished by restarting the PC or by manually starting 
the service. For more information on starting it manually, please see the Starting 
Laserfiche Service section at the end of this manual.  
 

 

Very Important: 
You will need to have a Laserfiche server on the network you are connected to 
with a valid username and password. 
 

 
 

First, the Reform Designer must be started.  To open it, go to 

Start>Programs>Reform…>Designer. 

 

1. For the example, we will be creating a new form with an existing template. Go to 
File > New > New. Select the LASERFICHE.FTM and click OK. 
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2. When it asks if you would like to open a text file for designing, select No. 

 
3. Next, go to File>Save to save your form. Name it LaserficheInvoice.FOM 
 
4. You can now close the Reform Designer since we have our form which we will be 

using alongside the Workflow Designer to route the document. 

 

*Now that we have our form, we can begin to create the desired Laserfiche workflow 

using the Workflow Designer.  First, the Workflow Designer must be started.   

5. To open it, go to Start>Programs>Reform…>Workflow Designer. 

6. Once open, we must go to File > New… 

 

7. Select “Document Automation” and click Ok. 
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8. You will now notice that your Inputs, Processes and Outputs have been populated by 

the various plugins you have installed (Laserfiche being one of the Outputs) 
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9. Once open, we can start adding the necessary components to the workflow.  First, 

drag and drop a Form and File object onto the workflow by clicking and holding 

your mouse on Form and File and then moving your mouse over to the workflow 

and releasing the mouse button.  

 
 

*You will be prompted with the following dialog: 

 
 

10.   Type “Laserfiche Demo” and click Finish. 

 
 

11. Now we are ready to configure the “Laserfiche Demo” form and input file.  To do 
so, right click on the newly added object and select “Configuration…” or simply 
double-click it. 
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12. You are now presented with the Input Setup window.  First, we want to select the 
TextFile or data stream that our form will be using.  To do so, you can simply begin 
typing in the box, or you can browse to find it.  We want to select the 
LaserficheInvoice.out file.  Click the small folder icon to bring up a window which 
will let us choose that file.  Select the file and click Open.   

 

 
 

13. After choosing the text file, you are taken back to the Input Setup page so that you 
can now select a form.  Click the small folder icon to bring up a window which will 
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let us choose the desired LaserficheInvoice.FOM form file.  Select the FOM file and 
click Open.          

      

 
 

14. Now that you have both your Input Text File and Reform Form selected, the setup 
of Form and File is complete.  You can quickly double check that the correct files 
are selected and then click Finish.  

 



Reform To Laserfiche                                                                           11 

 

 

                                                                                                                                                                                                                                                                                                                              

Laserfiche 

 
 

15. You will also be prompted to add a page-break field to the forms.  At this point, we 
want to select No. 

 
16. To finish the Laserfiche workflow, we want to add a Laserfiche Output.  We use the 

same drag and drop procedure as with the “Form and File” (see step 9).  Take your 

mouse and drag the “Laserfiche” object from under Output onto the workflow 

somewhere below your Input.  You will be prompted with a dialog box, type 

“Laserfiche Upload” and click Finish. 

 

17. Once you click Finish, you are taken back to your workflow.  Your Laserfiche will 
have a Red Caption because it is not yet configured. To configure Laserfiche, you 
must first connect the Form and File object titled “Laserfiche Demo”.  To do so, 
first select the “Add Connector” button from the menu bar.  Next, drag your 
mouse from the small “x” underneath “Laserfiche Demo” to the small “x” above 
“Laserfiche Upload” as pictured below. When the connection is complete, the 
connecter will turn black (if red, connection has not been made correctly, try again) 
and the “Laserfiche Demo” caption will turn green. 
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18. Now we are ready to configure the “Laserfiche Upload” output.  Click Yes.   

 

 
 
19. Please enter your Laserfiche Server Address and then click Next.  You can also hit 

Skip and it will search your network for any Laserfiche server.  A sample server 
address is filled in below.  
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20. Enter a valid Username. Click Next.   
 

 
 

21. Enter a valid password and click on Next. 
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22. Enter the Port Number used by the Laserfiche server and click Next or you can press 
Skip.   
 

 
 

 
23. Click Yes.  This may take a few seconds to complete. 
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24. Enter a Filename.  Click Next. 

 

 
 

25. Select the server you would like to upload to from the list and Click Next. 
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26. Select the repository you would like to upload to from the list and Click Next. 

 
 
27. Select the Template you would like to upload to from the list and Click Next. 
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28. Select the Volume you would like to use from the list and Click Next. 

 

 
 

29. Select the Folder you would like to upload to from the list and Click Next. 
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*Note:  After doing so, the list of variable data for you to enter in the next few steps will 
vary depending on what fields are in the template that you selected above. 
 

 
30. Repeat Step 31 until you have entered or skipped all the fields that you are 

prompted to enter. 

 
31. Enter a value for DOCUMENT and click Next.  You may also click Skip and have 

nothing entered into the value. 
 
*Note:  Some values may not have a Skip button, those are required to be entered. 
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32. You have completing configuring your simple Laserfiche workflow.  Your 2 objects 
(“Laserfiche Demo” and “Laserfiche Upload”) should all be green meaning they 
have been successfully configured and the workflow is ready to be created. 

 
 

33. To make all the appropriate forms and changes, the workflow must be executed.  

This is accomplished by clicking the “Execute” button  on the menu bar.   
After execution, you will be notified about what has taken place.  Click OK. 
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34. You can now close the Workflow Designer. Your form has been saved in your 

default forms directory.  A backup of your original LaserficheInvoice.FOM file has 
been copied to the “Workflow Designer Original Forms” folder in your forms 
directory.  Any permanent form changes should be made to this original form as 
it is used throughout the form configuration process as a template. If changes are 
made to this template, you will have to execute your workflow again to see the 
changes in the forms. 

 

 
35. To test your settings and make sure that files can be uploaded, first we should open 

the form with the Reform Designer.  Navigate to your Forms directory and double 
click LaserficheInvoice.FOM.  When asked to open the associated TextFile, click Yes. 
Verify that the special fields exist on the right hand side of your form.  
 

Note: make sure that Laserfiche Service is running. For more information please see the 
Starting Laserfiche Service section at the end of this document to start it manually. 
 
36. Go to File>Print in the Designer to send the document to Laserfiche. 
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37.  Log into your Laserfiche account and check to see if the document was sent there. 

 
Maintenance 
There are certain directories and SQL tables that need to be monitored for growth along 
with the Laserfiche plugin for Reform 12.  As a system processes more and more jobs, 
the size of these directories and SQL tables can grow very quickly.  Overall system 
performance can be affected by the large amounts of space that the files may take up.  
Also, there exists a 4GB database limit if using the Microsoft SQL Server Express 2005 
supplied with this installation. Obsolete files/database entries should be deleted 
according to your needs and file retention specifications.  It is recommended to monitor 
the following directories and SQL tables for growth: 
 
Directories: 
C:\Program Files\Reform…\Backups 
C:\Program Files\Reform…\Spooler\ImageQueue 
C:\Program Files\Reform…\Plugins\Laserfiche\Uploads 
 
SQL Tables: 
Reform_Laserfiche_Trans 
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Starting Laserfiche Service 
Go to Start > Programs > Control Panel > Administrative Tools > Services 
Right click on RM_Laserfiche_process > Properties. Under Service status click on Start. 
 

 
 

This service acts as a liaison between Reform 12 and Laserfiche.  It allows for Reform to 
upload documents and their properties to the Laserfiche server.   
 

Troubleshooting 
Q: Nothing is happening after the form is processed. How can I determine the cause of 
an issue? 
A: Check the Event Log for errors related to Reform or the Laserfiche service.  The Event 
Log can be access by going to Control Panel > Administrative Tools > Event Log.   This will 
usually give you a good idea about why the Laserfiche plugin might be failing.   
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