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Sobre el Plug-in Laserfiche  
El plug-in de Laserfiche actúa como un puente entre Reform y Laserfiche.  Permite 
archivar documentos procesados por Reform a Repositorios Laserfiche donde se puede 
compartir su colección de documentos.. 
 
Reform Enterprise/PDC maximiza la integración con Laserfiche por permitir la entrega 
automática de información del documento de cualquier sistema operativo, aplicaciones 
o dispositivos. Si se está imprimiendo un documento desde el host, analizado con un 
MFP o copiadora o generado por un usuario de una aplicación, Reform capturara el 
proceso, extraerá el texto y lo archivara inteligentemente a Laserfiche. Con opciones de 
entrada alternativas de Reform más de la información valiosa puede ser accedida sin 
esfuerzo y compartiendo fácilmente a  toda la empresa a través de Laserfiche. Reform 
puede controlar ubicaciones de directorio, así como información de índice 
personalizado para simplificar la recuperación de documentos. Acceso rápido y fácil a 
información importante es un recurso vital y capacidades de integración de Reform para 
Laserfiche permiten obtener el almacenamiento de información de documento más 
amplio para mejorar el flujo de trabajo de las operaciones del negocio. 

 
Requisitos del Sistema 

 Reform 12 Enterprise o Reform 12 PDC  

 Plugin Laserfiche 

 Para evaluación y demostración: Windows XP, Windows 2003 Server, Windows 
Vista, Windows 7 o Windows Server 2008 (se admiten los sistemas operativos de 64 
bits) 

 Para los sistemas de producción: Windows Server 2003 o Windows Server 2008 
(sistemas operativos de 64 bits son compatibles) 

 Microsoft SQL Server (SQL Server Express se instalará automáticamente por el 
programa de instalación de correo electrónico si no está presente en el sistema actual) 

 Microsoft.NET Framework 2.0 (descargará e instalará automáticamente si no 
está ya presente en el sistema actual) 

 
Todas las descargas de software Reform necesario pueden encontrarse en 
www.fabsoft.com >> Sección de descargas. 

 

Requisitos del Hardware 

 Recomendación de sistema de producción (estas sugerencias son sólo 
estimaciones. Entornos de alta carga pueden requerir varios servidores o hardware 
adicional.) 

1. Procesador Pentium 4 

http://www.fabsoft.com/
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2. 4 GB RAM 
3. HDD Space 100 GB (Redundancia recomendada) 
4. Respaldo de Batería (UPS) 
5. Servidor dedicado, no hay otros productos de software excepto 

para los programas de antivirus y seguridad. 

 Requisitos mínimos del sistema sólo con fines de demostración 
1. Procesador Pentium 4 
2. 2 GB RAM 
3. Espacio HDD 30 GB 

 
Especificaciones de hardware dependen enormemente de la carga de trabajo y el 
rendimiento que se requiere.  Procesadores de gama superiores y una mayor cantidad 
de memoria aumentará la cantidad de información y datos que Reform puede procesar, 
mejorando el rendimiento general del sistema.  Para equilibrio de carga y failover, 
también pueden utilizar varios servidores. (Nota: se requiere para cada servidor que 
ejecuta el software de una licencia para Reform y cada complemento.) Antes de obtener 
el servidor que desea utilizar para Reform, compruebe los manuales de usuario de los 
plug-ins para requisitos del sistema, así como pueden requerir hardware adicional. Para 
sistemas de producción, se recomiendan también discos duros redundantes utilizando 
las características de espejo de RAID (Redundant Array of Independent Disks) para 
minimizar la pérdida de datos y acelerar la recuperación del sistema en caso de una falla 
de hardware. También se sugieren respaldos de batería para mantener la disponibilidad 
del sistema y fiabilidad en caso de fallo de electricidad.     
 

 

Instalación 
Para instalar los componentes Plug-in de Laserfiche, descargue y ejecute el instalador. 
 

 
Siga paso a paso a través de los mensajes y acepte el acuerdo de licencia de usuario. 
Comenzará la instalación. Permita que la instalación se complete y después vaya a la 
siguiente sección  para aprender a configurar la integración Laserfiche.  
 
El directorio de instalación predeterminado para Reform 12 y sus Plugins es 
C:\Program Files\Reform…\.  Si ha cambiado la ruta durante la rutina de instalación 
Reform, o si utiliza un sistema operativo de 64 bits, consulte la ruta adecuada en lugar 
del predeterminado al que hace referencia a lo largo de esta documentación.  
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Plugin de Registro y Licencia 
Al evaluar Reform 12, los Plugins también estarán en un modo de evaluación para ese 
período de tiempo.  Una vez que Reform ha sido comprado y con licencia, los Plugins 
necesarios deben estar licenciados para continuar funcionando correctamente.    
 
Consulte la sección "Reform 12 licencias y registro” en el Manual de Usuario Reform 12 
para más información acerca de cómo poner licencias a los Plugins  de Reform 12.  
Después de introducir la licencia, el Reform Spooler deberá reiniciarse para actualizar las 
licencias. Puede encontrarse más información sobre el servicio Reform Spooler en el 
Manual de usuario Reform 12. 
 

Enviando su primer document a Laserfiche 
Después de instalar el Plug-in Laserfiche, es importante confirmar que se está 
ejecutando el servicio de Laserfiche. Esto puede lograrse reiniciando el PC o iniciando 
manualmente el servicio. Para obtener más información sobre iniciarlo manualmente, 
consulte la sección Starting Laserfiche Service al final de este manual.  
 

 

Muy Importante: 
Necesita tener un servidor de Laserfiche en la red que está conectado con un nombre de 
usuario válido y una contraseña. 

 
En primer lugar, debe iniciarse el Reform Designer.  Para abrirlo, ir a Start> Programs> 

Reform…> Designer. 

 

1. Para el ejemplo, estamos creando un nuevo formulario con una plantilla existente. Ir 
a File > New > New. Seleccione LASERFICHE.FTM y haga click en OK. 

 

 
 
2. Cuando le pregunta si desea abrir un archivo de texto para el diseño, seleccione No. 

 
3. Después, ir a File>Save para guardar su formulario. Llámelo LaserficheInvoice.FOM 
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4. Usted ahora puede cerrar el Reform Designer ya que tenemos nuestro formulario 
que va a utilizar junto con el Workflow Designer para distribuir el documento. 
 

* Ahora que tenemos nuestro formulario, podemos empezar a crear el flujo de trabajo 

Laserfiche usando el Workflow Designer.  En primer lugar, debe iniciarse el Workflow 

Designer.   

5. Para abrirlo, ir a Start>Programs>Reform…>Workflow Designer. 

6. Una vez abierto, debemos ir a File > New… 

 

7. Seleccionar “Document Automation” y haga click en Ok. 

 
 

8. Ahora verá que sus entradas, procesos y salidas han sido pobladas por varios plug-

ins que han sido instalados (DocumentMall siendo uno de los procesos) 
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9. Podemos empezar a agregar los componentes necesarios para el flujo de trabajo. 

En primer lugar, arrastrar y soltar un objeto Form and File en el flujo de trabajo 

haciendo click y sosteniendo el mouse en Form and File, a continuación, mover el 

mouse sobre el flujo de trabajo y soltar el botón del mouse.  

 

 
 

* Aparecerá el siguiente cuadro de diálogo: 
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10.   Escriba “Laserfiche Demo” y haga click en Finish. 

 

11. Ahora estamos listos para configurar el formulario de “Laserfiche Demo” y el 
archivo de entrada.  Para ello, haga click derecho en el objeto recién agregado y 
seleccione  “Configuration…” o simplemente haga doble click en el. 

 

 
 

12. Ahora aparecerá la ventana Configuración de entrada.  En primer lugar, queremos 
que seleccione la secuencia de datos o archivo de texto que va a utilizar nuestro 
formulario.  Para ello, simplemente puede empezar a escribir en el cuadro o puede 
navegar hasta encontrarlo.  Queremos que seleccione el archivo 
LaserficheInvoice.out.  Haga click en el icono de carpeta pequeña para abrir una 
ventana que nos permite escoger ese archivo.  Seleccione el archivo y haga click en 
Open.   
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13. Después de seleccionar el archivo de texto, volverá a la página de configuración de 
entrada para que ahora puede seleccionar un formulario.  Haga click en el icono de 
carpeta pequeña para abrir una ventana que nos permite escoger el archivo 
deseado, el formulario LaserficheInvoice.FOM.  Seleccione el archivo y haga click 
en Open.          
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14. Ahora que tiene el archivo de texto de entrada y la reforma de formulario 
seleccionado, la instalación de “Form and File” está completa.  Puede comprobar 
rápidamente que los archivos correctos fueron seleccionados y, a continuación, 
haga click en Finish.  

 

 
 

15. También se pedirá que agregar un campo de salto de página a los formularios. En 
este punto, queremos seleccionar No. 

 
16. Para finalizar el flujo de trabajo Laserfiche, queremos agregar un proceso Laserfiche.  

Usamos el mismo proceso arrastrar y colocar como con el “Form and File” (ver paso 

9). Tomar el mouse y arrastre el objeto “Laserfiche” bajo proceso de flujo de trabajo 

en algún lugar debajo de la entrada.  Aparecerá un cuadro de dialogo, escriba 

“Laserfiche Upload” y haga click en Finish. 

 

17. Una vez que haga click en finalizar, volverá a su flujo de trabajo. Laserfiche tendrá 
un título Rojo porque no se ha configurado aun. Para configurar Laserfiche, 
primero debe conectar el objeto Form and File llamado “Laserfiche Demo”.  Para 
ello, seleccione primero el botón “Add Connector” de la barra de menús. A 
continuación, arrastre el mouse de la pequeña “x” debajo de “Laserfiche Demo” 
hacia la pequeña “x” encima de “Laserfiche Upload” como muestra la imagen a 
continuación. Cuando se completa la conexión, el conector se volverá negro (si es 
roja, la conexión no se ha realizado correctamente, inténtelo de nuevo) y el título 
de “Laserfiche Demo” cambiará a verde. 
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18. Ahora estamos listos para configurar el proceso “Laserfiche Upload”. Haga click en 
Yes.   

 
 
19. Por favor, introduzca su dirección de servidor de Laserfiche y, a continuación, haga 

click en Next.  También puede presionar en Skip y buscará la red para cualquier 
servidor Laserfiche. La dirección de un servidor de ejemplo se rellena a continuación. 
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20. Ingrese un nombre de Usuario válido. Haga click en Next.   
 

 
 

21. Ingrese una contraseña valida y haga click en Next. 
 

 
 

22. Escriba el número de puerto utilizado por el servidor de Laserfiche y haga click en 
Next o puede presionar Skip.   
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23. Haga click en Yes.  Esta operación puede tardar unos segundos para completar. 
 

 
 

24. Ingrese un nombre de Archivo.  Haga click en Next. 
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25. Seleccione el servidor que desea cargar en la lista y haga click en Next. 
 

 
 
26. Seleccione el repositorio al cual le gustaría cargar de la lista y haga click en Next. 

 

 
 
27. Seleccione la plantilla a la cual le gustaría cargar de la lista y haga click en Next. 
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28. Seleccione el volumen que desea utilizar de la lista y haga click en Next. 

 

 
 

29. Seleccione la carpeta a la cual le gustaría cargar de la lista y haga click en Next. 
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*Nota: Después de hacerlo, la lista de datos variables para escribir en los próximos 
pasos variará en función de lo que los campos están en la plantilla que ha seleccionado 
anteriormente 

 
30. Repita el paso 31 hasta que haya introducido o saltado todos los campos que se le 

pedirá que introduzca. 
 

31. Introduzca un valor para el DOCUMENTO y haga click en Next.  También puede 
hacer click en Skip y así no introducir ningún valor. 

 
*Nota:  Algunos valores pueden no tener el botón Skip, esos requieren ser ingresados. 
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32. Ha completado la configuración del flujo de trabajo simple de Laserfiche.  Sus 2 
objetos (“Laserfiche Demo” y “Laserfiche Upload”) deben estar verdes lo cual 
significa que se han configurado correctamente y está listo para crear el flujo de 
trabajo. 

 
 

33. Para hacer todos los formularios y cambios adecuados, se debe ejecutar el flujo de 

trabajo.  Para ello, haga click en el botón “Ejecutar”  en la barra de 
menús. Después de la ejecución, se le notificará acerca de lo que ha llevado a cabo. 
Haga click en OK. 

 

 
 

34. Ahora puede cerrar el Workflow Designer. El formulario se ha guardado en el 
directorio de formulario predeterminado.  Un respaldo de su archivo original 
LaserficheInvoice.FOM ha sido copiado a su carpeta “Workflow Designer Original 
Forms” en su directorio de formularios.  Se efectuarán los cambios de forma 
permanente a su formulario original ya que se utiliza en todo el proceso de 
configuración de formulario como una plantilla.  Si se realizan cambios en esta 
plantilla, tendrá que ejecutar el flujo de trabajo para ver los cambios en los 
formularios. 

 
35. To Para probar la configuración y asegurarse de que se pueden cargar archivos, 

primero debemos abrir el formulario con el Reform Designer.  Navegue hasta el 
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directorio de Formularios y haga doble click en LaserficheInvoice.FOM.  Cuando se 
le pregunte si desea abrir el archivo de texto asociado, haga click en Yes. Compruebe 
que los campos especiales existen en el lado derecho del formulario. 

 
Nota: Asegúrese que su servicio Laserfiche se está ejecutando. Para obtener más 
información, consulte la sección Starting Laserfiche Service al final de este documento 
para iniciarlo manualmente. 
 
36. Ir a File>Print en el diseñador para enviar un documento a Laserfiche. 

 
 
37.  Inicie sesión en su cuenta de Laserfiche y compruebe si el documento fue enviado. 

 
Mantenimiento 
Hay ciertos directorios y tablas SQL que deben controlarse para crecimiento, junto con 
el plugin Email para Reform 12.  Cada vez que un sistema procesa más y más trabajos, el 
tamaño de estos directorios y tablas SQL puede crecer muy rápidamente. En general el 
rendimiento del sistema puede verse afectado por la gran cantidad de espacio que 
pueden ocupar los archivos.  Además, existe un límite de base de datos de 4 GB si utiliza 
Microsoft SQL Server Express 2005 suministrado con la instalación. Entradas obsoletas 
archivos/base de datos se deben eliminar de acuerdo a sus necesidades y 
especificaciones de retención de archivos. Se recomienda monitorear el crecimiento de 
los siguientes directorios y tablas SQL: 
 
Directorios: 
C:\Program Files\Reform…\Backups 
C:\Program Files\Reform…\Spooler\ImageQueue 
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C:\Program Files\Reform…\Plugins\Laserfiche\Uploads 
 
Tablas SQL: 
Reform_Laserfiche_Trans 
 
Iniciando el Servicio Laserfiche 
Ir a Start > Programs > Control Panel > Administrative Tools > Services 
Haga click derecho en RM_Laserfiche_process > Properties. Bajo Service status, haga 
click en Start. 
 

 
 

Este servicio actúa como un enlace entre Reform 12 y Laserfiche.  Permite a Reform 
cargar documentos y sus propiedades en el servidor de Laserfiche.   
 

Solución de Problemas 
Q: Nada sucede después de que el formulario es procesado. Cómo puedo determinar la 
causa de un problema? 
A: Busque errores en el Registro de Eventos relacionados a Reform o el servicio 
Laserfiche.  Se puede ingresar al Registro de Eventos yendo a Control Panel > 
Administrative Tools > Event Log.   Esto usualmente le dará una buena idea acerca de 
por qué el plugin Laserfiche podría estar fallando.   
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